Lost mp3 format in Sound Juicer

Asked by smgreg on 2008-09-26

I have lost access to the mp3 ripping format in Sound Juicer after I initially had it working.

After running the sudo apt-get install ubuntu-restricted-extras command and getting Sound Juicer to rip CDs to mp3, I started experimenting with creating some additional mp3 profiles with different GStreamer pipeline values, so that I could do listening comparisons of various fixed bit rates. Somewhere in this process, the ripping format reverted back to AAC and I lost the mp3 format option from the Output Format list in Sound Juicer. The mp3 profiles are all still visible in the Edit Profiles screen, but I can't make them show up in Sound Juicer.

I have tried re-running the sudo apt-get install ubuntu-restricted-extras command, but it does not help. I have also tried uninstalling and re-installing Sound Juicer. Also does not work.

Any ideas? I am running Sound Juicer 2.22.0 in Ubuntu 8.04

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sound-juicer Edit question
Assignee:
No assignee Edit question
Solved by:
smgreg
Solved:
2008-10-02
Last query:
2008-10-02
Last reply:
2008-09-28
Tobias Wolf (towolf) said : #1

Run this:

gst-inspect-0.10 | grep mp3

does it list an mp3 decoder?

smgreg (smgreg) said : #2

I ran the gst-inspect-0.10 | grep mp3 command and it returned the following:

lame: lame: L.A.M.E. mp3 encoder
ffmpeg: ffdemux_mp3: FFMPEG MPEG audio demuxer
ffmpeg: ffdec_mp3on4: FFMPEG MP3ON4 decoder
ffmpeg: ffdec_mp3adu: FFMPEG ADU-formatted MPEG-1 layer 3 audio decoder
ffmpeg: ffdec_mp3: FFMPEG MPEG-1 layer 3 audio decoder
mpegaudioparse: mp3parse: MPEG1 Audio Parser
mad: mad: mad mp3 decoder
typefindfunctions: application/x-id3v2: mp3, mp2, mp1, mpga, ogg, flac, tta
typefindfunctions: application/x-id3v1: mp3, mp2, mp1, mpga, ogg, flac, tta
typefindfunctions: audio/mpeg: mp3, mp2, mp1, mpga

I count 4 mp3 decoders in that list. Still no mp3 output format available in Sound Juicer.

smgreg (smgreg) said : #3

I did some more research and then edited the GStreamer Pipeline for mp3 as follows:

audio/x-raw-int,rate=44100,channels=2 ! lame name=enc mode=1 vbr=4 vbr-min-bitrate=32 vbr-max-bitrate=320 vbr-quality=3 ! id3v2mux

After saving and restarting Sound Juicer, the mp3 output format had miraculously reappeared. I'm not sure what I did right this time, that I wasn't doing right before (I am new to Linux), but the problem is fixed.

Greg

akhenaton (aky-home) said : #4

@smgreg: well.. modified the mp3 profile like you said you did and then restarted Sound Juicer but still to no avail
i'm not able to rip an audio cd in mp3 format using Sound Juicer [from Intrepid Ibex]
any other hints?

akhenaton (aky-home) said : #5

ok, it seems after (re)installing gstreamer0.10-plugins-ugly-multiverse (0.10.7-2) the problem is gone
i'm now able to rip audio cds in mp3

smgreg (smgreg) said : #6

Glad to hear you sorted this out. As you could probably tell, I was
basically blundering around in the dark with this problem until it
miraculously was fixed. Sound Juicer is a mysterious applicaiton.

gs.

On Fri, Dec 5, 2008 at 9:49 AM, akhenaton <
<email address hidden>> wrote:

> Your question #46360 on sound-juicer in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/sound-juicer/+question/46360
>
> akhenaton posted a new comment:
> ok, it seems after (re)installing gstreamer0.10-plugins-ugly-multiverse
> (0.10.7-2) the problem is gone
> i'm now able to rip audio cds in mp3
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>