Adobe Flash asks for update to watch youtube movies

Asked by Eddy Van Hemelrijck on 2014-12-27

Adobe Flash asks for update to watch youtube movies - How do I install an update in Ubuntu?
Thanks for your help.
Eddy

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Last query:
2014-12-27
Last reply:
2015-01-02

What is the full Terminal output of the following command?

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark|restricted'

Eddy Van Hemelrijck (eddy-i) said : #2

Dear Mark, I have no idea where and how I have to find what you ask for. Ubuntu is runting for years on my harddesk PC but I am not a specialist at all. I can check the Ubunt software center which says to me that I have flashplugin-installer 11.2.202.310ubuntu0.12.04.1 properly installed and till a week ago I could watch youtube movies without problem but now I get the error code that I need an update of adobe flash. I downloaded it but I have no idea how to install it. I am not famliar at all with Ubuntu software ... any suggestions?

If you are using the Gnome interface, open the Terminal console via "Applications->Accessories->Terminal"

If you are using the Unity interface (default graphical user interface in Ubuntu), use the 'search' function on the dash. Or you can click on the 'More Apps' button, click on the 'See more results' by the installed section, and find it in that list of applications. A third way, available after you click on the 'More Apps' button, is to go to the search bar, and see that the far right end of it says 'All Applications'. You then click on that, and you'll see the full list. Then you can go to Accessories > Terminal after that.

So the methods in Unity are:

Press CTRL-ALT-T key combination.

Dash > Search for Terminal

Dash > More Apps > 'See More Results' > Terminal

Dash > More Apps > Accessories > Terminal

If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the following diagnostic command:

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark|restricted'

Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

Then copy-paste the output of that command into the following thread:

https://answers.launchpad.net/ubuntu/+source/software-center/+question/259739

I am NOT asking you to be an Ubuntu expert, but to simply copy-paste a Terminal command and send the output.....

Eddy Van Hemelrijck (eddy-i) said : #4

Sorry Mark, appreciating your help a lot.
This is the output:
Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise
Linux Maror-SC-ASUS 3.2.0-53-lowlatency #55-Ubuntu SMP PREEMPT Mon Aug 26 22:30:31 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
ii flashplugin-installer 11.2.202.310ubuntu0.12.04.1 Adobe Flash Player plugin installer
ii ubuntu-restricted-addons 12 Commonly used restricted packages for Ubuntu
ii ubuntu-restricted-extras 57 Commonly used restricted packages for Ubuntu

Does this help? What do I have to do next?

Copy-paste these Terminal commands one by one into the Terminal:

cd $HOME
rm *.deb
wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
sudo dpkg -i google-chrome*.deb
# fix the Google Chrome dependencies issue
sudo DEBIAN_FRONTEND=noninteractive apt-get --yes --force-yes -f install

Then run Google Chrome which contains the newest version of Adobe Flash plugin.

Eddy Van Hemelrijck (eddy-i) said : #6

Dear Mark,

Any idea how we can solve this in Firefox as we are using this browser in stead of google chrome...
Thanks!
Eddy

Eddy Van Hemelrijck (eddy-i) said : #7

In google-chrome we had no problems in opening youtube movies - or should we just all the time use google chrome instead of Firefox?

Manfred Hampl (m-hampl) said : #8

See http://www.adobe.com/software/flash/about/

Adobe does not provide a flash player higher than 11.2.202 for Linux with Firefox. If you need a highe version, then the only chance you have is using chrome.

Can you help with this problem?

Provide an answer of your own, or ask Eddy Van Hemelrijck for more information if necessary.

To post a message you must log in.