Scanner not working

Asked by wordsmyth2 on 2013-12-20

I have installed an HP2510 All-in-one and it works fine as a printer, but it's not recognised as a scanner: NO SCANNER FOUND etc.
I've had no problems with a previous installation with the same printer/scanner/copier, and am wondering what the problem is. Please advise... someone? (Acer Aspire E1-531/Ubuntu 12.04)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu simple-scan Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2013-12-21
Last query:
2013-12-21
Last reply:
2013-12-20
wordsmyth2 (wordsmyth2) said : #1

P.S. Neither Simple Scan nor Xsane recognise the HP2510... but ir prints and copies just fine.

What is the output of :

lsb_release -a; uname -a; lsusb

Thanks

wordsmyth2 (wordsmyth2) said : #3

On 20/12/13 14:51, actionparsnip wrote:
> lsb_release -a; uname -a; lsusb

wordsmyth@wordsmyth-Aspire-E1-531:~$ lsb_release -a; uname -a; lsusb
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise
Linux wordsmyth-Aspire-E1-531 3.8.0-34-generic #49~precise1-Ubuntu SMP
Wed Nov 13 18:05:00 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 1bcf:2c18 Sunplus Innovation Technology Inc.
Bus 002 Device 003: ID 1a40:0201 Terminus Technology Inc. Hub
Bus 002 Device 004: ID 062a:4101 Creative Labs
Bus 002 Device 005: ID 03f0:ac11 Hewlett-Packard
wordsmyth@wordsmyth-Aspire-E1-531:~$

wget http://prdownloads.sourceforge.net/hplip/hplip-3.13.11.run

chmod +x ./hplip-3.13.11.run

./hplip-3.13.11.run

This will give you the latest HPLIP which may help.

daniel CURTIS (anoda) said : #5

Hello. Have you used a 'sane-find-scanner' utility (available in the 'sane-utils' package)? If not, please try to check it. One suggestion; run it with 'sudo' (I think it should be used also witha 'lsusb' command). You can also try to add your user to e.g. the 'scanner', 'lp' or 'saned' groups.

wordsmyth2 (wordsmyth2) said : #6

        Thanks, AP. Have downloaded hplip to desktop, but when I type
        'cd Desktop' in the terminal I get 'no such file or directory'.
        Have followed the HP instructions and tried various combinations
        thereof, all with the same result. Frustrating. Have downloaded
        Hplip previously and not had these error messages etc. Have
        limited knowledge of technical syntax: what are the commands
        inserted here under the download link your have provided i.e.
        'chmod' etc & './hplip' etc: are these two separate terminal
        entries????

        Thanks again for the help,

        wordsmyth

On 20/12/13 20:01, actionparsnip wrote:mod' etc
> Your question #241051 on simple-scan in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/simple-scan/+question/241051
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> wget http://prdownloads.sourceforge.net/hplip/hplip-3.13.11.run
>
> chmod +x ./hplip-3.13.11.run
>
> ./hplip-3.13.11.run
>
> This will give you the latest HPLIP which may help.
>

wordsmyth2 (wordsmyth2) said : #7

Thanks actionparsnip, that solved my question.

wordsmyth2 (wordsmyth2) said : #8

    Well, well - success at last! Persistence is all - didn't try
    anything different, just continued re-typing 'cd desktop' until -
    voila! - the syntax was accepted and took me to 'desktop'. Curious,
    non? :-( Now scanner works fine!

On 20/12/13 20:01, actionparsnip wrote:
> Your question #241051 on simple-scan in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/simple-scan/+question/241051
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> wget http://prdownloads.sourceforge.net/hplip/hplip-3.13.11.run
>
> chmod +x ./hplip-3.13.11.run
>
> ./hplip-3.13.11.run
>
> This will give you the latest HPLIP which may help.
>