Facebook upload is working but I need to authorize it again on facebook

Asked by Rob on 2012-12-21

I am able to upload pictures to facebook, but it does not show up, so when I go into the picture folder I uploaded it to it asks me to authorize the picture for it to be shown on my timeline. I was wondering why this is? So is there a way to fix this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shotwell Edit question
Assignee:
No assignee Edit question
Solved by:
Rob
Solved:
2013-01-08
Last query:
2013-01-08
Last reply:
2013-01-03
Jim Nelson (yorba-jim) said : #1

What version of Shotwell are you using?

Rob (rstreeter78) said : #2

I am using 0.12.3 on ubuntu 12.04

Rob (rstreeter78) said : #3

I am using 0.12.3 on ubuntu 12.04. I am attaching a screen shot of how my
published photos look when I go to facebook

On Sat, Dec 29, 2012 at 12:41 PM, Jim Nelson <
<email address hidden>> wrote:

> Your question #217325 on shotwell in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/shotwell/+question/217325
>
>
>
> Status: Open => Needs information
>
> Jim Nelson requested more information:
> What version of Shotwell are you using?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/shotwell/+question/217325
>
>
>
> You received this question notification because you asked the question.
>

Rob (rstreeter78) said : #4

I was wondering if by telling you what version of shotwell is all the info that you needed, or do you still need more information?

Jim Nelson (yorba-jim) said : #5

No, that's very helpful. Could you upgrade to Shotwell 0.13.1? You'll need to add our Yorba PPA and upgrade. We've done some work on Facebook since 0.12.3 and I'm hoping the newer version will solve your problem.

The Yorba PPA is at https://launchpad.net/~yorba/+archive/ppa

Rob (rstreeter78) said : #6

I did the upgrade of shotwell via the ppa and I still am having the same issue.

Jim Nelson (yorba-jim) said : #7

I suspect then you're having this problem: http://redmine.yorba.org/issues/5873 Lucas mentions a workaround there (until we get this fixed). Does it work for you?

Rob (rstreeter78) said : #8

I am unsure of how to implement the workaround, could you please explain on how to implement this please and thank you

Jim Nelson (yorba-jim) said : #9

What you want to do this:

1. Select Photos you want to publish to Facebook.
2. Press the "Publish" button.
3. You should see a "Logout" button in the window. Press that.
4. Now Login to Facebook.
5. Once logged in, publish your photos.

This should make your new photos available as before. This won't fix the problem for photos you already published, however.

Rob (rstreeter78) said : #10

Is this a workaround for the shotwell in the yorba ppa or the shotwell default with 12.04

Jim Nelson (yorba-jim) said : #11

This should work for both.

It will *not* work with the default Shotwell for 12.10, as Canonical changed our photo sharing plugins to use Ubuntu Online Accounts.

Rob (rstreeter78) said : #12

I tried this workaround on both versions and I have the same issue, the workaround didn't seem to work for me.

Lucas Beeler (lucas-yorba) said : #13

> So is there a way to fix this?

Alas, there's no way to fix this right now. Shotwell still uses the legacy REST API to push photos to Facebook. This API is now four years old and the permissions model it exposes is incompatible with the permissions model of the new timeline view. There may be some trick'd-out, Facebook-insider workaround to avoid having to authorize photos uploaded by Shotwell before they're posted to your timeline but I don't know it. In any case, such a workaround would only be a temporary band aid. The right way to fix this problem is to rewrite the Shotwell Facebook Connector plugin to use the Facebook Graph API, which is now the recommended web service interface to Facebook. Because Facebook upload is so critical for our users, we hope to fix this in the next version of Shotwell. We have two bug tickets for the problem in our issue tracking database here:

    http://redmine.yorba.org/issues/5873

    http://redmine.yorba.org/issues/4110

Take care,
Lucas

Rob (rstreeter78) said : #14

I have found out that if I set my photo albums to be seen by only me on facebook my pictures show up on my timeline, so it is some weird permission issue, so for now I will just set the albums to only be seen by me or just authorize them again so thank you for all of your help