Issues after upgrading to 11.10 in desktop

Asked by ramachandran r on 2011-10-25

Issues after upgrading from 11.04 to 11.10 in desktop

1) sudo password not working; tried to change the same in terminal & is working in some cases. The superuser account got locked.

2) update manager not working. An error message " Requires installation of untrusted packages

The action would require the installation of packages from not authenticated sources" appears

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shadow Edit question
Assignee:
No assignee Edit question
Solved by:
ramachandran r
Solved:
2011-11-20
Last query:
2011-11-20
Last reply:
2011-11-04

There is no superuser account, only your account which is in the admin group, giving it sudo and gksudo abilities.

Can you give the output of:

sudo apt-get update

Thanks

ramachandran r (ravi29392003) said : #3

Please find below the output:

ravi@rr-desktop:~$ sudo apt-get update
[sudo] password for ravi:
ravi is not in the sudoers file. This incident will be reported.
ravi@rr-desktop:~$

Thanks

Can you give the output of:

groups

Thanks

ramachandran r (ravi29392003) said : #5

Please find below the output:

ravi@rr-desktop:~$ groups
ravi adm dialout fax tape audio dip video plugdev fuse netdev lpadmin sambashare
ravi@rr-desktop:~$

Thanks

You are not in the admin group so cannot use sudo. Is your username the only on on the system or are there others

ramachandran r (ravi29392003) said : #7

Sorry for the delay as I was away on business.

Before upgrading to11.10 ¨rr¨ was in the admin group. After upgrading I am unable to login with ¨rr¨ user name. I was unable carry out administrative tasks as well. With the methods suggested in http://www.psychocats.net/ubuntu/resetpassword I am able to execute some tasks but not updation, package addition, sudo, etc.,

Thanks

The instructions at http://www.psychocats.net/ubuntu/resetpassword are just for resetting the password a user account. Once you have done this, you should then be able to perform administrative tasks...after you have booted all the way back into the system. You shouldn't attempt to update and install packages in rescue mode.

Since rr is the account you want to have administrative privileges, check and see if it does:

groups rr

If "admin" (not to be confused with "adm" or "lpadmin" which are different) is not listed, then you'll have to add rr to the admin group. Since in that case you don't have any user account in the admin group, you cannot simply log in as an administrator and do this. Instead, you'll have to use the method at http://www.psychocats.net/ubuntu/resetpassword, but instead of running "passwd rr" instead run:

usermod -a -G admin rr

If you're still having problems, then please describe in detail what the problems are, and what you are and are not able to do successfully. Please include the *full* and exact text of any error messages. Please also run this command in the Terminal (when logged in normally, not in rescue mode). To open a Terminal in a normal, graphical login session, press Ctrl+Alt+T.

lsb_release -a; uname -a; groups $USER; gconftool -R /apps/gksu; sudo echo success

(You should copy that command to the clipboard from https://answers.launchpad.net/ubuntu/+source/shadow/+question/176098 -- not your email, as it will get split into two lines -- and paste it into the Terminal; then press enter to run it.)

You may be prompted for your password. If so, enter your login password, and press enter. Don't worry that you don't see any placeholder characters, like *, and that nothing seems to be happening when you enter your password. Try to type it carefully--if authentication fails, maybe type it again. But this is a diagnostic procedure to determine if authentication of a certain kind is broken on your system, so it might not work. Whether or not it does, please then select all the text in the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it here.

If you're still getting errors while trying to install or update software, then please follow steps 1-4 at https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure. That might fix your problem. If not, then please let us know if you had problems with the procedure, and please make sure to post all the text from the Terminal, here in this question.

ramachandran r (ravi29392003) said : #9

I did a re-install without formating the disk; the problem persisted.

Did a fresh install after formating; that solved the issue.

Thanks for the support