Ubuntu

Is there anyway to resume playback of an online radio station at start?

Asked by Chris on 2010-07-28

Hello!
   This isn't a bug or other problem, but more of a feature inquiry or request. I'd like to add rhythmbox to my startup applications list, and have it open playing an online radio station. Any way to accomplish this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu rhythmbox Edit question
Assignee:
No assignee Edit question
Solved by:
Luis Aguiar
Solved:
2010-07-31
Last query:
2010-07-31
Last reply:
2010-07-30
Luis Aguiar (techm3) said : #1

Try Radio Tray http://sourceforge.net/projects/radiotray/

You can add all stations you want with right click on the icon. You only need to know the server of the online radio station.

Chris (kyfho23) said : #2

Forgive me for not asking the question correctly. What I'm looking for is an option to resume playback of the last played media at startup. In other words, when I log in, have the radio station start playing on it's own.

Same question applies to Radio Tray. I'd just like my radio station to start playing at login, and avoid having to open the application (either one), select the media, and pushing play. But I'm looking to do this with either Radio Tray or Rhythmbox. VLC used to have a "Resume playback at start" option, but they took it out, or I can't find it any more.

A command-line option is probably what I'm looking for, but something in the GUI would be great, too.

I'm a big fan of Radio Tray, as it's one of those apps that does one thing very well. And Radio Paradise is my favorite station. I just want the music to start when I login, like a web browser starting with the last page you had open.

I hope I made myself clear this time.

Best Luis Aguiar (techm3) said : #3

My bad! Try this:

Create a blank document and paste:

#!/bin/sh
radiotray "http://www.radioparadise.com/musiclinks/rp_128.m3u"

Give permissions to execute as a program with chmod +x and add it to your startup applications.

I'm in a protected connection so I can't start it when login but the script works to me.

Let me know if it works.

Chris (kyfho23) said : #4

  It worked!!
Thank you...to elaborate on this, in case someone else wants to do this:

1. Quit Radio Tray

2. Open (in a terminal) gksu gedit

3. Paste this code into the file:
#!/bin/sh
radiotray "http://www.radioparadise.com/musiclinks/rp_128.m3u"

4. Save the file to /usr/local/bin/radiotray.sh If the directory does
not exist, create it.

5. Run this command in a terminal:
Code:
sudo chmod 755 /usr/local/bin/radiotray.sh

6. Go to System/Preferences/Startup Applications

7. Add this entry to the startup programs list:
Code:
/usr/local/bin/radiotray.sh . Close and save.

8. Log out and log in. Check if it works.

I adapted this from a post on how to start xscreensaver in the forums:
http://ubuntuforums.org/showthread.php?t=759094 , to give credit where
credit is due. Scroll down the page to quirks' entry on April 19, 2008

On 07/30/2010 01:04 PM, Luis Aguiar wrote:
> Your question #119249 on rhythmbox in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/rhythmbox/+question/119249
>
> Status: Open => Answered
>
> Luis Aguiar proposed the following answer:
> My bad! Try this:
>
> Create a blank document and paste:
>
> #!/bin/sh
> radiotray "http://www.radioparadise.com/musiclinks/rp_128.m3u"
>
> Give permissions to execute as a program with chmod +x and add it to
> your startup applications.
>
> I'm in a protected connection so I can't start it when login but the
> script works to me.
>
> Let me know if it works.
>

Luis Aguiar (techm3) said : #5

No problem! Change the status to solved please

Chris (kyfho23) said : #6

Thanks Luis Aguiar, that solved my question.