Problem with dependencies

Asked by Alen Masic on 2014-08-05

Hello

Since last update I have problems with dependencies. If I try to install or remove any application I get this error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 shotwell : Depends: shotwell-common (= 0.18.0-0ubuntu4.1) but 0.18.0-0ubuntu4.2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried manually to install shotwell-common but I got same error. Also I tried with sudo apt-get -f install and got this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  shotwell
The following packages will be upgraded:
  shotwell
1 upgraded, 0 newly installed, 0 to remove and 48 not upgraded.
Need to get 0 B/7,511 kB of archives.
After this operation, 25.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 299243 files and directories currently installed.)
Preparing to unpack .../shotwell_0.18.1-1~trusty1_i386.deb ...
Unpacking shotwell (0.18.1-1~trusty1) over (0.18.0-0ubuntu4.1) ...
dpkg: error processing archive /var/cache/apt/archives/shotwell_0.18.1-1~trusty1_i386.deb (--unpack):
 trying to overwrite '/usr/share/shotwell/icons/shotwell-16.svg', which is also in package shotwell-common 0.18.0-0ubuntu4.2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for menu (2.1.46ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/shotwell_0.18.1-1~trusty1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

So what should I do to solve this problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu qt4-x11 Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2014-08-05
Last query:
2014-08-05
Last reply:
2014-08-05
Manfred Hampl (m-hampl) said : #1

What is the output of the terminal commands

uname -a
lsb_relaese -a
sudo apt-get update
apt-cache policy shotwell shotwell-common
sudo apt-get install -f shotwell- shotwell-common- shotwell shotwell-common

sudo dpkg --force-all -i /var/cache/apt/archives/shotwell_0.18.1-1~trusty1_i386.deb

There is a conflict in the files in the package. I suggest you run:

ubuntu-bug shotwell

And report the issue. The command I gave will make the system ignore the overlap and install the package.

Please also send us the output of this command:

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;

You might have a PPA enabled that is causing this conflict...

Alen Masic (alenn-masic) said : #4

Thanks actionparsnip, that solved my question.