qt applications all crash on launch

Asked by Mannex on 2011-01-20

Fresh install of OS and apps today. Every qt program crashes on launch like this:

mannex@jackass:~$ marble
marble: symbol lookup error: /usr/lib/libQtDBus.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv
mannex@jackass:~$

They all site the same library. I have tried doing a complete removal from synaptic on this library, doing a complete removal of all qt apps that I suspect are linking to it, then reinstalling one app (in this case, Marble), and I get the same error.

Any idea how I can fix this? Any information will be greatly appreciated. Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu qt4-x11 Edit question
Assignee:
No assignee Edit question
Last query:
2011-01-20
Last reply:
2011-02-02
mycae (mycae) said : #1

Have you installed any debs or PPAs outside from the normal repository?

Just to make sure that we have removed the library full and proper, can you try (this will suck down a lot of bandwidth):

sudo aptitude remove libqt4-dbus
sudo aptitude install marble

If that does not work, can you give the output of the command

md5sum /usr/lib/libQtDBus.so.4.*

and

strings /usr/lib/libQtDBus.so.4.* | grep -H checkWindow

cat /etc/apt/sources.list

?

Mannex (russ-mannex) said : #2

I apologize, but it is going to be a few days before I can tackle this. The machine's hard drive crashed, and my guess is that when I get I nice, shiny new drive in there and reinstall, the problem will have vanished (fingers crossed). I do recall installing GoogleEarth, and I know it's a remarkably ugly install, but I don't know if it relies on the qt stuff. If it does, that might have been the problem. I don't really need it anyway, so I will install everything on my "list of things to reinstall after ugly crashes" except GoogleEarth and see how things go from there. I will then get back to y'all. Thanks for all the help! I owe you all a six-pack!

When you get a chance to work on this again, after following mycae's advice, if the aptitude commands don't fix the problem, then in addition to running the md5sum, strings, and cat commands in the way mycae says, please also paste the output of the command, as I suggested earlier:

ls -lRh /usr/local/lib

That will give some idea of what software, installed by some means other than the package manager, has installed libraries onto your computer that might interfere with qt4's proper operation.

It appears that you wish this Question to supersede https://answers.launchpad.net/ubuntu/+source/qt4-x11/+question/142145. If that is the case, you should set the status of https://answers.launchpad.net/ubuntu/+source/qt4-x11/+question/142145 to Invalid.

Mannex (russ-mannex) said : #4

I will definitely follow up.

I can't figure out how to mark the other one as invalid. I don't see a link to change the status.

Mannex (russ-mannex) said : #5

Reinstalled OS. Unable to reproduce. I highly suspect it was the install of GoogleEarth, which is a very non-standard install.

Mannex (russ-mannex) said : #6

I seem to be unable to change the status of this to unconfirmed, so could someone please do that for me? Thanks.

Mannex (russ-mannex) said : #7

I seem to be unable to change the status of this to unconfirmed, so could someone please do that for me? Thanks.

This is a question, and not a bug, so "unconfirmed" is not a possible status for it. (Actually, "unconfirmed" is not a possible status for bugs on Launchpad either, but "Incomplete" and "Invalid" are both available).

"Invalid" is a possible status for a question, but it is not the right status for this question. For example, this question is not a duplicate, or a post that was intended for a totally different forum (say, on restoring old hot rods) that was inadvertent submitted here.

If you no longer need any further assistance on this issue, the best status for this question would be Solved.

Can you help with this problem?

Provide an answer of your own, or ask Mannex for more information if necessary.

To post a message you must log in.