libqt4-opengl cannot be installed as it requires earlier versions

Asked by TheOldFellow on 2010-11-08

Binary package hint: libqt4-opengl

Prevents installing VirtualBox.
Maverick AMD-64. Fully up to date.

apt-cache policy libqt4-opengl
libqt4-opengl:
  Installed: (none)
  Candidate: 4:4.7.0-0ubuntu4
  Version table:
     4:4.7.0-0ubuntu4.1 0
        100 /var/lib/dpkg/status
     4:4.7.0-0ubuntu4 0
        500 http://gb.archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages

sudo apt-get install libqt4-opengl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libqt4-opengl : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4) but 4:4.7.0-0ubuntu4.1 is to be installed
                 Depends: libqtgui4 (= 4:4.7.0-0ubuntu4) but 4:4.7.0-0ubuntu4.1 is to be installed
E: Broken packages

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu qt4-x11 Edit question
Assignee:
No assignee Edit question
Last query:
2010-11-08
Last reply:
2010-11-21
TheOldFellow (theoldfellow) said : #1

This appears to be the same problem as this one.
https://answers.launchpad.net/ubuntu/+source/qt4-x11/+question/132957

TheOldFellow (theoldfellow) said : #2

It seems that the system allows unofficial software to installed without any warning. How can this be avoided? By just using software that comes from Canonical - if so then Ubuntu is no better than Windows. There surely should be some warning when a package seeks to upgrade an official release to a later version?

Dmitry Shachnev (mitya57) said : #3

Qt 4.7.0-0ubuntu4.2 was uploaded to proposed repositories. Enable them (https://wiki.ubuntu.com/Testing/EnableProposed) and your problem should be fixed

Dmitry Shachnev (mitya57) said : #4

Qt 4.7.0-0ubuntu4.2 was uploaded to proposed repositories. Enable them (https://wiki.ubuntu.com/Testing/EnableProposed) and your problem should be fixed.

Can you help with this problem?

Provide an answer of your own, or ask TheOldFellow for more information if necessary.

To post a message you must log in.