needs to fix pulse audio driver / snowglobe shut down

Asked by Halaliel on 2009-11-14

Snowglobe 1.1.3 (2906) Oct 16 2009 11:37:51 (Snowglobe Release)
Release Notes

Built with GCC version 40102

You are at 212320.1, 316705.1, 25.0 in Desert located at sim8054.agni.lindenlab.com (216.82.37.121:13001)
Second Life Server 1.32.0.136920
Release Notes

CPU: Intel(R) Atom(TM) CPU N270 @ 1.60GHz
Memory: 2003 MB
OS Version: Linux 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686
Graphics Card Vendor: Tungsten Graphics, Inc
Graphics Card: Mesa DRI Intel(R) 945GME GEM 20090712 2009Q2 RC3 x86/MMX/SSE2
OpenGL Version: 1.4 Mesa 7.6

libcurl Version: libcurl/7.16.4 OpenSSL/0.9.7c zlib/1.2.3.3 c-ares/1.4.0
J2C Decoder Version: OpenJPEG: 1.3.0, Runtime: 1.3.0
Audio Driver Version: OpenAL, version 1.1 / OpenAL Community / OpenAL Soft: ALSA Software on default
LLMozLib Version: [LLMediaImplLLMozLib] - 2.01.28228 (Mozilla GRE version 1.8.1.18_0000000000)
Packets Lost: 43/3002 (1.4%)

Asriazh Frye added a comment - 11/Nov/09 07:18 AM
That's most likely OpenAl, freezing Pulseaudio. Until i compiled Pulseaudio from the GIT source, i had the same issue of OpenAL killing and creating new instances of stream until the sound finally froze which also caused Snowglobe to hang at shutdown. I use Pukseaudio 0.9.19.237-g721e-dirty right now without issues.

-Asriazh

Halaliel Zenith added a comment - 11/Nov/09 04:56 PM - edited
OK, I'm not sure about what you are telling me above, I looked @ installed software & looked up pulse audio & 6 pakages not installed.

They have simple Gnome audio control by default & not sure about what pulse audio is. Since i don't see pulse audio on this PC not a issue here.

Also looked for openAL to it is not installed on my pc, again not the issue.
[ Show » ]
Halaliel Zenith added a comment - 11/Nov/09 04:56 PM - edited OK, I'm not sure about what you are telling me above, I looked @ installed software & looked up pulse audio & 6 pakages not installed. They have simple Gnome audio control by default & not sure about what pulse audio is. Since i don't see pulse audio on this PC not a issue here. Also looked for openAL to it is not installed on my pc, again not the issue.

Asriazh Frye added a comment - 11/Nov/09 08:11 PM
You might not have Pulseaudio installed (you can check by opening a commandprompt window and entering "pulseaudio --version" without quotes) , but you sure use OpenAL, cause SL comes with a copy of it. Just look at your own environment output you pasted here ^^;

-Asriazh
[ Show » ]
Asriazh Frye added a comment - 11/Nov/09 08:11 PM You might not have Pulseaudio installed (you can check by opening a commandprompt window and entering "pulseaudio --version" without quotes) , but you sure use OpenAL, cause SL comes with a copy of it. Just look at your own environment output you pasted here ^^; -Asriazh

[ Permlink | Edit | Delete | « Hide ]
Halaliel Zenith added a comment - 12/Nov/09 04:59 PM - edited
pulseaudio 0.9.19 is shown installed although not shown in synaptic.
Well questions are what is pulse audio ? do I need it ? will solve or cause trouble ? keep it Installed ? or what is it I should install extra +/- 6 different packages ?

Yes I see the info. pasted I do have openAL, I found something in synaptic same name it seems to be for developers, so way over my head to know. It does not show installed there BTW.

Asriazh Frye added a comment - 13/Nov/09 10:28 AM - edited
You could compile Pulseaudio from source and the hang at closing SL would go away. But since you're new to Linux, the better and easier option would be to go to your SL folder and open the file "snowglobe" there with a texteditor like gedit for example. there change

## - Avoids using any OpenAL audio driver.
#export LL_BAD_OPENAL_DRIVER=x
## - Avoids using any FMOD audio driver.
#export LL_BAD_FMOD_DRIVER=x

to

## - Avoids using any OpenAL audio driver.
export LL_BAD_OPENAL_DRIVER=x
## - Avoids using any FMOD audio driver.
#export LL_BAD_FMOD_DRIVER=x

and save. This will force Snowglobe to use FMOD instead of OpenAL. The sound stuttering and hanging at shutdown will go away, but as a trade off you'll have a slight audio delay. Good luck _
[ Show » ]
Asriazh Frye added a comment - 13/Nov/09 10:28 AM - edited You could compile Pulseaudio from source and the hang at closing SL would go away. But since you're new to Linux, the better and easier option would be to go to your SL folder and open the file "snowglobe" there with a texteditor like gedit for example. there change

## - Avoids using any OpenAL audio driver.
#export LL_BAD_OPENAL_DRIVER=x
## - Avoids using any FMOD audio driver.
#export LL_BAD_FMOD_DRIVER=x

to

## - Avoids using any OpenAL audio driver.
export LL_BAD_OPENAL_DRIVER=x
## - Avoids using any FMOD audio driver.
#export LL_BAD_FMOD_DRIVER=x

and save. This will force Snowglobe to use FMOD instead of OpenAL. The sound stuttering and hanging at shutdown will go away, but as a trade off you'll have a slight audio delay. Good luck _

Can anyone figure this out ??

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-21
Last reply:
2009-11-24
Daniel T Chen (crimsun) said : #1

Keep in mind that 0.9.20 is in Lucid and is also available in the ubuntu-audio-dev PPA (https://edge.launchpad.net/~ubuntu-audio-dev/+archive/ppa) for Karmic.

Halaliel (halaliel) said : #2

What is this for ?

Halaliel (halaliel) said : #3

OK the page was not clear @ 1st. I add the repository & 59 packages are upgrading now.
Hope this is not unstable stuff.

Halaliel (halaliel) said : #4

OK Snowglobe still does not shutdown can anyone help me with a fix ?

Daniel T Chen (crimsun) said : #5

Please be aware of bug 485488.

Can you help with this problem?

Provide an answer of your own, or ask Halaliel for more information if necessary.

To post a message you must log in.