Why do I loose "sound card" in sound setting in other logins?

Asked by Shunsuke Akagi on 2013-08-07

There is a strange thing happening.
I have Analog Output SB X-Fi in my regular login. But when I change to other login they do not have the option.
So no sound from them.

So I have done the followng
# apt-get remove --purge alsa-base pulseaudio
# apt-get install alsa-base pulseaudio
# alsa force-reload

Then I got the option back and sound back from other logins.
However I logged out once and then went back, now I lost the option and sound again.
Is this a bug?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
Shunsuke Akagi
Solved:
2013-08-08
Last query:
2013-08-08
Last reply:
2013-08-07

This question was reopened

Shunsuke Akagi (shoon) said : #2

This is completely seperate another problem.
https://answers.launchpad.net/ubuntu/+source/pulseaudio/+question/233659
is about "test sound" voice being disapearing.
This question is about sound card setting being disapearing.

Shunsuke Akagi (shoon) said : #3

I have fixed with this web site
https://bbs.archlinux.org/viewtopic.php?id=164868

set-card-profile 1 output:analog-stereo in /etc/pulse/default.pa has fixed this problem.

Shunsuke Akagi (shoon) said : #4

I thought I have fixed the problem but I found out that it has not been fixed yet.
This is what's happening.
There are two logins "ABC" and "DEF"
When I login from "DEF" at first. Sound setting is fine.
Login "ABC". Sound setting is fine.
Go back to "DEF", Sound setting is fine.
logout from "DEF" then come to "DEF" now sound setting has gone.
"ABC" is always good meanwhile.
Logout from both "ABC" and "DEF" then login "DEF" now sound setting is back.

It seems to be" /etc/pulse/default.pa" is occupied by "ABC" once it's ocupied other user cannot access to it anymore.
Is it supposed to work like this?

Shunsuke Akagi (shoon) said : #5

I think
sudo usermod -a -G audio <userame>
fixed this problem.
Thank you all!