Pulseaudio only works in System-wide mode

Asked by Michael Stump on 2012-07-22

I just upgraded to 12.04 and had no sound after upgrade. I went through a lot of troubleshooting before finally posting here. I even did a full format/reinstall of 12.04 only to have sound on first boot only.

I have tried step 1 of the SoundTroubleshooting that adds the audio-dev ppa and reinstalls pulseaudio and everything and this still does not work. I think I have finally narrowed it down to a problem with pulseaudio. I know that alsa is working just fine and can produce sound by telling my apps (xbmc) to play through alsa etc. However, I want to have pulseaudio working also for the added functionality.

I can get pulseaudio working by starting it in system mode through editing the /etc/default/pulseaudio file. But this does not solve my problem as the Simultaneous output doesn't work and neither does streaming sound to other computers.

I don't know what is interfering with pulse when ran at user-level but I'm hoping to get some help here.

~$ start-pulseaudio-x11
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

I have a verbose log from pulseaudio uploaded here http://pastebin.com/rnvcTGdc

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Last query:
2012-07-22
Last reply:
2012-07-22

Try:

killall pulseaudio; rm -r ~/.pulse*

Wait 10 seconds then reboot

HTH

Michael Stump (stumpalump) said : #2

Andrew, thanks for your reply. I have tried what you suggested before but do you think I should try it again?

Worth a shot

Can you help with this problem?

Provide an answer of your own, or ask Michael Stump for more information if necessary.

To post a message you must log in.