Audio plays for one user account but not the other

Asked by John Lamont on 2011-04-29

After messing around with my audio to try and get microphone input to play on speakers, I screwed up my audio and nothing would play. Now after reinstalling alsa, reconfiguring it, etc., audio will play but only for one user account and not my working account (the one under which I made all the changes). When I log out of my main account I get the little drum roll sound (or whatever it is), ditto when I get to the login page. But after logging in, I get no sound. The other account works fine.

Both users have audio rights as seen in System/Admin/User-Groups.
I am running You are using Ubuntu 10.04 LTS - the Lucid Lynx
I don't believe I have PulseAudio - never had Ubuntu 9.4 on this box
RhythmBox plays for one account but not the other, for example if I log out of my main account and log in as the secondary account and run something from Ubuntu store - sound. I then log out and into my main account and go to RBox, but no sound.

Thanks in advance,

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
John Lamont
Solved:
2011-04-29
Last query:
2011-04-29
Last reply:
2011-04-29

Can you give the output of:

groups

for each account (make a note on your update which user bad and which is good). You may also want to run:

killall pulseaudio; rm -r ~/.pulse*

on the user having issues.

John Lamont (john-lamon) said : #2

killall pulseaudio; rm -r ~/.pulse* seems to have fixed it. Is it permanent?

main id : main-id adm dialout cdrom audio video plugdev lpadmin netdev admin sambashare
me : me adm dialout fax cdrom floppy tape audio dip video plugdev fuse nopasswdlogin

me was the account that got audio.

Thanks so much!

Yes, it holds the settings for pulse (There is a folder and a file), By deleting them you set the settings to defaults.

Willing2Learn (curious-g74) said : #4

This worked for me, except that my pulse configuration folder was at ~/.config/pulse .