Unable to run OSS applications in Maverick

Asked by doctordruidphd on 2010-10-07

Binary package hint: pulseaudio

I am trying to use a USB logitech c-510 webcam, and can get no audio.
Pulseaudio volume control shows the device there, and responding to sounds.
No applications can receive sound from the device.
Skype says it is using Pulseaudio, but gets no sound from the mic.
padsp does not work for skype, streamer, or any other applications that need to get audio from the mic.

I realize that there is a desire to fold alsa and oss applications into pulseaudio, but it is not working.
Any suggestions as to how we run skype, or other essential applications, without alsa or oss support?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
doctordruidphd
Solved:
2010-10-07
Last query:
2010-10-07
Last reply:
2010-10-07

This question was originally filed as bug #656091.

Daniel T Chen (crimsun) said : #1

Please clarify whether you are unable to *capture* anything from your webcam. Did you select it as the default input device using the GNOME sound preferences/Input or the pavucontrol application (you'd need to install the latter, though it isn't necessary)?

Skype works fine here in both Lucid and Maverick via native PulseAudio support. Make sure that you've disabled Skype's automatic adjustment of capture levels.

The decision to obsolete OSS support was made at UDS-Maverick and simply follows the lead that Fedora established several releases ago.

Thank You for your reply.

I have disabled Skype's "Allow Skype to automatically adjust my mixer levels"

I am running kubuntu. In pavucontrol, under Input Devices, the camera is listed as ")81d Analog Mono".
The mute button is unchecked, and the fallback button is checked.

Allright, I had to run Skype with the "recording" tab open. Then I hit "make a test call", and the stream for skype appeared. I could then sent the camera as default, and now it works.

Maybe need to do the same for other applications.

Thank You for your assistance.

I have not been able to get padsp to work. Applications that expect to see /dev/dsp as a sound device won't work unless they see that device, and padsp evidently does not create it. Maybe other applications that don't require /dev/dsp to be explicitly configured might work, but applications that require you to enter a sound device will not work with padsp, because /dev/dsp is not there.

example: qsstv

The original issue with skype is solved.