Unable to type in keyring password - locked out

Asked by srh118@hotmail.com on 2011-08-02

When I want to install software using the Ubuntu Software Centre - I am asked to authenticate, but the password dialog box doesn't let me type in a password?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu policykit-1-gnome Edit question
Assignee:
No assignee Edit question
Last query:
2011-08-04
Last reply:
2011-08-04

The password you type in to use the Software Center is *not* your keyring password, it is the password you set when you installed Ubuntu (and with which you log on, if you have not enabled automatic login). This would only be the same as your keyring password if you happened to set the two passwords to the same thing.

If that enables you to solve your problem, then please mark this question as Solved. (You can do that at https://answers.launchpad.net/ubuntu/+source/gksu/+question/166694.) Otherwise, please provide more information, as requested below.

Is the problem that you cannot get a text cursor inside the password field, that you can but typing a password in has no effect, that you can type in the password but pressing enter or clicking OK has no effect, or that you are able to enter and submit a password but you are told that it is incorrect?

Does this happen when you attempt to perform other administrative tasks? For example, with the Software Center closed, if you open the Update Manager and click Settings... on the lower left corner of the window, does this happen?

In addition to providing the above information, please open a Terminal window (Ctrl+Alt+T) and run this command:

gksu xclock

To run it, you can paste it into the Terminal (or type it in very carefully), then press enter. Does this prompt you to enter your password? If it does, are you able to enter it successfully?

That will run a simple clock application. You can quit it immediately. This is just for testing for problems running graphical applications as root.

If that does not work, please run this similar (but different) command, and report what happens (if it shows a clock, you can quit it as well):

gksudo xclock

Whatever happened with either of those commands (and whether or not you ran the second one), please run this command, which I recommend you copy from here and paste into the Terminal, as it is very easy to get wrong if you were to mistype it:

lsb_release -a; groups $(whoami); gconftool-2 -R /apps/gksu; sudo -k; sudo echo testing

That command will probably be split into two lines in your email, in such a way that it will not copy correctly. So you should copy it from https://answers.launchpad.net/ubuntu/+source/gksu/+question/166694 instead.

When you run that command, you should be prompted for your password (though that will not be the first thing you see). As you type it in, you won't see any placeholder characters (like *). In this situation, that is normal. Just type it in and press enter.

Afterwards, please select *all* the text in the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it here.

srh118@hotmail.com (srh118) said : #2

I think the problem is this : I cannot get a text cursor inside the
password field

On Tue, 2011-08-02 at 05:41 +0000, Eliah Kagan wrote:
> Your question #166694 on gksu in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gksu/+question/166694
>
> Status: Open => Answered
>
> Eliah Kagan proposed the following answer:
> The password you type in to use the Software Center is *not* your
> keyring password, it is the password you set when you installed Ubuntu
> (and with which you log on, if you have not enabled automatic login).
> This would only be the same as your keyring password if you happened to
> set the two passwords to the same thing.
>
> If that enables you to solve your problem, then please mark this
> question as Solved. (You can do that at
> https://answers.launchpad.net/ubuntu/+source/gksu/+question/166694.)
> Otherwise, please provide more information, as requested below.
>
> Is the problem that you cannot get a text cursor inside the password
> field, that you can but typing a password in has no effect, that you can
> type in the password but pressing enter or clicking OK has no effect, or
> that you are able to enter and submit a password but you are told that
> it is incorrect?
>
> Does this happen when you attempt to perform other administrative tasks?
> For example, with the Software Center closed, if you open the Update
> Manager and click Settings... on the lower left corner of the window,
> does this happen?
>
> In addition to providing the above information, please open a Terminal
> window (Ctrl+Alt+T) and run this command:
>
> gksu xclock
>
> To run it, you can paste it into the Terminal (or type it in very
> carefully), then press enter. Does this prompt you to enter your
> password? If it does, are you able to enter it successfully?
>
> That will run a simple clock application. You can quit it immediately.
> This is just for testing for problems running graphical applications as
> root.
>
> If that does not work, please run this similar (but different) command,
> and report what happens (if it shows a clock, you can quit it as well):
>
> gksudo xclock
>
> Whatever happened with either of those commands (and whether or not you
> ran the second one), please run this command, which I recommend you copy
> from here and paste into the Terminal, as it is very easy to get wrong
> if you were to mistype it:
>
> lsb_release -a; groups $(whoami); gconftool-2 -R /apps/gksu; sudo -k;
> sudo echo testing
>
> That command will probably be split into two lines in your email, in
> such a way that it will not copy correctly. So you should copy it from
> https://answers.launchpad.net/ubuntu/+source/gksu/+question/166694
> instead.
>
> When you run that command, you should be prompted for your password
> (though that will not be the first thing you see). As you type it in,
> you won't see any placeholder characters (like *). In this situation,
> that is normal. Just type it in and press enter.
>
> Afterwards, please select *all* the text in the Terminal (Edit > Select
> All), copy it to the clipboard (Edit > Copy), and paste it here.
>

Please provide all the other information I have requested, or, if you cannot, please explain any difficulties you are experiencing in attempting to do so.

srh118@hotmail.com (srh118) said : #4

I pasted ran the command line in terminal as instructed.
Here is all the text copied from terminal as requested :

shane@shane-P4GSL:~$ lsb_release -a; groups $(whoami); gconftool-2
-R /apps/gksu; sudo -k;
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick
shane : shane adm dialout cdrom plugdev lpadmin admin sambashare
 sudo-mode = true
 prompt = false
 force-grab = false
 save-to-keyring = false
 display-no-pass-info = false
 disable-grab = false
 save-keyring = session
shane@shane-P4GSL:~$ sudo echo testing
[sudo] password for shane:
testing
shane@shane-P4GSL:~$

On Tue, 2011-08-02 at 06:35 +0000, Eliah Kagan wrote:
> Your question #166694 on gksu in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gksu/+question/166694
>
> Status: Open => Needs information
>
> Eliah Kagan requested more information:
> Please provide all the other information I have requested, or, if you
> cannot, please explain any difficulties you are experiencing in
> attempting to do so.
>

You have still not provided the following requested information:

Does this happen when you attempt to perform other administrative tasks? For example, with the Software Center closed, if you open the Update Manager and click Settings... on the lower left corner of the window, does this happen?

In addition to providing the above information, please open a Terminal window (Ctrl+Alt+T) and run this command:

gksu xclock

To run it, you can paste it into the Terminal (or type it in very carefully), then press enter. Does this prompt you to enter your password? If it does, are you able to enter it successfully?

That will run a simple clock application. You can quit it immediately. This is just for testing for problems running graphical applications as root.

If that does not work, please run this similar (but different) command, and report what happens (if it shows a clock, you can quit it as well):

gksudo xclock

srh118@hotmail.com (srh118) said : #6

When I opened Update Manager and clicked on settings I was able to type
in a password and the gksu xclock application prompted me for a password
which I was able to enter. I then closed the clock app and quit
terminal.

Have I provided all info or is there something still missing?

On Tue, 2011-08-02 at 07:36 +0000, Eliah Kagan wrote:
> Your question #166694 on gksu in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gksu/+question/166694
>
> Status: Open => Needs informationgksu xclock
>
> Eliah Kagan requested more information:
> You have still not provided the following requested information:
>
> Does this happen when you attempt to perform other administrative tasks?
> For example, with the Software Center closed, if you open the Update
> Manager and click Settings... on the lower left corner of the window,
> does this happen?
>
> In addition to providing the above information, please open a Terminal
> window (Ctrl+Alt+T) and run this command:
>
> gksu xclock
>
> To run it, you can paste it into the Terminal (or type it in very
> carefully), then press enter. Does this prompt you to enter your
> password? If it does, are you able to enter it successfully?
>
> That will run a simple clock application. You can quit it immediately.
> This is just for testing for problems running graphical applications as
> root.
>
> If that does not work, please run this similar (but different) command,
> and report what happens (if it shows a clock, you can quit it as well):
>
> gksudo xclock
>

"Have I provided all info or is there something still missing?"

At this point, you have provided all the information requested so far, yes. It seems that perhaps there is some problem with PolicyKit on your system. But before we look into that, I want to exclude one other possibility and gather some additionally potentially useful information.

You should just be able to click in the "Password:" box (or press Tab until it is selected) and enter your password, then type it in and press enter (or click Authenticate) to submit it. Are you not able to do this?

If not, please let me know whether or not the password window looks like http://s3.postimage.org/nvrycq0ao/software_center_authenticate.png, and if it does not, how it looks different. (If you like, you could post your own screenshot on the web and link to it here.)

srh118@hotmail.com (srh118) said : #8

You should just be able to click in the "Password:" box (or press Tab
until it is selected) and enter your password, then type it in and press
enter (or click Authenticate) to submit it. Are you not able to do this?

- I tried this but still no cursor in the password field.

The desktop screenshot link is below :

http://postimage.org/image/tj735w2s/

If not, please let me know whether or not the password window looks like
and if it does not, how it looks different. If not, please let me know
whether
 or not the password window looks like
http://s3.postimage.org/nvrycq0ao/software_center_authenticate.png, and
if it does not, how it looks different. (If you like, you could post
your own screenshot on the web and link to it here.)

On Tue, 2011-08-02 at 08:56 +0000, Eliah Kagan wrote:

> You should just be able to click in the "Password:" box (or press Tab
> until it is selected) and enter your password, then type it in and
> press
> enter (or click Authenticate) to submit it. Are you not able to do
> this?
>
> If not, please let me know whether or not the password window looks
> like
> http://s3.postimage.org/nvrycq0ao/software_center_authenticate.png,
> and
> if it does not, how it looks different. (If you like, you could post
> your own screenshot on the web and link to it here.)

That screenshot is extremely tiny. Would it be possible for you to post a larger (higher-resolution) image?

srh118@hotmail.com (srh118) said : #10

Here is a better resolution image :

http://postimage.org/image/1khybcjl0/

On Tue, 2011-08-02 at 11:21 +0000, Eliah Kagan wrote:
> Your question #166694 on gksu in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gksu/+question/166694
>
> Status: Open => Needs information
>
> Eliah Kagan requested more information:
> That screenshot is extremely tiny. Would it be possible for you to post
> a larger (higher-resolution) image?
>

What happens when you just click the Authenticate button?

Also, what do you see when you expand Details?

srh118@hotmail.com (srh118) said : #12

What happens when you just click the Authenticate button?

 - Nothing happens - the "Authenticate" box remains on screen.

Also, what do you see when you expand Details?

 - Details expand as below :

   Action: org.debian.apt.install-or-remove-packages

  Vendor: Apt Daemon

Action: org.debian.apt.install-or-remove-packages

  Vendor: Apt Daemon

On Wed, 2011-08-03 at 06:11 +0000, Eliah Kagan wrote:

> What happens when you just click the Authenticate button?
>
> Also, what do you see when you expand Details?
>
>

Please try running this command in a Terminal:

pkcheck --action-id org.freedesktop.systemtoolsbackends.set --allow-user-interaction --process `pidof gnome-settings-daemon`

That command will not copy correctly from your email (line breaks will be inserted where it splits into multiple lines), so you'll have to copy it from https://answers.launchpad.net/ubuntu/+source/policykit-1-gnome/+question/166694.

Does that command produce the same unusable authentication window that you get when you attempt to install something in the Software Center? Also, after that runs, please select all the text in the Terminal, copy it to the clipboard, and paste it here.

srh118@hotmail.com (srh118) said : #14

Does that command produce the same unusable authentication window that
> you get when you attempt to install something in the Software Center?

 - YES IT DOES.

Here is what I copied from the terminal (after closing the above
unusable window):

shane@shane-P4GSL:~$ pkcheck --action-id
org.freedesktop.systemtoolsbackends.set --allow-user-interaction
--process `pidof gnome-settings-daemon`
Not authorized.
shane@shane-P4GSL:~$

On Wed, 2011-08-03 at 20:46 +0000, Eliah Kagan wrote:
> Your question #166694 on policykit-1-gnome in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/policykit-1-gnome/+question/166694
> Does that command produce the same unusable authentication window that
> you get when you attempt to install something in the Software Center?
> Status: Open => Needs information
>
> Eliah Kagan requested more information:
> Please try running this command in a Terminal:
> Does that command produce the same unusable authentication window that
> you get when you attempt to install something in the Software Center?:
> pkcheck --action-id org.freedesktop.systemtoolsbackends.set --allow-
> user-interaction --process `pidof gnome-settings-daemon`
>
> That command will not copy correctly from your email (line breaks will
> be inserted where it splits into multiple lines), so you'll have to copy
> it from
> https://answers.launchpad.net/ubuntu/+source/policykit-1-gnome/+question/166694.
>
> Does that command produce the same unusable authentication window that
> you get when you attempt to install something in the Software Center?
> Also, after that runs, please select all the text in the Terminal, copy
> it to the clipboard, and paste it here.
>

srh118@hotmail.com (srh118) said : #15

It seems the problem is solved - I simply typed :

sudo apt-get install in terminal and after updating quickly I tried
again and this time I was able to enter the password successfully.

Thanks for your help.

On Wed, 2011-08-03 at 20:46 +0000, Eliah Kagan wrote:

> Your question #166694 on policykit-1-gnome in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/policykit-1-gnome/+question/166694
>
> Status: Open => Needs information
>
> Eliah Kagan requested more information:
> Please try running this command in a Terminal:
>
> pkcheck --action-id org.freedesktop.systemtoolsbackends.set --allow-
> user-interaction --process `pidof gnome-settings-daemon`
>
> That command will not copy correctly from your email (line breaks will
> be inserted where it splits into multiple lines), so you'll have to copy
> it from
> https://answers.launchpad.net/ubuntu/+source/policykit-1-gnome/+question/166694.
>
> Does that command produce the same unusable authentication window that
> you get when you attempt to install something in the Software Center?
> Also, after that runs, please select all the text in the Terminal, copy
> it to the clipboard, and paste it here.
>

I'm glad to hear you were able to solve the problem! Since you have done so, please mark this question as Solved. (You can do that at https://answers.launchpad.net/ubuntu/+source/policykit-1-gnome/+question/166694.)

Can you help with this problem?

Provide an answer of your own, or ask srh118@hotmail.com for more information if necessary.

To post a message you must log in.