Jaunty pidgin-how to turn off pop up notification?

Asked by Gillypants on 2009-04-24

I upgraded to the new distribution today, and now when i use pidgin, every time someone logs in/out or when i receive a message when the im window is not selected, i got a pop up notification in my top right corner that i never got with ubuntu 8, and i cannot for the life of me figure out how to turn it off. it is annoying the crap out of me... please help!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pidgin Edit question
Assignee:
No assignee Edit question
Solved by:
zexo
Solved:
2009-04-25
Last query:
2009-04-25
Last reply:
2009-04-24
Sam_ (and-sam) said : #1

Hi,
depending on how fast the implementation goes on, notification is handled within the app itself, quote:
Any notification configuration should be handled by individual applications

Hence you may check options in pidgin or maybe in gconf-editor /apps/pidgin

Reference:
https://wiki.ubuntu.com/NotifyOSD
https://wiki.ubuntu.com/NotificationDevelopmentGuidelines

Gillypants (bluexmoonxmist) said : #2

it's definitely not in the preferences, i looked through it like five times. i also looked through system prefs just to make sure i wasn't missing something.
i don't really know how to do anything in terminal... its not that i couldn't know, i just don't have anyone to teach me and all the technical jargon on forums really confuses me so i haven't really been able to pick anything up.

Gillypants (bluexmoonxmist) said : #3

also i checked out those links you posted and it seems like that information is geared towards fixing broken notification pop ups as opposed to just removing them all together.

Sam_ (and-sam) said : #4

It explains en detail how NotifyOSD is working, as it is a complex messaging module and as mentioned apps will be modified.
Reference section: Programs that should be modified before Ubuntu 9.04 in the link above.

https://wiki.ubuntu.com/MessagingMenu#Pidgin

To get rid of it you need to write a script, which isn't trivial.
Maybe on ubuntuforums.org someone has the same wish as you.
The specifics:
http://www.galago-project.org/specs/notification/0.9/

gconf-editor wasn't meant as command it is the configuration editor which can be used for configuration.
applications -> system tools -> gconf-editor

If it isn't visible you may open the main menu to make it visible.
system preferences -> main menu

Or you start this app in a terminal by typing:
gconf-editor

Reference:
https://help.ubuntu.com/community/UsingTheTerminal
https://help.ubuntu.com/community/GnomeTerminal
http://library.gnome.org/users/gconf-editor/2.22/getting-started.html.en

Introduction:
http://www.markshuttleworth.com/archives/265

Best zexo (zexo) said : #5

Pidgin Menu -> Tools -> Plugins -> Libnotify Popups -> [Configure Plugin]

uncheck "Buddy signs on"

Gillypants wrote:
> New question #68417 on pidgin in ubuntu:
> https://answers.launchpad.net/ubuntu/+source/pidgin/+question/68417
>
> I upgraded to the new distribution today, and now when i use pidgin, every time someone logs in/out or when i receive a message when the im window is not selected, i got a pop up notification in my top right corner that i never got with ubuntu 8, and i cannot for the life of me figure out how to turn it off. it is annoying the crap out of me... please help!
>

In the Buddy List go to Tools > Plugins and disable or Configure the
"Libnotify Popups" plugin.

Gillypants (bluexmoonxmist) said : #7

Thanks zexo, that solved my question.

bobtykac (glanocr+a) said : #8

Thanks Zexo! I hate these popups.

Sam, what in gods name are you talking about?

X Y (throwaway-xy+ubuntu) said : #9

I was able to workaround this BUG by going to Tools ->
Plugins -> then uncheck "Libnotify".

The fact that this fucking shit makes it into a Ubuntu
release is seriously pathetic. No one wants this crap.
If I wanted incessant popups, I could use an operating
system distribution geared toward them specifically.

Fucking piece of shit.

Ben Bridts (band-b) said : #10

> I was able to workaround this BUG by going to Tools ->
> Plugins -> then uncheck "Libnotify".
It's not a bug and it's not a workaround. It is a plugin that behaves like it should and a the way to disable it.

> No one wants this crap.
I do

> The fact that this fucking shit makes it into a Ubuntu
> release is seriously pathetic. No one wants this crap.
> [...]
> Fucking piece of shit.

Being rude isn't going to help.

Has anyone filed a bug against Pidgin asking for plugin preferences to be integrated into the main preferences menu? Users should not be expected to know or care whether functionality is due to the main program or a plugin, it should all be in one place.

clombard (clombard44) said : #12

I can relate to X Y's frustration. WHY WHY WHY...?
The talented people working on and developing these programs should assume some basics...
1) We do not want pop-ups!
2) Yes we want to connect to the Internet!
3) Yes we want to connect to a local network!

Simple but so difficult in Linux!

Josh Kupershmidt (schmiddy) said : #13

I actually just ran into this annoyance on a fresh install of Jaunty -- the constant buddy sign-on notifications are very annoying, and it's not at all obvious that one has to go to the plugin preferences and configure "Libnotify Popups". Googling for "turn off pidgin notifications" brought me here.

Does anyone know if Pidgin comes configured like this by default, or is this an Ubuntu-specific setting? If Pidgin ships like this by default, I definitely agree it's a UI bug which should be filed upstream. Preferences enabled by default with a high probability of being very annoying should *not* be difficult to find and disable.

Karol Gusak (groadin) said : #14

@X Y: some people wants these notifications, including me. Yes it is annoying that status change is notificated by default, but I googled, and switched it off - no problem (actually I should figure out that this kind of setting is in plugin's configuration). And notifications in Ubuntu 9.04 are way better than before. Thanks for cool distro :-).

vanity-name (azalathemad) said : #15

Yeah this isn't a Pidgin problem, they have every right to put in a notification option.
The issue is that there *really* should exist an Ubuntu config option to globally disable libnotify/notifyOSD.
I use Jaunty, is this done in Karmic?