booting issue

Asked by Francene DeShields on 2010-06-19

atempted to upgrade to 10.4 but found many issues that I would not know how to resolve. I am a new user of ubuntu. uninstalled 10.4 and reinstalled 8.04. have had issues every since. It took several tries before I was able to reinstall. Now, sometimes ubuntu loads and freezes, other times it does not boot and occasionally it will boot. Error message is operating system not found. this is one of the times that ubuntu booted.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pidgin Edit question
Assignee:
No assignee Edit question
Solved by:
Tom
Solved:
2010-06-19
Last query:
2010-06-19
Last reply:
2010-06-19
Tom (tom6) said : #1

Hi

Presumably you installed from an Ubuntu 8.04 Cd? If you have any Ubuntu Cd please could you use it as a bootable Cd next time you have troubles booting in. Before logging out today it might be worth skim-reading some of this link
https://help.ubuntu.com/community/LiveCD

Please let us know how this goes
Good luck and regards from
Tom :)

Is this a dual boot or a single boot?

As far as I know it is a single boot. When I installed the 10.4 I selected to overwrite 8.04 but I uninstalled the 10.4 by choosing the uninstall icon.

________________________________
From: actionparsnip <email address hidden>
To: <email address hidden>
Sent: Sat, June 19, 2010 1:00:20 PM
Subject: Re: [Question #115121]: booting issue

Your question #115121 on pidgin in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/pidgin/+question/115121

actionparsnip requested for more information:
Is this a dual boot or a single boot?

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+source/pidgin/+question/115121

You received this question notification because you are a direct
subscriber of the question.

Tom (tom6) said : #4

Hi :)

When you are posting into here please use the links in the email to actually surf into the launchpad site so that you can write into the comment sectoin at the bottom of your thread here. Replying to emails means we get all the bit that we sent you and that is already here so it often gets very confusing too fast. Don't worry tho, we all did soemthing like that when we first started using Launchpad.

Please can you open a terminal console to get a command-line
https://help.ubuntu.com/community/UsingTheTerminal#Starting%20a%20Terminal
and please give us the result of this command

sudo fdisk -l

where "-l" is a lower-case "-L". The "sudo" part will make it ask you for your normal user password, not your SuperUser one and it wont give any stars as you type. Hopefully the output should show us how your drive is currently partitioned and also show us if there is something we can do to tidy things up a bit. Copy&paste is good for this but the command-line doesn't let us use keyboard shortcuts to do that so you have to use right-click menu with the mouse.
Good luck and regards from
Tom :)

the cd came with pc. it is a recovery media cd

I'd boot to the liveCD and reinstall grub:
https://help.ubuntu.com/community/Grub2

Tom (tom6) said : #7

Hi :)

Wow!! An Ubuntu Recovery Cd??

If you don't have an Ubuntu Cd please could you make one? First download Ubuntu from
http://www.ubuntulinux.org/

Then this guide can help you make an Ubuntu Cd using a cheap blank Cd (the cheaper the better usually, oddly)
https://help.ubuntu.com/community/BurningIsoHowto

Anyway, while the downloading is going on or even before that please could give us the output of

sudo fdisk -l

Thanks and regards from
Tom :)

Tom (tom6) said : #8

Hi again :)

Err, Ubuntu does get pre-installed by some hardware manufacturers such as Dell and a few others but it is still quite rare to find one. Mostly machines have Windows pre-installed and so the Recovery Cd is almost always a Windows Cd and quite dangerous. Hopefully as more machines get shipped with Ubuntu already pre-installed then presumably we can expect to see more Recovery Cds being Ubuntu ones that allow you to get to a working desktop without installing or over-writing anything on your hard-drive. If you suspect your Recovery Cd is probably a Windows one then it might be best to avoid using it at all.

Good luck and regards from
Tom :)

francene@francene:~$ sudo fdisk -l
[sudo] password for francene:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

   Device Boot Start End Blocks Id System
/dev/sda1 1 4 32098+ de Dell Utility
/dev/sda2 * 5 9546 76646115 83 Linux
/dev/sda3 9547 9729 1469947+ 1b Hidden W95 FAT32

Disk /dev/sdc: 128 MB, 128450560 bytes
8 heads, 32 sectors/track, 980 cylinders
Units = cylinders of 256 * 512 = 131072 bytes
Disk identifier: 0x25e59e20

   Device Boot Start End Blocks Id System
/dev/sdc1 * 1 980 125424 6 FAT16
francene@francene:~$

Tom (tom6) said : #10

HI :)

That is looking quite good. I was expecting a lot more partitions with the main one being far too small. So now i am at a bit of a loss for what is causing the problem. I think it is worth trying to reinstall grub but first lets try grub1 since this is Ubuntu 8.04. The newer grub2 should also work but we know that grub1 used to work so lets see if we can fix that one again.

This guide might help but you can do these commands straight from the Ubuntu you have already booted into, you don't need to use a LiveCd for this.
https://help.ubuntu.com/community/DualBoot/Grub#Ubuntu%209.10%20&%20earlier

On a linux command-line try

sudo grub

to get to a grub1 command-line rather than the linux one. On the grub command-line try

find /boot/grub/stage1

this should give the result

hd (0,1)

in which case these commands should fix the problem (hopefully)

root (hd0,1)
setup (hd0)
quit

If the result of the "find" command gave a different result then the first of those 3 commands should be a little different. If none of this works then lets try fixing the problem by reinstalling grub2 instead.
Good luck and regards from
Tom :)

Tom (tom6) said : #11

Hi :)

I am not sure how well it is going there. and have thought of an alternative reason for things going wrong during bootup. When booting-up do you get a menu listing a few different choices for how to boot into Ubuntu along with some other choices such as "Memtest" and things? If so then please try the 2nd Ubuntu option, this should have "recovery mode" near the end of it's line. The recovery mode has a few useful tools well worth trying out, particularly the "fix broken packages" option. You can also run this from inside your Ubuntu by going up to the top taskbar/panel and click on

System - Adminstration - Synaptic

and in Synaptic's "Edit" menu choose "Fix broken..." and then click on the "Apply" button. Hopefully this should help? Did it appear to do anything or was it very fast? Was the "Apply" button greyed out so that you couldn't click on it?

Ok, i plugged the numbers you gave us into a spreadsheet and found that
sda1 = 25 Mb
sda2 = 78.5 Gb
sda3 = 1.5 Gb

The sdc drive is probably a Usb-stick or something and has been set-up to work well with Windows or Ubuntu equally well. It is looking unusually perfect if anything! The only thing missing is a swap partition but i have a suspicion that you probably don't need one. On a linux command-line the command

free -m

should show how much ram (it calls it "Mem") your machine has. If it shows over 1Gb then you probably don't need a swap partition. If you do 'need' one then we can help you sort that fairly easily but only from a LiveCd. At worst it is not-urgent and shouldn't be causing the problems you have been having.

It might be good to check to see which release of Ubuntu your machine currently thinks it is running
but i don't know a good command for that. The best i can remember is

uname -a

but that doesn't quite do what i want. It does show which kernel you are using which might be helpful.

Anyway, please let us know how the "fix broken packages" in Synaptic went
Good luck and regards from
Tom :)

ffrancene@francene:~$ free -m
             total used free shared buffers cached
Mem: 1000 935 65 0 14 387
-/+ buffers/cache: 533 467
Swap: 0 0 0
francene@francene:~$ uname -a
Linux francene 2.6.24-27-lpia #1 SMP Wed Feb 17 22:14:54 UTC 2010 i686 GNU/Linux
francene@francene:~$
results of memory and release i am running

I HAVE LOOKED FOR LIVE CD FOR 8.04 EVERYTHING IS FOR 10.4. I REALLY DON'T WANT TO USE 10.4 . IT DOESN'T RECOGNIZE MY WIRELESS CARD.

Tom (tom6) said : #14

Hi

Grrr, yes the website has changed quite radically recently and i am having trouble finding the 8.04 myself too now. Sorry about this! It is really annoying me too!

With 1Gb of ram it might be a good plan to sort out a swap partition at some point but you can do that from the LiveCd of just about any version of linux, it doesn't even have to be Ubuntu at all! I would download sliTaz (30Mb rather than the usual 700-800Mb of Ubuntu) and make a Cd of that.
http://distrowatch.com/table.php?distribution=slitaz
Note that a LiveCd session does not change what you have installed on your machine except where you specifically tell it to change something. The idea is to be able to use LiveCd on a machine and then reboot back into the normal OS that machine uses leaving no trace of the LiveCd session.

If you already have an Ubuntu Cd even if it is the 10.04 one then we could use that for the LiveCd session. If you don't already have an Ubuntu Cd then it might be faster to download and make a sliTaz Cd instead.

Whichever distro you do have as a Cd it doesn't matter if the wireless works because you can use GPartEd to resize the linux partition (sda2) down by 2Gb and create a new "linux swap" in that 2Gb space without needing to access the internet. GPartEd is normally inside the the menu's somewhere like "System Tools" or "Accessories" or something like that. In earlier releases of Ubuntu it used to be called "Partition Editor" but 10.04 and most other distros call it "gparted" in the desktop's menus.

Many apols and regards from
Tom :)

Best Tom (tom6) said : #15

Hi again

I still can't find it. Lets try to fix the grub1 from inside your current Ubuntu 8.04 without worrying about trying to get a LiveCd (for now, it would be good to have one later)

Ok, so on a command-line try this

sudo grub

The command-line should look different now. Just before the blinking cursor it should say something like "grub >" instead of the typical linux command-line's "user@desktop:~$". Ok, so now on the grub's command line this should help us find out if grub1 is still accessible ..

find /boot/grub/stage1

this should give the result = hd (0,1) in which case these 3 commands should hopefully fix the booting problem.

root (hd0,1)
setup (hd0)
quit

Hopefully the "quit" command at the end should put you back onto a normal linux command-line again? If not then just closing that window should do the same job of closing grub.

Attacking the same problem from a different angle have you been able to try the "fix broken packages" approach either from inside Ubuntu using Synaptic or else during reboot using "recovery mode"?

Regards from
Tom

Tom
Thanks so much for your patience and perseverence. I believe we have resolved the issue. I have not tried to fix broken packages.

Tom (tom6) said : #17

Hi :))

That sounds good but getting a Cd you can use as a LiveCd is still fairly important. The linux-command-line and even many of the system packages/programs are the same in all the various distros (versions of linux) such as Ubuntu, sliTaz and so on. Getting a Cd you can use as a LiveCd can help deal with a variety of fairly rare problems such as this one.

Congrats if that all worked.
Good luck and lets hope the reboot goes smoothly :) Please let us know how it goes!
Many regards from
Tom :)