Firefox blocked Icetea Plug-in, how do I unblock?

Asked by Larry Williams on 2012-04-04

On April 2nd, Firefox blocked my Icetea plug-in. Now my browser doesn't display any java applets. I run lucid 10-04 and ALL UPDATED are current, according to Update Manager, even after "check".

Please help, stock quote graphs and weather radar loops no longer work.

Thanks in advance

Larry

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openjdk-6 Edit question
Assignee:
No assignee Edit question
Solved by:
Larry Williams
Solved:
2012-04-11
Last query:
2012-04-11
Last reply:
2012-04-04

Can you give the output of:

lsb_release -a; uname -a; apt-cache policy firefox

Thanks

Larry Williams (larrywilliams) said : #2

larry@larry-desktop:~$ lsb_release -a; uname -a; apt-cache policy firefox
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.4 LTS
Release: 10.04
Codename: lucid
Linux larry-desktop 2.6.32-40-generic #87-Ubuntu SMP Mon Mar 5 20:26:31 UTC 2012 i686 GNU/Linux
firefox:
  Installed: 11.0+build1-0ubuntu0.10.04.2
  Candidate: 11.0+build1-0ubuntu0.10.04.2
  Version table:
 *** 11.0+build1-0ubuntu0.10.04.2 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
        500 http://security.ubuntu.com/ubuntu/ lucid-security/main Packages
        100 /var/lib/dpkg/status
     3.6.3+nobinonly-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
larry@larry-desktop:~$

What message do you get to say it it blocked?
Do you have any blocking addons?

Larry Williams (larrywilliams) said : #4

I don't get any message now, but when firefox blocked it, firefox gave me a message that it contained a security risk and they were blocking it. Today I learned that it was blocked in error and firefox fixed their problem, but didn't fix mine.

It wasn't "broke" in the first place and they"fixed" it. Yet they didn't un-block it and I don't know how to. I did go to firefox's check your plug-ins and it showed that it was not en-abled, so I clicked the enable button and tried it and got the same result. So I went back and clicked it again to put it back where it was.

It was working fine before they blocked it. I keep my system current and up to date, I install all updates as soon as the Update Manager informs me that they are available, as indicated by the above information.

Is it possible to just delete the plug-in and then, using apt, re-install it? Will that make the problem go away?

michael (yellupcm-gmail) said : #5

Have you gone to Tools+Add-ons+Plugins and enabled IceTea plug in? It's working on mine after I did that.

Larry Williams (larrywilliams) said : #6

Michael
yes I did. That's what I meant when I said , above, I did go to firefox's check your plug-ins ... and clicked "enable".

If you want Oracle Java, you can run:

cd $HOME; wget http://dl.dropbox.com/u/8850924/install32bitJava; chmod +x ./install32bitJava; sudo ./install32bitJava

Larry Williams (larrywilliams) said : #8

I did a dpkg -l | less
I see:
icetea-6-jre-cacao 6b20-1.9.13-0ubuntu1~10.04.1
icetea6-plugin 6b20-1.9.13-0ubuntu1~10.04.1
java-common 0.34

Will I have to delete anything before I start the "wget and install" sequence?

No, just go for it...

OK, I ran the wget command as recommended and it seemed to run successfully, but that did not fix the problem.

I wonder if the images I've been looking at and assuming they were java applets, are actually from the flash plug-in. Is it possible that the flash plug-in was affected by this block? I have no idea, I'm just guessing. What I do know is, everything worked before I got the block message from firefox. Now none of it works.

In the past, if I got a stock quote using google financial, in addition to the quote (text), I got a graph of the days activity, now I don't get the graph with the quote.

Now that I look closer at the wget command responses, it didn't end successfully! Here's how it ended.

Unpacking unp (from .../archives/unp_1.0.15_all.deb) ...
Processing triggers for man-db ...
Setting up unp (1.0.15) ...

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Exiting with failure status due to previous errors
./jre-7u3-linux-i586.tar.gz
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Exiting with failure status due to previous errors
mv: cannot stat `/home/larry/jre1.7.0_03/': No such file or directory
update-alternatives: error: alternative path /usr/lib/jvm/jre1.7.0_03/bin/java doesn't exist.
There is only one alternative in link group java: /usr/lib/jvm/java-6-openjdk/jre/bin/java
Nothing to configure.
./install32bitjava: line 12: cd: /usr/lib/chromium-browser/plugins: No such file or directory
larry@larry-desktop:~$

Sam
I don't understand what you're asking of me. I got your email but I don't
see a question.

Are you asking for more information or what?

Larry

On Thu, Apr 5, 2012 at 7:20 PM, Sam_
<email address hidden>wrote:

> Your question #192640 on openjdk-6 in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/openjdk-6/+question/192640
>
> Project: firefox in Ubuntu => openjdk-6 in Ubuntu
>
> --
> You received this question notification because you asked the question.
>

--
As A Child, My Dad Always Told Me To Never Trust Anyone That Didn't Trust
Me.
He Said, "They Suspect You Of Doing What They Themselves Would Do, Given
The Opportunity"!

Forgive me for the delay, I'm an old man, 74 years old, and the frustration got to me. But I'm back to try again. here's where I am now. I have downloaded jre-6u31-linux-i586.bin and installed it in my home directory. When I got to the part in the instructions that cover "enable and configure", I got a bit confused. Seems my brain isn't as swift as it use to be. I'm almost ashamed to admit I used to be a hardware tech for a large computer company.

I still help on enable and configure.

Larry

I guess we should close this out. Today I solved the problem by downloading and installing Google Chrome Browser and it works as well as Firefox did, (faster, too), before they started dinking around with it.

I intend to upgrade Ubuntu 10.04 LTS to 12.04 LTS as soon as the stable version is available anyway. What I learned from this is Chrome should be my default browser instead of Firefox.

My thanks to all who tried to help me solve this problem.

Larry Williams