X window system don't starts after installing nvidia-graphics driver

Asked by Marc Mauri Alloza on 2010-05-09

Hi, I'm having a problem with my kubuntu.

I've installed kubuntu 10.04 LTS, then I've installed the nvidia-current propietary drivers. I rebooted and everything was working fine. Then I've made the last updates for kubuntu 10.04 which includes a new kernel. After that I rebooted and in startup X.org don't start I've read the X.org log and it says it can't load the kernel modules of the nvidia-current driver. I have done a new fresh install and I'm using nouveau drivers as a workarround but I would like to use the nvidia-current drivers to get 3D acceleration.

Is this a bug or I've done something wrong?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Last query:
2010-05-27
Last reply:
2010-05-27

How did you install the driver?

Using jockey.

2010/5/9 actionparsnip <email address hidden>

> Your question #110344 on nvidia-graphics-drivers in ubuntu changed:
>
> https://answers.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+question/110344
>
> Status: Open => Needs information
>
> actionparsnip requested for more information:
> How did you install the driver?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
>
> https://answers.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+question/110344
>
> You received this question notification because you are a direct
> subscriber of the question.
>

ko try this:

sudo nvidia-xconfig

Then reboot.

As I see, the problem is that the nvidia-current package is incompatible with the latest kernel some some reason. I know this because I booted with the old kernel and It worked.

I've tried sudo nvidia-xconfig and the only think it made is that X now don't start, neither in the new neither in the old.

boot to recovery root console and run this:

sudo apt-get install --reinstall dkms

then reboot, if you get nowhere try:

sudo add-apt-repository ppa:nvidia-vdpau/ppa; sudo apt-get update; sudo apt-get update; sudo apt-get installl nvidia-glx-185

I assume your nvidia chip is > 6150

Should be ok.

Can you help with this problem?

Provide an answer of your own, or ask Marc Mauri Alloza for more information if necessary.

To post a message you must log in.