Which directory is mapped to the desktop

Asked by janf on 2008-02-11

On my desktop I see the contents of my home dir.
I would expect to see the contents of <homedir>/Desktop or <homedir>/Skrivebord (in danish).
Can I fix this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
Albert Damen
Solved:
2008-02-11
Last query:
2008-02-11
Last reply:
2008-02-11
Russell Phillips (ignissport) said : #1

Your desktop will default to your home directory if your ~/Desktop (or ~/Skrivebord) directory is un-writeable. Do a chmod 755 and a chown to make it yours and see if that helps.

It is possible to make the desktop display the content of your home directory. Open gconf-editor (press alt+f2 and type it) and navigate to /apps/nautilus/preferences and see if desktop_is_home_dir is checked. Uncheck it if it is.

janf (janf) said : #3

I changed ~/Desktop from 700 to 755. Ownership was janf:janf which is
OK. Reboot. No change.

janf (janf) said : #4

/apps/nautilus/preferences was already unchecked. I checked it, rebooted, unchecked, reboot. No change.

Jo-Erlend Schinstad skrev:
> Your question #24381 on nautilus in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/24381
>
> Jo-Erlend Schinstad proposed the following answer:
> It is possible to make the desktop display the content of your home
> directory. Open gconf-editor (press alt+f2 and type it) and navigate to
> /apps/nautilus/preferences and see if desktop_is_home_dir is checked.
> Uncheck it if it is.
>
>

Best Albert Damen (albrt) said : #5

The mapping of your desktop is configured in the file ~/.config/user-dirs.dirs
On my English system, the desktop directory setting is XDG_DESKTOP_DIR="$HOME/Desktop". You probably need to use $HOME/Skrivebord.
Take a look in ~/.config/user-dirs.dirs and see if you can correct the setting. If you don't succeed, please paste the content of the file here.

janf (janf) said : #6

Thanks. This solved the problem. Had to reboot to make everything behave correctly.