Ubuntu

Dropbox installation stuck at downloading phase 99percent

Asked by Silvio Traversaro on 2012-06-22

Hi, I'm tryng to install Dropbox on a freshly installation of Ubuntu 12.04, I have added the dropbox repos, and then I try to install the nautilus-dropbox package. The installation then goes on, and the it stucks at the end of downloading, writing on the console Downloading Dropbox... 99%, and never doing anything else. During the same time, I can se a dropbox process by user root taking 100% of the cpu.
A similar issue happens by using the deb downloaded from the website dropbox.com

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nautilus-dropbox Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-22
Last reply:
2012-06-23

You don't need a 'dropbox repo', dropbox is in the official Ubuntu repos.

http://packages.ubuntu.com/precise/nautilus-dropbox

You don't need to add anything at all, may be causing your issue.

Silvio Traversaro (pegua1) said : #2

Yes, I noted afterwards that the package nautilus-dropbox is available also on the official Ubuntu repos, so i removed the http://linux.dropbox.com/ubuntu/ repo and purged all the packages downloaded, then installed the ubuntu package nautilus-dropbox, and the issue was the same, perhaps it was caused by the package I've previous installed, but I could not understand in which way as I purged all the configurations.
I've worked around this directly downloading the dropboxd from the website ( https://www.dropbox.com/install?os=lnx ) in the section "Install Dropbox via command line".

Adam Orwell (anopenid6045) said : #3

I'm having this exact same problem. I just confirmed that this happens on a fresh install of Ubuntu 12.04; after installing, I immediately entered the command "sudo apt-get install nautilus-dropbox". Installation begins, but then hangs when the download gets to 99%.

Just created a bug report from this question.

Same problem (fresh install Ubuntu 12.04).
And yes, you can work it around by downloading the dropboxd via command line but then you don't have the desktop notifications and the icons on your dropbox folder.

Remove this repo you added then run:

sudo apt-get clean
sudo apt-get update
sudo apt-get --purge remove nautilus-dropbox
sudo apt-get --purge autoremove
sudo apt-get --reinstall install nautilus-dropbox

HTH

not working... still stuck at 99%

Silvio Traversaro (pegua1) said : #7

HTH, yes I have done that previously, but the problem persist (as it can be demonstrated by other users having the same problem).
With regard to the workaround, and I have the applet and nautilus icon working, I believe because I have installed in the system (after testing and removing the one from Ubuntu) the package " dropbox ", from the dropbox repo, and then separetly installing dropboxd by command line. Just for the sake of information, I do not recommend this unorthodox workaround, as probably could give some error!

Adam Orwell (anopenid6045) said : #8

So, to be clear - this is a bug in nautilus-dropbox, but there is a temporary workaround.

Workaround procedure:

- Download the Dropbox .deb file from: https://www.dropbox.com/install?os=lnx
- Open the .deb with Ubuntu Software Center and begin installation
- When you see the screen saying "To complete installation, you must start Dropbox", press CANCEL
- Install the dropbox daemon (nautilus-dropbox) using this command (from https://www.dropbox.com/install?os=lnx):
        cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -
- Restart computer

Now you should have Dropbox working, including the notification icon and the Dropbox icon overlays in Nautilus.

Knightnet (jk-launchpad) said : #9

Same problem here. I added some more info to the bug.

pa_card (pa-card) said : #10

I have managed to install mine after following anopenid6045 instructions. Only thing I want to add is that the link he posted is for 64-bit. For 32-bit:

cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86" | tar xzf -

sorry if this was evident to most :)

Adam Orwell (anopenid6045) said : #11

Sorry - you're right! My mistake, should have included both 64-bit and 32-bit commands.

aste (asteinbr) said : #12

for me helps upgrade package libnautilus-extension1a
after the upgrades dropbox starts without problems

I confirm this. Upgrade libnautilus-extension1a does not help. Still stuck @ 99% and uses a lot of CPU.

The procedures listed by anopenid6045 worked for me (eventually). Took me a few full uninstalls and re-installs to get it working right. What people should do first is try to completely remove any traces of it if they have a previous installation that has failed to work.

I tried doing all of this with a partial install on my system and this just refused to work. Once I had removed all the erroneous files from previous attempts, it worked fine. But keep in mind, I am still using Ubuntu 10.10.

=^.,.^=

Maverick is EOL, I suggest you upgrade

Adam Orwell (anopenid6045) said : #16

Seems like a lot of people are having this problem, and the original workaround left some information out, so here's an updated version.

Updated workaround procedure:

- Download the Dropbox .deb file from: https://www.dropbox.com/install?os=lnx
- Open the .deb with Ubuntu Software Center and begin installation
- When you see the screen saying "To complete installation, you must start Dropbox", press CANCEL
- Install the dropbox daemon (nautilus-dropbox) using one of these commands (from https://www.dropbox.com/install?os=lnx):
      For 32-bit operating systems:
            cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86" | tar xzf -
      For 64-bit operating systems:
            cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -
- Start the dropbox daemon with this command:
      ~/.dropbox-dist/dropboxd
- Restart computer

clombard (clombard44) said : #17

Hey once the install of dropBox hangs at 99% the software center and update manager does not work...says dpkg locked by another process. Trys a "partial" upgrade then says a software package or link is broken?
I tried some commands and kill -9 the root and user pid...actually the output of
ps -ef | grep dpkg looks identical now on my two ubuntu 12.04 machines but the one that tried to install
dropBox still is not able to install remove or update software...?
?

clombard (clombard44) said : #18

yeah Adam those workarounds are not too relieable.
Ahh...remember the good ole days of 10.10 when the software
center had konqueror, OpenOffice and DropBox...and they all worked.

Adam Orwell (anopenid6045) said : #19

The workaround works best on a fresh install. There's been some discussion in the bug report about what to do if you've already installed Dropbox or you're getting dpkg errors:

https://bugs.launchpad.net/ubuntu/+source/nautilus-dropbox/+bug/1016559

Can you help with this problem?

Provide an answer of your own, or ask Silvio Traversaro for more information if necessary.

To post a message you must log in.