why fix mountall: Evnet failed with different way?

Asked by wally on 2015-02-05

Hi, I recently looking my custom ubuntu have a error message "mountall: Event failed" since I change my kernel.

the root cause is /proc/slabinfo is not generated anymore by my new kernel; but /etc/init/mounted-proc have following code:
    chmod 0400 "${MOUNTPOINT}"/slabinfo
this make mountall output the error message.

I've noticed this issue is fixed in version 2.54ubuntu1, using following code:
    if [ -e "${MOUNTPOINT}"/slabinfo ]; then
        chmod 0400 "${MOUNTPOINT}"/slabinfo
    fi

my question is there also already same fix for "mountall: Event failed" in /etc/init/mounted-debugfs:
    chmod 0700 "${MOUNTPOINT}" || true

why we not using the SAME way to fix the SAME problem?

maybe we should change /etc/init/mounted-debugfs to:
    if [ -e "${MOUNTPOINT}" ]; then
        chmod 0700 "${MOUNTPOINT}"
    fi

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu mountall Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2015-02-06
Last query:
2015-02-06
Last reply:
2015-02-05
Best Manfred Hampl (m-hampl) said : #1

I suggest you create a bug report

wally (wally-yeh) said : #2

Ok, I open a bug report for it, but I'm not sure we can call a suggestion as a bug or not.

wally (wally-yeh) said : #3

Thanks Manfred Hampl, that solved my question.