modemmanager does not install on 15.04

Asked by Bob Bosak on 2015-05-12

Trying to build OS off of a mini-iso of 15.04 and modemmanger will not install. Even after all dependencies are installed fails with an error pointing to a ficticious file that should be in init.d, a script file that has never been there in any OS I have ever built. I need this issue resolved and can see is an ongoing problem for not not me but everyone out there. This problem is so terrible it will prevent systems from booting to the desktop. Please send a fix for everyone. Thank you!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu modemmanager Edit question
Assignee:
No assignee Edit question
Last query:
2015-05-14
Last reply:
2015-05-14

Make the file using touch, or search http://packages.ubuntu.com to see if a package provides the file

Bob Bosak (bbosak2143) said : #2

Using Touch? Please explain that one as I am unfamiliar with that on a PC.
I did do a search for initscripts for modemmanager and came up nil and is
 why I posted this. Is very upsetting as the entire boot process is
demolished for something this stupid! So, you bet want to fix it and need
help. I see many others out here with this same problem and am sure they
would also be happy for it to be solved!

On Wed, May 13, 2015 at 5:36 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #266854 on modemmanager in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/modemmanager/+question/266854
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Make the file using touch, or search http://packages.ubuntu.com to see
> if a package provides the file
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/modemmanager/+question/266854/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/modemmanager/+question/266854
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #3

What is the exact file name in the error message?

The Unix command "touch" creates a file or modifies its access date.

If the system complains that it cannot find file /abc/def, the you can either search on http://packages.ubuntu.com/ to identify a package that should install that file and install that package, or you can use the command "touch /abc/def" to create an empty file with that name. (caveat: there is required syntax for the files in /etc/init.d, so creating an empty file there might result in other problems.)

Can you help with this problem?

Provide an answer of your own, or ask Bob Bosak for more information if necessary.

To post a message you must log in.