Epson L210 multifunctional printer, scanner is not working.

Asked by Aravind Gopal on 2016-08-01

Installed lsb package and installed epson's drivers. Not working. Printer setting identifies printer correctly(EPSON-L210-Series). but in Simple scan, an error"unable to connect to scanner" arise. when tried to change scanner there the scanner name is given as "Epson(unknown model)". It seems that there is something wrong with hardware detection/identification and/or communication gap between printer and scanner modules.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lsb Edit question
Assignee:
No assignee Edit question
Solved by:
Aravind Gopal
Solved:
2017-03-01
Last query:
2017-03-01
Last reply:
2017-02-25
Brian Murray (brian-murray) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug.

Please see the comments from #116 , #126 etc in bug
https://bugs.launchpad.net/ubuntu/+source/lsb/+bug/1536353

I thought that bug is for printers only and not MFD.

I am suffering from this issue for more than 10 MONTHS.
Even after providing with the screenshots and log files .

Till now there isn't any technical guidance.. to solve a partial problem with an essential hardware.
AND PROBLEM PERSISTS.. I cannot scan from LINUX.(No problem with Win10)

Even though I a like a Canon MFD(not supported by Linux), I opted Epson MFD because Linux supported it.
I am a fan of Linux. Now Its like Ubuntu is forcing me to Switch OS.

PLease Help

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

When this problem will have a solution...
 Its a sort of escapism...
A bug turned in to question and then closing the question without answering any thing..
Expect more user-friendliness, professionallism and responsibility from the reputed launch pad team..
Please help

Manfred Hampl (m-hampl) said : #5

Have you installed the Epson scanner package from http://support.epson.net/linux/iscan_c.php?version=1.0.4

Have you tried using the Epson scan utility iscan ?

Please provide also basic information like Ubuntu release on your system, architecture (32 or 64 bit), etc.

Thank you for the response..
Its Kubuntu 16.04 64 bit with latest updates.
Latest Epson scanner package from http://support.epson.net/linux/iscan_c.php?version=1.0.4 Installed.

Contacted sane , given required information and their supporting team confirmed that the problem is with kernel USB layer. ans asked to contact the maintainer.
Contacted the maintainer. "AVASYS CORPORATION <email address hidden>"
But till now no response.

tried Earlier version 14.04 , and is is fine for MFD scanner and printer arw working. , but graphics system makes system slow and unrefined.

16.04 mfd not working , but more refined and fast.

anyway unusable , epson mfd support degraded in 16.04.

Its a nightmare for nearly 10 months..

Once more Thank you for your response..

Manfred Hampl (m-hampl) said : #7

If the sane team tells that the epson driver has problems with current kernel versions, then you should not blame Ubuntu.

Have you tried the iscan program from epson?

Iscan fails to communicate with scanner. But printer driver prints.
 I am a casual user of Linux.
It seems a problem arise due to change in LSB package.

After posting the problem comment #96 on 2016-08-01
https://bugs.launchpad.net/ubuntu/+source/lsb/+bug/1536353

the launchpad team asked for many information an I provided that with even pictures/ screenshots, files, log files, etc

In comment #126 on
they said ""No issue with Epson printer, """"problem with scanner""""

$ dpkg -l | grep -i epson

ii epson-inkjet-printer-escpr 1.6.5-1lsb3.2 amd64 Epson Inkjet Printer Driver (ESC/P-R) for Linux
ii iscan 2.30.2-2 amd64 simple, easy to use scanner utility for EPSON scanners"" 2016-08-24.

After that a terrifying/manner-less science is maintained from launchpad team till now.

If they are inefficient to rectify the problem or they need more time or they want me to contact someone else. They should inform. Hiding is not good Personality.

Mean while I posted another bug. And that is "easily" turned to a question.

When I lost hope(wasted 6 months) in launchpad, I contacted Sane support(in feb 2017).
They responded quickly and asked for more information and I provided all that they needed. And finally they said Its a problem with the kernel USB layer. And advice me to contact the maintainer(also provided the console command to know the maintainer).

So I contacted the maintainer.

I don't know whether it will solve the problem and improve the LINUX.

I don't know whether anything else is needed to awake the maintainer.

 I am an advocate and fan of Linux for nearly 20 years. So its painful to switch OS.

Hope you will provide support to solve this bug and make Linux better.

 Thank You for your response..

Manfred Hampl (m-hampl) said : #9

I did not expect that you put information about your "scanner not detected" problem into a bug report about "Epson printer driver not installable".

Have you tried accessing your MFD device from xsane via the epkowa entry?

The link that I provided in my previous post contains a higher version of iscan - 2.30.3-1. Can you try that one?

iScan is the same version(2.30.3-1). sane support also asked about that.

According to the advice from sane support, I did the following processes,

 - comment out the epkowa backend in /etc/sane.d/dll.d/iscan
 - add `usb 0x4b8 0x8a1` to /etc/sane.d/epson2.conf

But didn't solved the problem.

I dont know whether it is same as your advice "Have you tried accessing your MFD device from xsane via the epkowa entry?."

Manfred Hampl (m-hampl) said : #11

Your output

$ dpkg -l | grep -i epson

ii epson-inkjet-printer-escpr 1.6.5-1lsb3.2 amd64 Epson Inkjet Printer Driver (ESC/P-R) for Linux
ii iscan 2.30.2-2 amd64 simple, easy to use scanner utility for EPSON scanners"" 2016-08-24.

shows iscan version 2.30.2-2 which is lower than 2.30.3-1

The recommendation with the epkowa entry is more or less the opposite from what I wanted you to try.
If you select the other radio button in xsane in the screen that looks like this https://bugs.launchpad.net/ubuntu/+source/lsb/+bug/1536353/+attachment/4725036/+files/ScanVsPrinter%20setting1.png
what happens then?

1. "shows iscan version 2.30.2-2 which is lower than 2.30.3-1" was an old comment. Aug 2016
Updated to latest version as soon as epson released the new one. see comment #129 and #130 in Bug #1536353

2. regarding "select other radio button in xsane" nothing happens. could not scan or same result.

3. ReInstalled latest XUbuntu (16.04.2) with latest Epson drivers. Result is the same. Coulds not scan. see screenshot photo pasted in Bug #1536353 and Bug #1608604.

4. Please advice where to post this bug. In Bug #1536353 and/or Bug #1608604 or file a new Bug
Or ONLY question is needed..

5. "The recommendation with the epkowa entry is more or less the opposite from what I wanted you to try." please give the commands and information to do the analysis.

Manfred Hampl (m-hampl) said : #13

It is extremely inconvenient if the supporters have to check two bug reports and a question document to pick together all your information.
In my opinion it is nonsense to put screen shots about "scanner not working" into a bug report "epson printer driver cannot be installed due to changes with lsb", which has already been resolved - Bug #1536353
Similar with respect to the other bug report which is already marked as invalid - Bug #1608604

How to attach a file that here. ???/

Screenshot shows how Printer software identifies the Hardware correctly and scan software(s) fail to identify the same device Ubuntu 16.04.02 behaves differently with the same hardware.

Simple scan fails, xsane fails, iscan fails... and the mystery continues after 6 months.

Cannot identify the reason?

See the Bug #1536353, I provided all needed information. But no-one even commented about the exact cause(at least probable ) of the problem. no one informed that they need more information or time or file the bug as question or as new bug...

What to do? please help..

I attach a screen shot because one picture can explain the situation better than words.
I didn't find any option/way to attach file in this question page. so I attached it in bug page.. My intention was to provide more information in less time... sorry..

Waiting to support team's advice and support..

Manfred Hampl (m-hampl) said : #17

You cannot add images to a launchpad question document, only to bug reports. This, however, is no reason to create a bug report where no bug (=error in the software) exists.
Your case seems to be caused by certain user settings, and not by the software as such; this it does not qualify for a bug report.

If you want to provide images like screen shots, you can upload them to any image hosting site of your choice and provide a link to that page.

Thank U
I will try Image Hosting Site..
Sane support advised me to add user is in the scanner group. If it is not part of that.
By default user wasn't part of scanner group a. so I added that.
If This is a flaw, it may be rectified by adding it automatically by the software. (for better user-friendliness of Linux).

But problem persists as it is.. cannot scan.

Then what to do clear problems with user setting.

"groups|grep scanner" gave the result
"swami adm cdrom sudo dip plugdev lpadmin scanner sambashare"

Is it OK, any thing missing or excess?

please inform what to do to clear problems with user setting.

Problem Solved.
According to my experience, solution is achieved through..

Prerequisite: Install Sane, latest epson drivers, xsane
Reasons for the problem.

Reason 1. Linux failed to add user name to scanner group.
Solution: In terminal/console execute the command.
$ groups | grep scanner

If this produced no output, you can fix that with

  $ sudo adduser swami scanner

Note: replace "swami" with your user name

Reason 2. Sane have certain problem/bug
Solution : Update sane to the latest developmental release. by using the command.
sudo add-apt-repository ppa:rolfbensch/sane-git
sudo apt-get update

link: https://launchpad.net/~rolfbensch/+archive/ubuntu/sane-git

Reason3: Kernel have some bug or limitations.
Upgrade Kernal to at least 4.4.0.62

It seems there is bug in driver installation software, sane and kernel.

If there is any short coming or problem in this please inform

Thank U