Ubuntu 14.04 iPhone 5s: Unable to Mount iPhone, error -3 and error -20

Asked by Elaine Armtrong on 2020-04-28

Ubuntu 14.04 & iPhone 5s: Unable to Mount iPhone, Unhandled lockdown error -3 and -20.
tried:
1. sudo apt-get install libimobiledevice-utils ifuse Successful
2. idevicepair unpair && idevicepair pair error pairing device failed with unhandled error code -20
3. sudo ideviceinfo -k successful
4. ideviceinfo ldd -r successful
5. reset iphone (used Erase all content & settings options ) reboot, reconnect USB, same error result

I've learned to use the terminal to type these codes but my iphone is not accessible and will not be mounted.
I have tried suggested solutions but what can I do now?

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu libimobiledevice Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Manfred Hampl (m-hampl) said : #1

Ubuntu 14.04 is no more supported, except for servers with an extended security mainenance contract.

Thanks

On Tue, Apr 28, 2020 at 2:23 AM Manfred Hampl <
<email address hidden>> wrote:

> Your question #690268 on libimobiledevice in Ubuntu changed:
>
> https://answers.launchpad.net/ubuntu/+source/libimobiledevice/+question/690268
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> Ubuntu 14.04 is no more supported, except for servers with an extended
> security mainenance contract.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/libimobiledevice/+question/690268/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
>
> https://answers.launchpad.net/ubuntu/+source/libimobiledevice/+question/690268
>
> You received this question notification because you asked the question.
>

So I should upgrade to which version?

On Tue, Apr 28, 2020 at 2:23 AM Manfred Hampl <
<email address hidden>> wrote:

> Your question #690268 on libimobiledevice in Ubuntu changed:
>
> https://answers.launchpad.net/ubuntu/+source/libimobiledevice/+question/690268
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> Ubuntu 14.04 is no more supported, except for servers with an extended
> security mainenance contract.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/libimobiledevice/+question/690268/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
>
> https://answers.launchpad.net/ubuntu/+source/libimobiledevice/+question/690268
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #4

I suggest upgrading to Ubuntu 18.04, and in a few months an upgrade to Ubuntu 20.04 (published last week) should be possible.

Thank you for sharing this with me today

On Tue, Apr 28, 2020 at 9:13 AM Manfred Hampl <
<email address hidden>> wrote:

> Your question #690268 on libimobiledevice in Ubuntu changed:
>
> https://answers.launchpad.net/ubuntu/+source/libimobiledevice/+question/690268
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> I suggest upgrading to Ubuntu 18.04, and in a few months an upgrade to
> Ubuntu 20.04 (published last week) should be possible.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/libimobiledevice/+question/690268/+confirm?answer_id=3
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
>
> https://answers.launchpad.net/ubuntu/+source/libimobiledevice/+question/690268
>
> You received this question notification because you asked the question.
>

Can you help with this problem?

Provide an answer of your own, or ask Elaine Armtrong for more information if necessary.

To post a message you must log in.