imagemagick 8:6.9.7.4+dfsg-16ubuntu6 source package in Ubuntu

Changelog

imagemagick (8:6.9.7.4+dfsg-16ubuntu6) bionic; urgency=medium

  * Stop installing the Debian-specific .desktop for the display program.
    (LP: #1740741, LP: #1740743, LP: #1717951, LP: #1615435,
    Closes: #675617, #677318)

 -- Jeremy Bicha <email address hidden>  Fri, 06 Apr 2018 09:20:04 -0400

Upload details

Uploaded by:
Jeremy Bicha
Uploaded to:
Bionic
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
graphics
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Bionic release main graphics

Downloads

File Size SHA-256 Checksum
imagemagick_6.9.7.4+dfsg.orig.tar.xz 8.5 MiB 47fb2cdd26f5913318c4504f16ea363e04d1f400dda9ec52e461ab661d724026
imagemagick_6.9.7.4+dfsg-16ubuntu6.debian.tar.xz 251.3 KiB 4b8d39304a0f48410674820fd78ced6d8fc235274294aefcc7a5b486fe74cc7d
imagemagick_6.9.7.4+dfsg-16ubuntu6.dsc 5.1 KiB a02d890d078444e0f890321e450df3118bd9c0bc3f72d860495396029e518f98

View changes file

Binary packages built by this source

imagemagick: No summary available for imagemagick in ubuntu cosmic.

No description available for imagemagick in ubuntu cosmic.

imagemagick-6-common: image manipulation programs -- infrastructure

 imagemagick-common contains the filesystem infrastructure required for
 further installation of imagemagick in any configuration; it does not provide
 a full installation of binaries, libraries, and utilities
 required to run imagemagick.
 .
 This package is independent of channel depth.

imagemagick-6-doc: document files of ImageMagick

 This package contains the document files shipped with ImageMagick, a software
 suite to create, edit, and compose bitmap images.
 .
 Documentations includes html manuals, examples files, and doxygen generated API
 documentation.

imagemagick-6.q16: No summary available for imagemagick-6.q16 in ubuntu cosmic.

No description available for imagemagick-6.q16 in ubuntu cosmic.

imagemagick-6.q16-dbgsym: No summary available for imagemagick-6.q16-dbgsym in ubuntu cosmic.

No description available for imagemagick-6.q16-dbgsym in ubuntu cosmic.

imagemagick-6.q16hdri: No summary available for imagemagick-6.q16hdri in ubuntu cosmic.

No description available for imagemagick-6.q16hdri in ubuntu cosmic.

imagemagick-6.q16hdri-dbgsym: No summary available for imagemagick-6.q16hdri-dbgsym in ubuntu cosmic.

No description available for imagemagick-6.q16hdri-dbgsym in ubuntu cosmic.

imagemagick-common: No summary available for imagemagick-common in ubuntu cosmic.

No description available for imagemagick-common in ubuntu cosmic.

imagemagick-doc: document files of ImageMagick -- dummy package

 This package contained the document files shipped with ImageMagick, a software
 suite to create, edit, and compose bitmap images.
 .
 This is a transitional package to help migrate systems to the new
 imagemagick-6-doc package.
 .
 This is a dummy package. You can safely purge or remove it.

libimage-magick-perl: Perl interface to the ImageMagick graphics routines

 PerlMagick is an objected-oriented Perl interface to ImageMagick.
 Use the module to read, manipulate, or write an image or image sequence from
 within a Perl script. This makes it very suitable for Web CGI scripts.
 .
 This is the compatibility (wrapper) perlmagick package that
 use the default channel depth.
 .
 This package provides the perl Image::Magick class.

libimage-magick-q16-perl: No summary available for libimage-magick-q16-perl in ubuntu cosmic.

No description available for libimage-magick-q16-perl in ubuntu cosmic.

libimage-magick-q16-perl-dbgsym: debug symbols for libimage-magick-q16-perl
libimage-magick-q16hdri-perl: Perl interface to the ImageMagick graphics routines -- Q16HDRI version

 PerlMagick is an objected-oriented Perl interface to ImageMagick.
 Use the module to read, manipulate, or write an image or image sequence from
 within a Perl script. This makes it very suitable for Web CGI scripts.
 .
 This version of libimage-magick is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).
 .
 This package provides the perl Image::Magick::Q16HDRI class.

libimage-magick-q16hdri-perl-dbgsym: debug symbols for libimage-magick-q16hdri-perl
libmagick++-6-headers: No summary available for libmagick++-6-headers in ubuntu cosmic.

No description available for libmagick++-6-headers in ubuntu cosmic.

libmagick++-6.q16-7: No summary available for libmagick++-6.q16-7 in ubuntu cosmic.

No description available for libmagick++-6.q16-7 in ubuntu cosmic.

libmagick++-6.q16-7-dbgsym: debug symbols for libmagick++-6.q16-7
libmagick++-6.q16-dev: C++ interface to ImageMagick - development files (Q16)

 The Magick++ library is a set of C++ wrapper classes that provides access
 to the ImageMagick package functionality from within a C++ application.
 .
 This package includes header files and static libraries needed to compile
 programs using Magick++.
 .
 This version of libmagick++-dev is compiled for a channel
 depth of 16 bits (Q16).

libmagick++-6.q16hdri-7: No summary available for libmagick++-6.q16hdri-7 in ubuntu cosmic.

No description available for libmagick++-6.q16hdri-7 in ubuntu cosmic.

libmagick++-6.q16hdri-7-dbgsym: debug symbols for libmagick++-6.q16hdri-7
libmagick++-6.q16hdri-dev: C++ interface to ImageMagick - development files (Q16HDRI)

 The Magick++ library is a set of C++ wrapper classes that provides access
 to the ImageMagick package functionality from within a C++ application.
 .
 This package includes header files and static libraries needed to compile
 programs using Magick++.
 .
 This version of libmagick++-dev is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

libmagick++-dev: object-oriented C++ interface to ImageMagick -- dummy package

 The Magick++ library was a set of C++ wrapper classes that provides access
 to the ImageMagick package functionality from within a C++ application.
 .
 This is a transitional package to help migrate systems to the new
 ABI of libmagick++-6 development files for default channel depth.
 .
 This is a dummy package. You can safely purge or remove it.

libmagickcore-6-arch-config: No summary available for libmagickcore-6-arch-config in ubuntu cosmic.

No description available for libmagickcore-6-arch-config in ubuntu cosmic.

libmagickcore-6-headers: low-level image manipulation library - header files

 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package includes the architecture independent header files
 needed to compile programs using MagickCore.
 .
 This package is independent of channel depth.

libmagickcore-6.q16-3: low-level image manipulation library -- quantum depth Q16

 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package contains the C libraries needed to run executables that make
 use of MagickCore.
 .
 This version of libmagickcore is compiled for a channel
 depth of 16 bits (Q16).

libmagickcore-6.q16-3-dbgsym: debug symbols for libmagickcore-6.q16-3
libmagickcore-6.q16-3-extra: No summary available for libmagickcore-6.q16-3-extra in ubuntu cosmic.

No description available for libmagickcore-6.q16-3-extra in ubuntu cosmic.

libmagickcore-6.q16-3-extra-dbgsym: No summary available for libmagickcore-6.q16-3-extra-dbgsym in ubuntu cosmic.

No description available for libmagickcore-6.q16-3-extra-dbgsym in ubuntu cosmic.

libmagickcore-6.q16-dev: low-level image manipulation library - development files (Q16)

 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package includes header static libraries needed to compile
 programs using MagickCore.
 .
 This version of libmagickcore-dev is compiled for a channel
 depth of 16 bits (Q16).

libmagickcore-6.q16hdri-3: low-level image manipulation library -- quantum depth Q16HDRI

 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package contains the C libraries needed to run executables that make
 use of MagickCore.
 .
 This version of libmagickcore is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

libmagickcore-6.q16hdri-3-dbgsym: debug symbols for libmagickcore-6.q16hdri-3
libmagickcore-6.q16hdri-3-extra: low-level image manipulation library - extra codecs (Q16HDRI)

 This package adds support for SVG, WMF, OpenEXR, DjVu and Graphviz to
 MagickCore.
 .
 This version of libmagickcore-extra is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

libmagickcore-6.q16hdri-3-extra-dbgsym: No summary available for libmagickcore-6.q16hdri-3-extra-dbgsym in ubuntu cosmic.

No description available for libmagickcore-6.q16hdri-3-extra-dbgsym in ubuntu cosmic.

libmagickcore-6.q16hdri-dev: low-level image manipulation library - development files (Q16HDRI)

 The MagickCore API is a low-level interface between the C programming language
 and the ImageMagick image processing libraries and is recommended for
 wizard-level programmers only. Unlike the MagickWand C API which uses only a
 few opaque types and accessors, with MagickCore you almost exclusively access
 the structure members directly.
 .
 This package includes header static libraries needed to compile
 programs using MagickCore.
 .
 This version of libmagickcore-dev is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

libmagickcore-dev: No summary available for libmagickcore-dev in ubuntu cosmic.

No description available for libmagickcore-dev in ubuntu cosmic.

libmagickwand-6-headers: image manipulation library - headers files

 The MagickWand API is the recommended interface between the C programming
 language and the ImageMagick image processing libraries. Unlike the
 MagickCore C API, MagickWand uses only a few opaque types. Accessors are
 available to set or get important wand properties.
 .
 This package includes header files needed to compile
 programs using MagickWand.
 .
 This package is independent of channel depth.

libmagickwand-6.q16-3: image manipulation library -- quantum depth Q16

 The MagickWand API is the recommended interface between the C programming
 language and the ImageMagick image processing libraries. Unlike the
 MagickCore C API, MagickWand uses only a few opaque types. Accessors are
 available to set or get important wand properties.
 .
 This package contains the C libraries needed to run executables that make
 use of MagickWand.
 .
 This version of libmagickwand is compiled for a channel
 depth of 16 bits (Q16).

libmagickwand-6.q16-3-dbgsym: debug symbols for libmagickwand-6.q16-3
libmagickwand-6.q16-dev: image manipulation library - development files (Q16)

 The MagickWand API is the recommended interface between the C programming
 language and the ImageMagick image processing libraries. Unlike the
 MagickCore C API, MagickWand uses only a few opaque types. Accessors are
 available to set or get important wand properties.
 .
 This package the static libraries needed to compile
 programs using MagickWand.
 .
 This version of libmagickwand-dev is compiled for a channe
 depth of 16 bits (Q16).

libmagickwand-6.q16hdri-3: image manipulation library -- quantum depth Q16HDRI

 The MagickWand API is the recommended interface between the C programming
 language and the ImageMagick image processing libraries. Unlike the
 MagickCore C API, MagickWand uses only a few opaque types. Accessors are
 available to set or get important wand properties.
 .
 This package contains the C libraries needed to run executables that make
 use of MagickWand.
 .
 This version of libmagickwand is compiled for a channel
 depth of 16 bits with high dynamic range (Q16HDRI).

libmagickwand-6.q16hdri-3-dbgsym: No summary available for libmagickwand-6.q16hdri-3-dbgsym in ubuntu cosmic.

No description available for libmagickwand-6.q16hdri-3-dbgsym in ubuntu cosmic.

libmagickwand-6.q16hdri-dev: No summary available for libmagickwand-6.q16hdri-dev in ubuntu cosmic.

No description available for libmagickwand-6.q16hdri-dev in ubuntu cosmic.

libmagickwand-dev: image manipulation library -- dummy package

 This package included the static libraries needed to compile
 programs using MagickWand.
 .
 This is a transitional package to help migrate systems to the new
 ABI of libmagickwand-6 development files for default channel depth.
 .
 This is a dummy package. You can safely purge or remove it.

perlmagick: Perl interface to ImageMagick -- dummy package

 PerlMagick is an objected-oriented Perl interface to ImageMagick.
 Use the module to read, manipulate, or write an image or image sequence from
 within a Perl script. This makes it very suitable for Web CGI scripts.
 .
 This is a transitional package to help migrate systems to the new
 libimage-magick-perl perl library.
 .
 This is a dummy package. You can safely purge or remove it.