Dual boot selection is wrong

Asked by mikehi on 2012-11-17

12.04 LTS upgrade from 10.04 on 64-bit AMD dual core, dual boot system. 2GB RAM.
In 10.04 had made boot selection to be Win XP in last position.
Changed boot order to make Win XP first on list and this is OK. But boot selection is now second from last.
This is my wife's PC. I need to make automatic boot selection first on list for XP.

How to do this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-11-21
Last query:
2012-11-21
Last reply:
2012-11-19

Can you give the output of:

sudo update-grub; uname -a; dpkg -l | grep linux-image

Thanks

mikehi (silversage) said : #2

Below is what these commands give:

mike@wanda:~$ sudo update-grub; uname -a; dpkg -l | grep linux-image
Generating grub.cfg ...
Found Microsoft Windows XP Home Edition on /dev/sda1
Found linux image: /boot/vmlinuz-3.2.0-33-generic
Found initrd image: /boot/initrd.img-3.2.0-33-generic
Found linux image: /boot/vmlinuz-2.6.32-43-generic
Found initrd image: /boot/initrd.img-2.6.32-43-generic
Found memtest86+ image: /boot/memtest86+.bin
done
Linux wanda 3.2.0-33-generic #52-Ubuntu SMP Thu Oct 18 16:29:15 UTC 2012
x86_64 x86_64 x86_64 GNU/Linux
rc linux-image-2.6.31-16-generic 2.6.31-16.53
Linux kernel image for version 2.6.31 on x86/x86_64
rc linux-image-2.6.31-17-generic 2.6.31-17.54
Linux kernel image for version 2.6.31 on x86/x86_64
rc linux-image-2.6.31-20-generic 2.6.31-20.58
Linux kernel image for version 2.6.31 on x86/x86_64
rc linux-image-2.6.31-21-generic 2.6.31-21.59
Linux kernel image for version 2.6.31 on x86/x86_64
ii linux-image-2.6.32-43-generic 2.6.32-43.97
Linux kernel image for version 2.6.32 on x86/x86_64
rc linux-image-2.6.32-44-generic 2.6.32-44.98
Linux kernel image for version 2.6.32 on x86/x86_64
ii linux-image-3.2.0-33-generic 3.2.0-33.52
Linux kernel image for version 3.2.0 on 64 bit x86 SMP
ii linux-image-generic 3.2.0.33.36
Generic Linux kernel image

----- Original Message -----
From: "actionparsnip" <email address hidden>
To: <email address hidden>
Sent: Saturday, November 17, 2012 3:46 PM
Subject: Re: [Question #214474]: Dual boot selection is wrong

Your question #214474 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/214474

    Status: Open => Needs information

actionparsnip requested more information:
Can you give the output of:

sudo update-grub; uname -a; dpkg -l | grep linux-image

Thanks

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+question/214474

You received this question notification because you asked the question.

sudo dpkg -P linux-image-2.6.31-16-generic
sudo dpkg -P linux-image-2.6.31-17-generic
sudo dpkg -P linux-image-2.6.31-20-generic
sudo dpkg -P linux-image-2.6.31-21-generic
sudo apt-get --purge remove linux-image-2.6.32-43-generic

Reboot to test

mikehi (silversage) said : #4

Performed the suggested commands. Almost gets the desired result, but not
quite.

Previously we had moved Windows XP to the top of the grub menu. Currently
automatic boot selection is on 5th of 5 choices (bottom) in the grub menu.
Now, how do I move the automatic boot selection to position 1, or top of the
grub menu to select Windows XP?

Thanks,

Mike
----- Original Message -----
From: "actionparsnip" <email address hidden>
To: <email address hidden>
Sent: Sunday, November 18, 2012 11:05 AM
Subject: Re: [Question #214474]: Dual boot selection is wrong

Your question #214474 on grub2 in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/grub2/+question/214474

    Status: Open => Answered

actionparsnip proposed the following answer:
sudo dpkg -P linux-image-2.6.31-16-generic
sudo dpkg -P linux-image-2.6.31-17-generic
sudo dpkg -P linux-image-2.6.31-20-generic
sudo dpkg -P linux-image-2.6.31-21-generic
sudo apt-get --purge remove linux-image-2.6.32-43-generic

Reboot to test

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/grub2/+question/214474/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/grub2/+question/214474

You received this question notification because you asked the question.

ok run:

sudo update-grub

what is output?

mikehi (silversage) said : #6

Output:

mike@wanda:~$ sudo update-grub
[sudo] password for mike:
Generating grub.cfg ...
Found Microsoft Windows XP Home Edition on /dev/sda1
Found linux image: /boot/vmlinuz-3.2.0-33-generic
Found initrd image: /boot/initrd.img-3.2.0-33-generic
Found memtest86+ image: /boot/memtest86+.bin
done

Mike
----- Original Message -----
From: "actionparsnip" <email address hidden>
To: <email address hidden>
Sent: Sunday, November 18, 2012 12:15 PM
Subject: Re: [Question #214474]: Dual boot selection is wrong

Your question #214474 on grub2 in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/grub2/+question/214474

    Status: Open => Needs information

actionparsnip requested more information:
ok run:

sudo update-grub

what is output?

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+source/grub2/+question/214474

You received this question notification because you asked the question.

Looks like WIndows is the 1st option with only one kernel then memtest after that. Is this not the case?

mikehi (silversage) said : #8

That seems correct.

Mike

----- Original Message -----
From: "actionparsnip" <email address hidden>
To: <email address hidden>
Sent: Sunday, November 18, 2012 2:11 PM
Subject: Re: [Question #214474]: Dual boot selection is wrong

Your question #214474 on grub2 in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/grub2/+question/214474

    Status: Open => Needs information

actionparsnip requested more information:
Looks like WIndows is the 1st option with only one kernel then memtest
after that. Is this not the case?

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+source/grub2/+question/214474

You received this question notification because you asked the question.

So is the issue resolved now? If not then please give details and we can progress.

mikehi (silversage) said : #10

Installed 12.10 from dvd and solved problem. Made xp first on grub boot list with three commands found in Launchpad comments for someone else with similar problem. All working well now.