Inability to log back in if you add/change the keyboard layout before the screen saver asks for password and your password uses characters that are different between layouts.

Asked by Devin on 2011-03-31

Ubuntu 10.10

I installed Ubuntu with the wrong keyboard layout because the characters that are not included on my keyboard look similar to keys that are only included on other keyboards and layouts. This caused myself having to press a key twice for it to register. So, I decided to fix the problem with keyboard layouts. That worked, but as soon as the screen saver came on and I had to enter my password to log on I entered the correct password many times, in speculation, even trying to tap the key twice where it registered two characters and of course didn't work then either. So, I had to re-install Ubuntu from the installation disk with the correct keyboard layout from the start. I expect it to intuitively ask for a new password with the enter old password with the old layout, and enter new password with the new layout.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-screensaver Edit question
Assignee:
No assignee Edit question
Solved by:
Devin
Solved:
2011-03-31
Last query:
2011-03-31
Last reply:
2011-03-31
Devin (8basepairs) said : #1

I could pose a question with this report. How do I log back in, without having to re-format the hard disk drive? However, what I expected to happen as mentioned would be a totally cool new feature, in my opinion.

If I understand your question correctly, then this should answer it:
https://answers.launchpad.net/ubuntu/+source/gnome-screensaver/+question/142627

Devin (8basepairs) said : #3

Yes, the questions are related. I had to make another layout like before to test it. Before I tested it, I looked under the Options on the Keyboard and found the shortcut keys to be selected differently than the one suggested in that one's answer. I then locked the screen and tested it with Shift CapsLock shortcut, the one selected. I noticed that I didn't even need the shortcut, because it had the word USA and when I used the shortcut it changed to USA2. Just clicking on the USA (to the right of the password input box) was able to change layouts without getting into the system with the password. I only wish it said Keyboard Layout next to USA so I could have seen it before I had to reload Ubuntu.

Devin (8basepairs) said : #4

Should I Create a new FAQ to link this question and the one Eliah linked?

You're not obligated to do so...but if you want to, that might be very helpful to people coming here with the same problem in the future.

Devin (8basepairs) said : #6

Never mind, I am not authorized to create FAQs. Even when I try and link this question to an FAQ an error pops up no matter what I suspected would get me out of the error to continue.