Can't type in password to unlock screen if input method is left in Japanese

Asked by Winjeel on 2011-01-24

I have Japanese installed as an alternative input language, with English default. I left the computer running and Japanese iBus on and the screen saver came on locking the screen. The input method didn't allow show Roman letters (hiragana, katakana, and kanji only), and so I couldn't type in my roman-alphabet password. Also, there was no means to change input method. I had to restart the computer.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-screensaver Edit question
Assignee:
No assignee Edit question
Last query:
2011-01-24
Last reply:
2011-01-24

When prompted to unlock the screen, you can still change the keyboard layout using the key combination. If you have an Unlock Screen prompt up right now and you need to switch languages, try Alt+Shift+L.

To set a key combination for switching keyboard layouts (or find out what key combination you currently have set), go to System > Preferences > Keyboard Input Methods and look at (and maybe edit) the "Next input method" and "Previous input method" fields. (They're under Keyboard Shortcuts in the General tab.) These keyboard shortcuts are toggled between being enabled and disabled by any of the key combinations listed in "Enable or disable" (and you can add your own).

Can you help with this problem?

Provide an answer of your own, or ask Winjeel for more information if necessary.

To post a message you must log in.