no icons on screen only wallpaper on 11.04

Asked by Hugh-hfegan on 2011-10-03

how can I get the default setup on 11.04, I tried to set it to default, when I restarted the computer there is only the wallpaper no Icons at all, can not do anything, can not switch it of or get into any programs

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-panel Edit question
Assignee:
No assignee Edit question
Solved by:
Hugh-hfegan
Solved:
2011-10-04
Last query:
2011-10-04
Last reply:
2011-10-03
Danillo (danillo) said : #1
Danillo (danillo) said : #2

Sorry, the proposed solution is not so evident in that page.
This is a direct link: https://answers.launchpad.net/ubuntu/+source/unity/+question/162941

Try to do this:
1. Login into Ubuntu
2. Open a terminal by hitting CTRL + ALT + T
3. Insert and run this command:
gconftool-2 --recursive-unset /apps/compiz-1
unity --reset

4. Restart, this should work.

If when you hit CTRL + ALT + T and nothing happen, do this:
1. At login screen select Recovery Console at bottom:
http://i1-news.softpedia-static.com/images/extra/LINUX/large/ubuntu1104classicgnome-large_002.jpg
2. Insert and run this command:
gconftool-2 --recursive-unset /apps/compiz-1
unity --reset

3. Restart, this should work.

I suggest you log into the Ubuntu Classic session. Unity needs 3D accelleration to work so you may need to set this up first

Hugh-hfegan (hugh-hfegan) said : #5

I have tried all of the above none worked, it will not even allow me to open a terminal anymore, this it did till i ran the commands from above, would it be as actionparsnip suggests that it needs the 3D accelerator to work if so can you tell me how to get it set up. can not do anything as there is nothing on the screen but the wallpaper is there anyway of doing a complete reboot back to the original settings

So please try to do this:
1. At login screen select Recovery Console at bottom:
http://i1-news.softpedia-static.com/images/extra/LINUX/large/ubuntu1104classicgnome-large_002.jpg
2. Insert and run this command:
gconftool-2 --recursive-unset /apps/compiz-1
unity --reset

Hugh-hfegan (hugh-hfegan) said : #7

Enrico "eNry" Carafa (mr.tennents) Unfortunately 11. 04 that I have was set up without the log in screen that asks for login in and password (I know this is not the best option) but this means that I cannot access the recovery console as in the jpg of the above link is there any other way to access this menu

If you press CTRL+ALT+T do you get a terminal window?

Hugh-hfegan (hugh-hfegan) said : #9

actionparsnip (andrew-woodhead666)
 As it is it will do nothing for me - CTRL+ALT+T does nothing the first time it did and I did what it said above (gconftool-2 -recursive-unset /apps/compiz-1 unity --reset ) then done a restart after this it will do nothing the screen has just the wall paper on it when I run the pointer round the edge nothing appears can not access anything

Hugh-hfegan (hugh-hfegan) said : #10

I done a reload of 11.04 with the live CD this seemed to have fixed the problem