eth%d: 5.100.82.38 driver failed with code 21 -> UNCLAIMED Wireless Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01) not working on HP Pavilion DV9000 (RU974UA#ABA) in Ubuntu 11.10

Asked by milton barton on 2011-10-14

the last install ubuntu i installed firmware and wala i had wireless, i waited 3 weeks for the release stable. and what a nightmare
no mater what i do i cant get it , im on a hp pavillion 9000 laptop. i have slako puppy on sda3 and that is the best o s for getting
wireless, i thought the release version oneric would have problem fixed, help if you can thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2011-10-16
Last query:
2011-10-16
Last reply:
2011-10-15

Hi,

Please first connect your wired network adapter to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1:

If you are using the Gnome interface, open the Terminal console via "Applications->Accessories->Terminal"

If you are using the Unity interface, the easiest way to open the Terminal is to use the 'search' function on the dash. Or you can click on the 'More Apps' button, click on the 'See more results' by the installed section, and find it in that list of applications. A third way, available after you click on the 'More Apps' button, is to go to the search bar, and see that the far right end of it says 'All Applications'. You then click on that, and you'll see the full list. Then you can go to Accessories > Terminal after that.

So the methods in Unity are:
Dash > Search for Terminal
Dash > More Apps > 'See More Results' > Terminal
Dash > More Apps > Accessories > Terminal

Step 2: Please copy-paste the following command from https://help.ubuntu.com/community/WirelessTroubleshootingProcedure in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word lsmod. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|ireless|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt5|rt6|rt7|usb|witch|wl';sudo dmidecode|egrep 'Manufact|Product'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl'; cat /var/lib/NetworkManager/NetworkManager.state; sudo hwinfo --netcard ; ps -aux|egrep 'icd|etwork'; sudo lsmod

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Step 4: Please also clarify if you installed Ubuntu to the harddisk and are running from a harddisk install OR if you are only testing Ubuntu in a LiveCD session.

Regards,

Mark

milton barton (barton-mk) said : #2

Get:5 http://us.archive.ubuntu.com oneiric-updates/restricted Sources [14 B]
Get:6 http://us.archive.ubuntu.com oneiric-updates/universe Sources [1,361 B]
Get:7 http://us.archive.ubuntu.com oneiric-updates/multiverse Sources [14 B]
Get:8 http://us.archive.ubuntu.com oneiric-updates/main amd64 Packages [5,297 B]
Get:9 http://us.archive.ubuntu.com oneiric-updates/restricted amd64 Packages [14 B]
Ign http://security.ubuntu.com oneiric-security/main Translation-en_US
Ign http://extras.ubuntu.com oneiric/main Translation-en_US
Get:10 http://us.archive.ubuntu.com oneiric-updates/universe amd64 Packages [1,975 B]
Get:11 http://us.archive.ubuntu.com oneiric-updates/multiverse amd64 Packages [14 B]
Get:12 http://us.archive.ubuntu.com oneiric-updates/main i386 Packages [5,310 B]
Ign http://security.ubuntu.com oneiric-security/main Translation-en
Ign http://security.ubuntu.com oneiric-security/multiverse Translation-en_US
Ign http://extras.ubuntu.com oneiric/main Translation-en
Get:13 http://us.archive.ubuntu.com oneiric-updates/restricted i386 Packages [14 B]
Get:14 http://us.archive.ubuntu.com oneiric-updates/universe i386 Packages [1,981 B]
Get:15 http://us.archive.ubuntu.com oneiric-updates/multiverse i386 Packages [14 B]
Get:16 http://us.archive.ubuntu.com oneiric-updates/main TranslationIndex [72 B]
Get:17 http://us.archive.ubuntu.com oneiric-updates/multiverse TranslationIndex [70 B]
Get:18 http://us.archive.ubuntu.com oneiric-updates/restricted TranslationIndex [70 B]
Get:19 http://us.archive.ubuntu.com oneiric-updates/universe TranslationIndex [72 B]
Ign http://security.ubuntu.com oneiric-security/multiverse Translation-en
Ign http://security.ubuntu.com oneiric-security/restricted Translation-en_US
Ign http://security.ubuntu.com oneiric-security/restricted Translation-en
Ign http://security.ubuntu.com oneiric-security/universe Translation-en_US
Ign http://security.ubuntu.com oneiric-security/universe Translation-en
Hit http://us.archive.ubuntu.com oneiric-backports/main Sources
Hit http://us.archive.ubuntu.com oneiric-backports/restricted Sources
Hit http://us.archive.ubuntu.com oneiric-backports/universe Sources
Hit http://us.archive.ubuntu.com oneiric-backports/multiverse Sources
Hit http://us.archive.ubuntu.com oneiric-backports/main amd64 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/restricted amd64 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/universe amd64 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/main i386 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/restricted i386 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/universe i386 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/multiverse i386 Packages
Ign http://us.archive.ubuntu.com oneiric-backports/main TranslationIndex
Ign http://us.archive.ubuntu.com oneiric-backports/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com oneiric-backports/restricted TranslationIndex
Ign http://us.archive.ubuntu.com oneiric-backports/universe TranslationIndex
Hit http://us.archive.ubuntu.com oneiric/main Translation-en
Hit http://us.archive.ubuntu.com oneiric/multiverse Translation-en
Hit http://us.archive.ubuntu.com oneiric/restricted Translation-en
Hit http://us.archive.ubuntu.com oneiric/universe Translation-en
Get:20 http://us.archive.ubuntu.com oneiric-updates/main Translation-en [3,044 B]
Hit http://us.archive.ubuntu.com oneiric-updates/multiverse Translation-en
Hit http://us.archive.ubuntu.com oneiric-updates/restricted Translation-en
Get:21 http://us.archive.ubuntu.com oneiric-updates/universe Translation-en [1,474 B]
Ign http://us.archive.ubuntu.com oneiric-backports/main Translation-en_US
Ign http://us.archive.ubuntu.com oneiric-backports/main Translation-en
Ign http://us.archive.ubuntu.com oneiric-backports/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com oneiric-backports/multiverse Translation-en
Ign http://us.archive.ubuntu.com oneiric-backports/restricted Translation-en_US
Ign http://us.archive.ubuntu.com oneiric-backports/restricted Translation-en
Ign http://us.archive.ubuntu.com oneiric-backports/universe Translation-en_US
Ign http://us.archive.ubuntu.com oneiric-backports/universe Translation-en
Fetched 47.4 kB in 4s (10.1 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
hwinfo is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.
  *-network UNCLAIMED
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:b6000000-b6003fff
The program 'rfkill' is currently not installed. You can install it by typing:
sudo apt-get install rfkill
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"
00:00.0 RAM memory [0500]: nVidia Corporation C51 Host Bridge [10de:02f0] (rev a2)
00:00.1 RAM memory [0500]: nVidia Corporation C51 Memory Controller 0 [10de:02fa] (rev a2)
00:00.2 RAM memory [0500]: nVidia Corporation C51 Memory Controller 1 [10de:02fe] (rev a2)
00:00.3 RAM memory [0500]: nVidia Corporation C51 Memory Controller 5 [10de:02f8] (rev a2)
00:00.4 RAM memory [0500]: nVidia Corporation C51 Memory Controller 4 [10de:02f9] (rev a2)
00:00.5 RAM memory [0500]: nVidia Corporation C51 Host Bridge [10de:02ff] (rev a2)
00:00.6 RAM memory [0500]: nVidia Corporation C51 Memory Controller 3 [10de:027f] (rev a2)
00:00.7 RAM memory [0500]: nVidia Corporation C51 Memory Controller 2 [10de:027e] (rev a2)
00:02.0 PCI bridge [0604]: nVidia Corporation C51 PCI Express Bridge [10de:02fc] (rev a1)
00:03.0 PCI bridge [0604]: nVidia Corporation C51 PCI Express Bridge [10de:02fd] (rev a1)
00:05.0 VGA compatible controller [0300]: nVidia Corporation C51 [GeForce Go 6150] [10de:0244] (rev a2)
00:09.0 RAM memory [0500]: nVidia Corporation MCP51 Host Bridge [10de:0270] (rev a2)
00:0a.0 ISA bridge [0601]: nVidia Corporation MCP51 LPC Bridge [10de:0260] (rev a3)
00:0a.1 SMBus [0c05]: nVidia Corporation MCP51 SMBus [10de:0264] (rev a3)
00:0a.3 Co-processor [0b40]: nVidia Corporation MCP51 PMU [10de:0271] (rev a3)
00:0b.0 USB Controller [0c03]: nVidia Corporation MCP51 USB Controller [10de:026d] (rev a3)
00:0b.1 USB Controller [0c03]: nVidia Corporation MCP51 USB Controller [10de:026e] (rev a3)
00:0d.0 IDE interface [0101]: nVidia Corporation MCP51 IDE [10de:0265] (rev f1)
00:0e.0 IDE interface [0101]: nVidia Corporation MCP51 Serial ATA Controller [10de:0266] (rev f1)
00:10.0 PCI bridge [0604]: nVidia Corporation MCP51 PCI Bridge [10de:026f] (rev a2)
00:10.1 Audio device [0403]: nVidia Corporation MCP51 High Definition Audio [10de:026c] (rev a2)
00:14.0 Bridge [0680]: nVidia Corporation MCP51 Ethernet Controller [10de:0269] (rev a3)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
03:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
07:05.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832]
07:05.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 19)
07:05.2 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 0a)
07:05.3 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev 05)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:c50e Logitech, Inc. Cordless Mouse Receiver
Bus 002 Device 003: ID 03f0:7604 Hewlett-Packard DeskJet 3940
H/W path Device Class Description
===================================================
                            system HP Pavilion dv9000 (RU97
/0 bus 30B9
/0/0 memory 101KiB BIOS
/0/4 processor AMD Turion(tm) 64 X2 Mob
/0/4/5 memory 64KiB L1 cache
/0/4/6 memory 1MiB L2 cache
/0/c memory 2GiB System Memory
/0/c/0 memory 1GiB DIMM DDR2 Synchrono
/0/c/1 memory 1GiB DIMM DDR2 533 MHz (
/0/1 memory RAM memory
/0/0.1 memory RAM memory
/0/0.2 memory RAM memory
/0/0.3 memory RAM memory
/0/0.4 memory RAM memory
/0/0.5 memory RAM memory
/0/0.6 memory RAM memory
/0/0.7 memory RAM memory
/0/2 bridge C51 PCI Express Bridge
/0/3 bridge C51 PCI Express Bridge
/0/3/0 network BCM4311 802.11b/g WLAN
/0/5 display C51 [GeForce Go 6150]
/0/9 memory RAM memory
/0/a bridge MCP51 LPC Bridge
/0/a.1 bus MCP51 SMBus
/0/a.3 processor MCP51 PMU
/0/b bus MCP51 USB Controller
/0/b.1 bus MCP51 USB Controller
/0/d scsi0 storage MCP51 IDE
/0/d/0.0.0 /dev/cdrom disk CD/DVDW TS-L632M
/0/e scsi2 storage MCP51 Serial ATA Control
/0/e/0.0.0 /dev/sda disk 120GB FUJITSU MHW2120B
/0/e/0.0.0/1 /dev/sda1 volume 7326MiB EXT4 volume
/0/e/0.0.0/2 /dev/sda2 volume 30GiB EXT4 volume
/0/e/0.0.0/3 /dev/sda3 volume 13GiB EXT4 volume
/0/e/0.0.0/4 /dev/sda4 volume 56GiB Extended partition
/0/e/0.0.0/4/5 /dev/sda5 volume 4397MiB Linux swap / Sol
/0/e/0.0.0/4/6 /dev/sda6 volume 13GiB Linux filesystem p
/0/e/0.0.0/4/7 /dev/sda7 volume 15GiB Linux filesystem p
/0/e/0.0.0/4/8 /dev/sda8 volume 22GiB Linux filesystem p
/0/10 bridge MCP51 PCI Bridge
/0/10/5 bus R5C832 IEEE 1394 Control
/0/10/5.1 generic R5C822 SD/SDIO/MMC/MS/MS
/0/10/5.2 generic R5C592 Memory Stick Bus
/0/10/5.3 generic xD-Picture Card Controll
/0/10.1 multimedia MCP51 High Definition Au
/0/14 eth0 bridge MCP51 Ethernet Controlle
/0/100 bridge K8 [Athlon64/Opteron] Hy
/0/101 bridge K8 [Athlon64/Opteron] Ad
/0/102 bridge K8 [Athlon64/Opteron] DR
/0/103 bridge K8 [Athlon64/Opteron] Mi
Linux milton-HP-Pavilion-dv9000-RU974UA-ABA 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
[ 0.000000] DMI: Hewlett-Packard HP Pavilion dv9000 (RU974UA#ABA) /30B9, BIOS F.3D 11/22/2007
[ 0.000000] No AGP bridge found
[ 0.000000] found SMP MP-table at [ffff8800000f8920] f8920
[ 0.000000] No NUMA configuration found
[ 0.000000] No AGP bridge found
[ 0.152113] Switch to broadcast mode on CPU1
[ 0.152708] Switch to broadcast mode on CPU0
[ 0.161909] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 0.170365] ACPI: No dock devices found.
[ 0.170369] HEST: Table not found.
[ 0.202113] usbcore: registered new interface driver usbfs
[ 0.202113] usbcore: registered new interface driver hub
[ 0.202113] usbcore: registered new device driver usb
[ 0.228081] Switching to clocksource hpet
[ 0.231689] Switched to NOHz mode on CPU #1
[ 0.231699] Switched to NOHz mode on CPU #0
[ 0.241234] pnp: PnP ACPI: found 13 devices
[ 0.254109] pci 0000:00:00.0: Found disabled HT MSI Mapping
[ 0.254166] pci 0000:00:00.0: Found enabled HT MSI Mapping
[ 0.254195] pci 0000:00:00.0: Found enabled HT MSI Mapping
[ 0.528131] pci 0000:00:09.0: Found enabled HT MSI Mapping
[ 0.528190] pci 0000:00:09.0: Found enabled HT MSI Mapping
[ 0.528252] pci 0000:00:09.0: Found enabled HT MSI Mapping
[ 0.596606] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input2
[ 0.596826] ACPI: Lid Switch [LID]
[ 0.600563] ERST: Table is not found!
[ 0.840225] hub 1-0:1.0: USB hub found
[ 0.898176] hub 2-0:1.0: USB hub found
[ 0.937151] powernow-k8: Found 1 AMD Turion(tm) 64 X2 Mobile Technology TL-52 (2 cpu cores) (version 2.20.00)
[ 0.937263] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 1.178606] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64.
[ 1.178915] forcedeth 0000:00:14.0: PCI INT A -> Link[LMAC] -> GSI 20 (level, high) -> IRQ 20
[ 1.178922] forcedeth 0000:00:14.0: setting latency timer to 64
[ 1.408041] usb 2-2: new low speed USB device number 2 using ohci_hcd
[ 1.439595] sdhci-pci 0000:07:05.1: SDHCI controller found [1180:0822] (rev 19)
[ 1.442633] mmc0: no vmmc regulator found
[ 1.667616] input: Logitech USB RECEIVER as /devices/pci0000:00/0000:00:0b.0/usb2/2-2/2-2:1.0/input/input5
[ 1.667776] generic-usb 0003:046D:C50E.0001: input,hidraw0: USB HID v1.11 Mouse [Logitech USB RECEIVER] on usb-0000:00:0b.0-2/input0
[ 1.667806] usbcore: registered new interface driver usbhid
[ 1.667809] usbhid: USB HID core driver
[ 1.701103] forcedeth 0000:00:14.0: ifname eth0, PHY OUI 0x732 @ 1, addr 00:1b:24:3c:8c:2b
[ 1.701110] forcedeth 0000:00:14.0: highdma pwrctl lnktim desc-v3
[ 4.744043] usb 2-6: new full speed USB device number 3 using ohci_hcd
[ 16.377878] lp: driver loaded but no devices found
[ 16.864239] wl: module license 'MIXED/Proprietary' taints kernel.
[ 17.581728] wl 0000:03:00.0: PCI INT A -> Link[LK4E] -> GSI 19 (level, high) -> IRQ 19
[ 17.581737] wl 0000:03:00.0: setting latency timer to 64
[ 17.584293] eth%d: 5.100.82.38 driver failed with code 21
[ 17.645769] type=1400 audit(1318642293.204:9): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/mission-control-5" pid=832 comm="apparmor_parser"
[ 17.648966] type=1400 audit(1318642293.208:10): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/telepathy-*" pid=832 comm="apparmor_parser"
[ 19.083095] Console: switching to colour frame buffer device 128x48
[ 27.840037] eth0: no IPv6 routers present
 Manufacturer: Hewlett-Packard
 Product Name: HP Pavilion dv9000 (RU974UA#ABA)
 Manufacturer: Quanta
 Product Name: 30B9
 Manufacturer: Quanta
 Manufacturer: AMD
 Manufacturer: F789000000000000
 Manufacturer: F789000000000000
lo no wireless extensions.

eth0 no wireless extensions.

install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
blacklist b43
blacklist b43legacy
blacklist bcm43xx
blacklist brcm80211
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist uart6850
blacklist twl4030_wdt

[main]
NetworkingEnabled=true
WirelessEnabled=false
WWANEnabled=true
WimaxEnabled=true
> hal.1: read hal dataprocess 9122: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file ../../dbus/dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
29: PCI 14.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.bYAEq7iXviA
  SysFS ID: /devices/pci0000:00/0000:00:14.0
  SysFS BusID: 0000:00:14.0
  Hardware Class: network
  Model: "Hewlett-Packard Company Presario V6133CL"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0269 "MCP51 Ethernet Controller"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x30b7 "Presario V6133CL"
  Revision: 0xa3
  Driver: "forcedeth"
  Driver Modules: "forcedeth"
  Device File: eth0
  Memory Range: 0xb0008000-0xb0008fff (rw,non-prefetchable)
  I/O Ports: 0x30e0-0x30e7 (rw)
  IRQ: 20 (54349 events)
  HW Address: 00:1b:24:3c:8c:2b
  Link detected: yes
  Module Alias: "pci:v000010DEd00000269sv0000103Csd000030B7bc06sc80i00"
  Driver Info #0:
    Driver Status: forcedeth is active
    Driver Activation Cmd: "modprobe forcedeth"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

34: PCI 300.0: 0280 Network controller
  [Created at pci.318]
  Unique ID: svHJ.5D2YRgUfek7
  Parent ID: 3hqH.Q0xgpa4wjL6
  SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Hewlett-Packard Company BCM4311 802.11b/g Wireless LAN Controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4311 "BCM4311 802.11b/g WLAN"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x1363 "BCM4311 802.11b/g Wireless LAN Controller"
  Revision: 0x01
  Memory Range: 0xb6000000-0xb6003fff (rw,non-prefetchable)
  IRQ: 19 (no events)
  Module Alias: "pci:v000014E4d00004311sv0000103Csd00001363bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is not active
    Driver Activation Cmd: "modprobe ssb"
  Driver Info #1:
    Driver Status: wl is active
    Driver Activation Cmd: "modprobe wl"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #17 (PCI bridge)
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 707 0.0 0.2 105136 5180 ? Ssl 18:31 0:00 NetworkManager
root 789 0.0 0.0 7128 1480 ? S 18:31 0:00 /sbin/dhclient -d -4 -sf /usr/lib/NetworkManager/nm-dhcp-client.action -pf /var/run/dhclient-eth0.pid -lf /var/lib/dhcp/dhclient-457549a0-2473-4446-b15c-08d96a8de4a3-eth0.lease -cf /var/run/nm-dhclient-eth0.conf eth0
milton 8986 0.0 0.6 316296 13072 ? Sl 18:50 0:00 /usr/lib/glib-networking/glib-pacrunner
milton 9134 0.0 0.0 13448 852 pts/0 S+ 18:53 0:00 egrep --color=auto icd|etwork
Module Size Used by
parport_pc 36962 0
ppdev 17113 0
vesafb 13809 1
joydev 17693 0
snd_hda_codec_conexant 62197 1
bnep 18436 2
rfcomm 47946 0
bluetooth 166112 10 bnep,rfcomm
snd_hda_intel 33390 2
snd_hda_codec 104802 2 snd_hda_codec_conexant,snd_hda_intel
snd_hwdep 13668 1 snd_hda_codec
snd_pcm 96755 2 snd_hda_intel,snd_hda_codec
hp_wmi 18092 0
sparse_keymap 13890 1 hp_wmi
snd_seq_midi 13324 0
snd_rawmidi 30547 1 snd_seq_midi
snd_seq_midi_event 14899 1 snd_seq_midi
snd_seq 61896 2 snd_seq_midi,snd_seq_midi_event
nvidia 8107305 37
snd_timer 29991 2 snd_pcm,snd_seq
snd_seq_device 14540 3 snd_seq_midi,snd_rawmidi,snd_seq
wl 2568210 0
psmouse 73882 0
edac_core 53746 0
serio_raw 13166 0
snd 68266 13 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
r852 18277 0
sm_common 16865 1 r852
nand 54966 2 r852,sm_common
nand_ids 12723 1 nand
nand_bch 13147 1 nand
bch 22061 1 nand_bch
nand_ecc 13230 1 nand
edac_mce_amd 23709 0
k8temp 13057 0
mtd 33181 2 sm_common,nand
soundcore 12680 1 snd
snd_page_alloc 18529 2 snd_hda_intel,snd_pcm
nv_tco 13687 0
i2c_nforce2 13058 0
binfmt_misc 17540 1
lib80211 14991 1 wl
wmi 19256 1 hp_wmi
video 19412 0
lp 17799 0
parport 46562 3 parport_pc,ppdev,lp
usbhid 47198 0
hid 95463 1 usbhid
firewire_ohci 40722 0
sdhci_pci 14032 0
firewire_core 63626 1 firewire_ohci
sdhci 32166 1 sdhci_pci
crc_itu_t 12707 1 firewire_core
sata_nv 32305 2
forcedeth 67563 0
pata_amd 14121 0
milton@milton-HP-Pavilion-dv9000-RU974UA-ABA:~$

I am pretty sure that your BCM4311 wireless adapter is experiencing the
following Broadcom driver bug in Ubuntu 11.10:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677

I suggest installing bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu5)
from maverick (Ubuntu 10.10) using gdebi

Solution is described here:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677/comments/23

Then reboot your PC and run the following commands to enable your
wireless adapter:

sudo apt-get update && sudo apt-get install rfkill
rfkill unblock all
sudo rfkill unblock all

Then retest wireless using NetworkManager

milton barton (barton-mk) said : #4

fixed went online and here it is $ sudo apt-get update
$ sudo apt-get install firmware-bc43-installer
$ sudo apt-get remove bcmwl-kernel-source
$ sudo reboot. this is from NFLOAMP BLOG. thanks

milton barton (barton-mk) said : #5

thanks Mark it been fun it keeps my mind active im 70 yrs old , but this
stuff keeps me young. milton

On Sun, Oct 16, 2011 at 9:50 AM, milton barton <
<email address hidden>> wrote:

> Your question #174248 on gnome-nettool in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/174248
>
> Status: Answered => Solved
>
> You confirmed that the question is solved:
> fixed went online and here it is $ sudo apt-get update
> $ sudo apt-get install firmware-bc43-installer
> $ sudo apt-get remove bcmwl-kernel-source
> $ sudo reboot. this is from NFLOAMP BLOG. thanks
>
> --
> You received this question notification because you asked the question.
>

milton barton (barton-mk) said : #6

Mark i still have wireless every thing is o k i think, if i need to change any drivers give me some copy & paste commands for the
terminal