incorrect wireless driver rt2800pci loaded -> DISABLED Wireless Network controller [0280]: RaLink RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090] not working in Ubuntu 10.10

Asked by jon on 2010-11-20

hey
cant get my pci card working. I think its my driver. I'm new to ubuntu so any ideas will help. here is the info.
Thx

jon@jon-p6654y:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"
jon@jon-p6654y:~$ sudo iwlist scanning
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down

jon@jon-p6654y:~$ sudo lshw -C network
  *-network DISABLED
       description: Wireless interface
       product: RT3090 Wireless 802.11n 1T/1R PCIe
       vendor: RaLink
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: 1c:65:9d:22:bf:70
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=2.6.35-22-generic firmware=N/A latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:feaf0000-feafffff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 05
       serial: d4:85:64:a3:a2:b3
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.0.69 latency=0 link=yes multicast=yes port=MII speed=100MB/s
       resources: irq:42 ioport:e800(size=256) memory:febff000-febfffff memory:fdffc000-fdffffff
jon@jon-p6654y:~$ lspci -nn
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS780 Host Bridge Alternate [1022:9601]
00:01.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx) [1022:9602]
00:05.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1) [1022:9605]
00:0a.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 5) [1022:9609]
00:11.0 SATA controller [0106]: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode] [1002:4391]
00:12.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
00:12.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
00:12.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 3c)
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration [1022:1200]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor Address Map [1022:1201]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller [1022:1202]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control [1022:1203]
00:18.4 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor Link Control [1022:1204]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS880 [Radeon HD 4200] [1002:9710]
02:00.0 Network controller [0280]: RaLink RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
jon@jon-p6654y:~$ lsusb
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 0461:4d8a Primax Electronics, Ltd
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0461:4d0f Primax Electronics, Ltd
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
jon@jon-p6654y:~$ uname -a
Linux jon-p6654y 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux
jon@jon-p6654y:~$ dmesg | grep ound
[ 0.000000] AMI BIOS detected: BIOS may corrupt low RAM, working around it.
[ 0.000000] No AGP bridge found
[ 0.000000] found SMP MP-table at [ffff8800000ff780] ff780
[ 0.000000] No AGP bridge found
[ 0.681031] ACPI: No dock devices found.
[ 0.723923] HEST: Table is not found!
[ 0.727443] pnp: PnP ACPI: found 12 devices
[ 1.523514] ERST: Table is not found!
[ 1.543079] hub 1-0:1.0: USB hub found
[ 1.563073] hub 2-0:1.0: USB hub found
[ 1.627058] hub 3-0:1.0: USB hub found
[ 1.677095] hub 4-0:1.0: USB hub found
[ 1.734146] hub 5-0:1.0: USB hub found
[ 1.794189] hub 6-0:1.0: USB hub found
[ 1.794379] PNP: No PS/2 controller found. Probing ports directly.
[ 1.795401] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 1.796360] powernow-k8: Found 1 AMD Athlon(tm) II X4 630 Processor (4 cpu cores) (version 2.20.00)
[ 1.797318] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 10.362259] lp: driver loaded but no devices found
jon@jon-p6654y:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2010-11-30
Last query:
2010-11-30
Last reply:
2010-11-20

Please first try the following workaround procedure:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/541620/comments/103

ATTENTION! There is an error in comment 103. The correct command is

sudo modprobe -rf rt2800pci

The WRONG command in comment 103 does not contain a dash (-) in front of the rf options (between modprobe and rf). It SHOULD contain the - symbol.

Then REBOOT and retest wireless.

If it does not help, then please try the following workaround procedure:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/541620/comments/43

Same solution is also given at the following location:

https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/112252

Then REBOOT and retest wireless again.

jon (jonwalther) said : #2

Thanks Mark Rijckenberg, that solved my question.