gedit:2547

Asked by Qiang on 2019-04-11

gedit:2547 :warning**:set docment metadata failed:setting attribute metadata::gedit-position not supported

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gedit Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-04-19
Last query:
2019-04-19
Last reply:
2019-04-16

What is the output of:

lsb_release -a; uname -a; apt-cache policy gedit

What do you do to trigger the message.

Details please.......

Qiang (johon1979) said : #2

Nice to meet you ,I'm very glad to hear from your letter.Today ,the error is:

sudo gedit /etc/exports
[sudo] password for vivado:
Sorry, try again.
[sudo] password for vivado:

** (gedit:3226): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-spell-enabled not supported

** (gedit:3226): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported

** (gedit:3226): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-position not supported
vivado@vivado-virtual-machine:~$

Waiting for your good news.

Yours truly!

________________________________
From: <email address hidden> <email address hidden> on behalf of actionparsnip <email address hidden>
Sent: Thursday, April 11, 2019 1:37 PM
To: <email address hidden>
Subject: Re: [Question #680182]: gedit:2547

Your question #680182 on gedit in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182

Question #680182 : Questions : gedit package : Ubuntu<https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182>
answers.launchpad.net
gedit:2547 :warning**:set docment metadata failed:setting attribute metadata::gedit-position not supported

    Status: Open => Needs information

actionparsnip requested more information:
What is the output of:

lsb_release -a; uname -a; apt-cache policy gedit

What do you do to trigger the message.

Details please.......

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182

You received this question notification because you asked the question.

What is the output of the command I gave?

Does gedit load despite the errors?

Qiang (johon1979) said : #4

the output is:

lsb_release -a; uname -a; apt-cache policy gedit

vivado@vivado-virtual-machine:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial
vivado@vivado-virtual-machine:~$ uname -a
Linux vivado-virtual-machine 4.10.0-28-generic #32~16.04.2-Ubuntu SMP Thu Jul 20 10:19:48 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
vivado@vivado-virtual-machine:~$ apt-cache policy gedit
gedit:
  Installed: 3.18.3-0ubuntu4
  Candidate: 3.18.3-0ubuntu4
  Version table:
 *** 3.18.3-0ubuntu4 500
        500 http://mirrors.tuna.tsinghua.edu.cn/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
vivado@vivado-virtual-machine:~$

Details of trigger the message is:
sudo gedit /etc/exports
[sudo] password for vivado:
Sorry, try again.
[sudo] password for vivado:

** (gedit:6523): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-spell-enabled not supported

** (gedit:6523): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported

** (gedit:6523): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-spell-enabled not supported

** (gedit:6523): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported

** (gedit:6523): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-position not supported

/etc/exports: the access control list for filesystems which may be exported
# to NFS clients. See exports(5).
#
# Example for NFSv2 and NFSv3:
# /srv/homes hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_subtree_check)
#
# Example for NFSv4:
# /srv/nfs4 gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
# /srv/nfs4/homes gss/krb5i(rw,sync,no_subtree_check)
#
/home/vivado/work *(rw,syns,no_root_squash,no_subtree_check)

________________________________
From: <email address hidden> <email address hidden> on behalf of actionparsnip <email address hidden>
Sent: Thursday, April 11, 2019 1:37 PM
To: <email address hidden>
Subject: Re: [Question #680182]: gedit:2547

Your question #680182 on gedit in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182

Question #680182 : Questions : gedit package : Ubuntu<https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182>
answers.launchpad.net
gedit:2547 :warning**:set docment metadata failed:setting attribute metadata::gedit-position not supported

    Status: Open => Needs information

actionparsnip requested more information:
What is the output of:

lsb_release -a; uname -a; apt-cache policy gedit

What do you do to trigger the message.

Details please.......

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182

You received this question notification because you asked the question.

Manfred Hampl (m-hampl) said : #5

These are just warning that can be ignored.

Qiang (johon1979) said : #6

sudo gedit /etc/exports

** (gedit:2548): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-spell-enabled not supported

** (gedit:2548): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported

** (gedit:2548): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-position not supported
vivado@vivado-virtual-machine:~$ sudo /etc/init.d/rpcbind restart
[ ok ] Restarting rpcbind (via systemctl): rpcbind.service.
vivado@vivado-virtual-machine:~$ sudo /etc/init.d/nfs-kernel-server restart
[....] Restarting nfs-kernel-server (via systemctl): nfs-kernel-server.serviceJob for nfs-server.service failed because the control process exited with error code. See "systemctl status nfs-server.service" and "journalctl -xe" for details.
 failed!
vivado@vivado-virtual-machine:~$ lsb_release -a
LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial
vivado@vivado-virtual-machine:~$ uname -a
Linux vivado-virtual-machine 4.10.0-28-generic #32~16.04.2-Ubuntu SMP Thu Jul 20 10:19:48 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
vivado@vivado-virtual-machine:~$ apt-cache policy gedit
gedit:
  Installed: 3.18.3-0ubuntu4
  Candidate: 3.18.3-0ubuntu4
  Version table:
 *** 3.18.3-0ubuntu4 500
        500 http://mirrors.tuna.tsinghua.edu.cn/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status

________________________________
From: <email address hidden> <email address hidden> on behalf of Manfred Hampl <email address hidden>
Sent: Saturday, April 13, 2019 1:02 PM
To: <email address hidden>
Subject: Re: [Question #680182]: gedit:2547

Your question #680182 on gedit in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182

Question #680182 : Questions : gedit package : Ubuntu<https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182>
answers.launchpad.net
gedit:2547 :warning**:set docment metadata failed:setting attribute metadata::gedit-position not supported

    Status: Open => Answered

Manfred Hampl proposed the following answer:
These are just warning that can be ignored.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182/+confirm?answer_id=4

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182

You received this question notification because you asked the question.

Qiang (johon1979) said : #7

~
vivado@vivado-virtual-machine:~$ systemctl status nfs-server.service
● nfs-server.service - NFS server and services
   Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since 日 2019-04-14 15:46:29 CST; 14min ago
  Process: 2655 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=22)

4月 14 15:46:29 vivado-virtual-machine systemd[1]: Starting NFS server and services...
4月 14 15:46:29 vivado-virtual-machine exportfs[2655]: exportfs: /etc/exports:1: unknown keyword "syns"
4月 14 15:46:29 vivado-virtual-machine systemd[1]: nfs-server.service: Control process exited, code=exited status=22
4月 14 15:46:29 vivado-virtual-machine systemd[1]: Failed to start NFS server and services.
4月 14 15:46:29 vivado-virtual-machine systemd[1]: nfs-server.service: Unit entered failed state.
4月 14 15:46:29 vivado-virtual-machine systemd[1]: nfs-server.service: Failed with result 'exit-code'.

Qiang (johon1979) said : #8

vivado@vivado-virtual-machine:~$ journalctl -xe
--
-- Unit nfs-mountd.service has begun shutting down.
4月 14 16:10:13 vivado-virtual-machine systemd[1]: Stopping NFSv4 ID-name mappin
-- Subject: Unit nfs-idmapd.service has begun shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit nfs-idmapd.service has begun shutting down.
4月 14 16:10:13 vivado-virtual-machine systemd[1]: Stopped NFSv4 ID-name mapping
-- Subject: Unit nfs-idmapd.service has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit nfs-idmapd.service has finished shutting down.
4月 14 16:10:13 vivado-virtual-machine systemd[1]: Stopped NFS Mount Daemon.
-- Subject: Unit nfs-mountd.service has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit nfs-mountd.service has finished shutting down.
4月 14 16:10:13 vivado-virtual-machine sudo[2491]: pam_unix(sudo:session): sessi
4月 14 16:10:14 vivado-virtual-machine tpvmlpd2[2541]: device type not supported
4月 14 16:10:29 vivado-virtual-machine tpvmlpd2[2552]: device type not supported
lines 2451-2473/2473 (END)
 Unit nfs-mountd.service has begun shutting down.
4月 14 16:10:13 vivado-virtual-machine systemd[1]: Stopping NFSv4 ID-name mappin
-- Subject: Unit nfs-idmapd.service has begun shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit nfs-idmapd.service has begun shutting down.
4月 14 16:10:13 vivado-virtual-machine systemd[1]: Stopped NFSv4 ID-name mapping
-- Subject: Unit nfs-idmapd.service has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit nfs-idmapd.service has finished shutting down.
4月 14 16:10:13 vivado-virtual-machine systemd[1]: Stopped NFS Mount Daemon.
-- Subject: Unit nfs-mountd.service has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit nfs-mountd.service has finished shutting down.
4月 14 16:10:13 vivado-virtual-machine sudo[2491]: pam_unix(sudo:session): sessi
4月 14 16:10:14 vivado-virtual-machine tpvmlpd2[2541]: device type not supported
4月 14 16:10:29 vivado-virtual-machine tpvmlpd2[2552]: device type not supported
~

Jeremy (wa113y3s) said : #9

Stop using sudo with GUI programs, use pkexec or you could use

gedit admin:///etc/exports

Manfred Hampl (m-hampl) said : #10

It seems to me that you are mixing two issues:

1. If you edit a file with the command "sudo gedit …", you will see warning messages like "setting attribute not supported"
These messages do not cause any harm and can be ignored.

2. Apparently you have a problem with your nfs server.
Look at the messages that you have received:

systemctl status nfs-server.service
 ● nfs-server.service - NFS server and services
    Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled; vendor preset: enabled)
    Active: failed (Result: exit-code) since 日 2019-04-14 15:46:29 CST; 14min ago
   Process: 2655 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=22)

4月 14 15:46:29 vivado-virtual-machine systemd[1]: Starting NFS server and services...
4月 14 15:46:29 vivado-virtual-machine exportfs[2655]: exportfs: /etc/exports:1: unknown keyword "syns"

It seems that you have put wrong contents into the /etc/exports file.

What is the output of the command

cat -n /etc/exports

Manfred Hampl (m-hampl) said : #11

I assume you have mistyped syns instead of sync

Qiang (johon1979) said : #12

You are right,the problem is solved.
Thank you very much!

发自我的 iPhone

> 在 2019年4月14日,下午9:57,Manfred Hampl <email address hidden> 写道:
>
> Your question #680182 on gedit in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gedit/+question/680182
>
> Manfred Hampl posted a new comment:
> I assume you have mistyped syns instead of sync
>
> --
> You received this question notification because you asked the question.

Best Manfred Hampl (m-hampl) said : #13

If the problem has been resolved, please set the status of this question to "solved" by pressing the appropriate button or opening the related link.

Qiang (johon1979) said : #14

Thanks Manfred Hampl, that solved my question.