Automatically turn off touchpad when USB mouse is plugged in???

Asked by manis on 2009-11-03

Is there any program, package, setting, etc. in Karmic Koala that will automatically turn off the touchpad whenever a USB mouse is plugged in? Not to be blasphemous, but this may be one of the few things that Windows does better than Ubuntu. I use a USB mouse 95 % of the time and have my touchpad turned off (because my salami paws keep hitting the touchpad when I type and move the cursor all over the darn place). The 5% of the time where I don't use the USB mouse, I have to find the darn thing so I can engage the touchpad again... ...only to disconnect the USB mouse a few seconds later.

So yeah, not really a "problem" per se, more of a mild inconvenience...

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gconf-editor Edit question
Assignee:
No assignee Edit question
Solved by:
manis
Solved:
2009-11-04
Last query:
2009-11-04
Last reply:
2009-11-04
sdim (socratesdim2) said : #1

http://ubuntuforums.org/showthread.php?t=1204735&page=3

This is where an answer might be found.
1)sudo modprobe -r psmouse - DEACTIVATE
2)sudo modprobe psmouse - ACTIVATE
3)Install gpointing-device settings--> Run it-->Click entry on the left that relates to the touchpad
   On the General tab, there is an option to turn the touchpad off.
   Uncheck "disable touchpad while typing",so as not to turn itself on back again.

manis (crclough) said : #2

That effectively killed the touchpad, but I had already managed to do that (using only gpointing-device-settings) and making sure that "disable touchpad while typing" was unchecked.

What I was hoping for is a fix that doesn't simply turn the touchpad off. I would like something that turns the touchpad off ONLY when a USB mouse is attached. Then have the touchpad automatically become active again when the USB mouse is removed.

I may be hoping for too much. Maybe the next release....

sdim (socratesdim2) said : #3

Yes,I know what you mean,manis,but I don't think Ubuntu ever did what you
ask.
You could simply turn off the touchpad completely in Jaunty,instead of
customising it now in Karmic.

2009/11/4 manis <email address hidden>

> Question #88423 on gconf-editor in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gconf-editor/+question/88423
>
> Status: Answered => Open
>
> manis is still having a problem:
> That effectively killed the touchpad, but I had already managed to do
> that (using only gpointing-device-settings) and making sure that
> "disable touchpad while typing" was unchecked.
>
> What I was hoping for is a fix that doesn't simply turn the touchpad
> off. I would like something that turns the touchpad off ONLY when a USB
> mouse is attached. Then have the touchpad automatically become active
> again when the USB mouse is removed.
>
> I may be hoping for too much. Maybe the next release....
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
SD

manis (crclough) said : #4

It looks like I can't do what I want. The touchpad remains off for the most part. Every few times after a reboot, I have to open up "gpointing-device-settings" and turn the darn thing off again. I made my life a bit easier by writing a short script into my bash.bashrc file.

In the bash file, simply write (on it's own line):

alias touchpad='gpointing-device-settings &'

and then in a terminal, you just have to type "touchpad" and the gpointing settings window starts up. Also, since I can never remember where that bash.bashrc file is, I took the liberty to write another quick script:

alias editalias='gvim /etc/bash.bashrc &'

Where you can replace "gvim" with whatever text editor you like. Type "editalias" into your terminal and you can add whatever alias/shortcuts you like.

sdim (socratesdim1) said : #5

Thanks,manis.I appreciate it.

2009/11/4 manis <email address hidden>

> Question #88423 on gconf-editor in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gconf-editor/+question/88423
>
> Status: Answered => Solved
>
> manis confirmed that the question is solved:
> It looks like I can't do what I want. The touchpad remains off for the
> most part. Every few times after a reboot, I have to open up
> "gpointing-device-settings" and turn the darn thing off again. I made
> my life a bit easier by writing a short script into my bash.bashrc file.
>
> In the bash file, simply write (on it's own line):
>
> alias touchpad='gpointing-device-settings &'
>
>
> and then in a terminal, you just have to type "touchpad" and the gpointing
> settings window starts up. Also, since I can never remember where that
> bash.bashrc file is, I took the liberty to write another quick script:
>
> alias editalias='gvim /etc/bash.bashrc &'
>
>
> Where you can replace "gvim" with whatever text editor you like. Type
> "editalias" into your terminal and you can add whatever alias/shortcuts you
> like.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
SD