No "gcc" could be found on packages.ubuntu.com

Asked by AN on 2012-05-15

I've tried to figure out what GCC versions are available in various versions of Ubuntu, opened page packages.ubuntu.com, entered 'gcc' in the search string, chosen 'all' in "Distribution", and got the following:

---------------------
You have searched for packages that names contain gcc in all suites, all sections, and all architectures. Found 2 matching packages.
Package gccxml

    quantal (devel): XML output extension to GCC
    0.9.0+cvs20120420-3: amd64 i386

Package libgccxml-dev

    quantal (libdevel): Libraries for building extension to gccxml output
    0.9.0+cvs20120420-3: amd64 i386
---------------------

Where all gcc gone? Or is it an issue of the search system on packages.ubuntu.com?

PS: I have Ubuntu 11.04 "Natty" installed, and I have gcc-4.4 and gcc-4.5 installed, so packages.ubuntu.com should give at least these package names in search results for sure.

PPS: What are plans about packaging of gcc-4.6 and gcc-4.7?

--
WBR,
Alexander

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gcc-defaults Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2012-05-16
Last query:
2012-05-16
Last reply:
2012-05-15
Best Sam_ (and-sam) said : #1

> Where all gcc gone?

Perhaps scroll down to the list there. (or just click on overview on top of this page)
https://launchpad.net/ubuntu/+source/gcc-defaults

For example 4.4.6 and .7 are there.
https://launchpad.net/ubuntu/quantal/amd64/gcc

Anyway atm package search works again.
http://packages.ubuntu.com/search?suite=default&section=all&arch=any&searchon=names&keywords=gcc

Hiccup of search function already reported. bug 996784

AN (alecn2002) said : #2

Thanks, the problem with packages searching looks solved.

Also thanks for info about default GCC versions.