Why doesn't file identify Ogg containers?

Asked by Adam Buchbinder

file(1) doesn't recognize Ogg Vorbis files, but there is information in the magic database about them (grep Ogg /usr/share/file/magic).

$ file /usr/share/hwtest/data/audio_playback.ogg
/usr/share/hwtest/data/audio_playback.ogg: data

$ ogginfo /usr/share/hwtest/data/audio_playback.ogg
Processing file "/usr/share/hwtest/data/audio_playback.ogg"...

New logical stream (#1, serial: 6be80e87): type vorbis
Vorbis headers parsed for stream 1, information follows...
Version: 0
Vendor: Xiph.Org libVorbis I 20070622 (1.2.0)
Channels: 1
Rate: 44100

Nominal bitrate: 110.000000 kb/s
Upper bitrate not set
Lower bitrate not set
Vorbis stream 1:
 Total data length: 8487 bytes
 Playback length: 0m:00.766s
 Average bitrate: 88.607173 kb/s
Logical stream 1 ended

Am I doing something wrong, or is this a bug?

Question information

English Edit question
Ubuntu file Edit question
No assignee Edit question
Solved by:
Florian Diesch
Last query:
Last reply:
Revision history for this message
Best Florian Diesch (diesch) said :
Revision history for this message
Adam Buchbinder (adam-buchbinder) said :

Ah, thank you. I should have looked there first.

Revision history for this message
Adam Buchbinder (adam-buchbinder) said :

Thanks Florian Diesch, that solved my question.