set password for printing

Asked by Peter AJ Hilbers on 2009-11-11

When a pdf-file is opened with acroread and then printed on a shared samba printer, a password is not asked, but the same actions with the file opened by evince gives a popup window in which a password is asked. When the password is supplied, the file is correctly printed. This feature is new (karmic koala), how can the settings be changed such that evince also directly prints the file, hence not every time the password needs to be given?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evince Edit question
Assignee:
No assignee Edit question
Solved by:
Luke Jennings
Solved:
2009-11-13
Last query:
2009-11-13
Last reply:
2009-11-13
Luke Jennings (ubuntujenkins) said : #1

If you open the print queue for the printer and select the item to be printed. Then click the "job" menu at the top and then click "Authenticate" enter your details and then tick the remember box. Alternatively reinstall the printer and on the first page of the setup there is an option to set the authentication then. Hope this helps.

Luke Jennings (ubuntujenkins) said : #2

If you open the print queue for the printer and select the item to be printed. Then click the "job" menu at the top and then click "Authenticate" enter your details and then tick the remember box. Alternatively reinstall the printer and on the first page of the setup there is an option to set the authentication then. Hope this helps.

> To: <email address hidden>
> From: <email address hidden>
> Subject: Re: [Question #89698]: set password for printing
> Date: Wed, 11 Nov 2009 16:48:11 +0000
>
> Your question #89698 on evince in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/evince/+question/89698
>
> UnbuntuJenkins posted a new comment:
> If you open the print queue for the printer and select the item to be
> printed. Then click the "job" menu at the top and then click
> "Authenticate" enter your details and then tick the remember box.
> Alternatively reinstall the printer and on the first page of the setup
> there is an option to set the authentication then. Hope this helps.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.

I had to reinstall the printer and now it works, so thanks.

What surprises me is that the authorisation by acroread behaves differently from that of evince and that when I was using
jaunty (where I used the same printer and indeed during installation had to give the username etc) I did not had to give the
authorisation for each job. So why did the upgrade to karmic koala has did 'side-'effect?

_________________________________________________________________
Kakker, Party of Nerd: download ze gratis voor in je Messenger
http://buddytest.rulive.nl/default.aspx?src=taglines

Best Luke Jennings (ubuntujenkins) said : #4

I am afraid that I have no knowledge of either program but I am glad that you found a solution.

Thanks UnbuntuJenkins, that solved my question.