Install MFC215C Brother ubuntu 9.10

Asked by Bill Shepherd on 2010-01-09

Brother solution center seem to have made it very difficult to understand by a newbie, what Commands and scripts I need to use to install LPR and CUPSWRAPPER

To complicate matters I cannot load the real driver MFC215C I have to use MFC210C does this mean that the Files or the data in the files need to be changed to make the real printer MFC215C work.

I did manage to get this printer working back 8.10. Brother appear to have made it more difficult on their Website, as they do not explain what the commands are doing.

Up to now I have managed to load on my spare PC about 6 different OS's but with out the Brother printer, Did have an old HP which worked every time.

Without a printer the Linux system is no good. Every thing else works straight out of the box. In Linux Format they could do with a good article on printing, and all the pitfalls, and work rounds.
I am still a Linux fan
Running a Novatech PC AMD Phenom II Quad Core 965 3.4Ghzs - Linux Ubuntu 9.10 downloaded from LXFDVD127 plus upgardes from the internet.
regards
Bill Shepherd

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Last query:
2010-03-24
Last reply:
2010-03-24

Could you please verify that you posted the correct model number? I myself have a Brother MFC-7840W and know that all MFC models contain 4 digits in the model name. I would like to help you but don't know what model you have for sure since I don't see it listed on the Brother Linux support website and or you didn't provide a correct model number. Please post back and I'll try my best to help you.

Sorry I found the page on Brothers site. It says to use the MFC-210C just like you said in your post. Does the printer work at all with that driver or not? The site doesn't specify any additional instructions so I'm guessing its a drop in replacement. Let me know.

Bill Shepherd (bshepherd95) said : #3

Hi Mark, I have closed this bug as I replied early on that I found an answer
to my problem.
Bother printers do not work on 64bit Operating systems - but don't ask me
why, do not have that info.

You are wrong in thinking all Brother printers have 4 digits - I have a
Brother MFC-215C and that is a correct Model No.
You have only got to look on sites selling Brother ink cartridges to know
that is a correct Model no.

I now have 5 OS's on my system, spread over 3 Hard Drives.
Mandriva
Crunchbang Linux
Ubuntu
Linux Mint
Printer only set up in Ubuntu

and that rotten system Windows 7

regards
Bill Shepherd
----- Original Message -----
From: "Mark Jones" <email address hidden>
To: <email address hidden>
Sent: Wednesday, March 24, 2010 8:22 AM
Subject: Re: [Question #96760]: Install MFC215C Brother ubuntu 9.10

Your question #96760 on cups in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/cups/+question/96760

    Status: Open => Needs information

Mark Jones requested for more information:
Could you please verify that you posted the correct model number? I
myself have a Brother MFC-7840W and know that all MFC models contain 4
digits in the model name. I would like to help you but don't know what
model you have for sure since I don't see it listed on the Brother Linux
support website and or you didn't provide a correct model number. Please
post back and I'll try my best to help you.

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+source/cups/+question/96760

You received this question notification because you are a direct
subscriber of the question.

Can you help with this problem?

Provide an answer of your own, or ask Bill Shepherd for more information if necessary.

To post a message you must log in.