compiz: switch virtual desktop using mouse wheel ONLY when mouse is over desktop

Asked by arne on 2009-11-25

Binary package hint: compizconfig-settings-manager

Just upgraded to Karmic. In Jaunty I was able to switch virtual desktops with mouse wheel up (move next) or down (move prev), in such a fashion that it ONLY worked if the mouse cursor was hovering over a visible part of the Desktop. This behaviour has changed in Karmic in that now ALL mouse wheel actions lead to virt. desktop switching -- normal scrolling is disabled.
Is there a secret option to re-enable Jaunty's behaviour?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu compizconfig-settings-manager Edit question
Assignee:
No assignee Edit question
Solved by:
arne
Solved:
2009-11-30
Last query:
2009-11-30
Last reply:
2009-11-26
Alex Wardle (awardle) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Well, it used to work in Jaunty, and it doesn't in Karmic. That's not a bug?

Robben (rj-grg) said : #3

By default, the work-space switching by using Mouse wheel wasn't activated in Karmic. I manually changed the settings. Go to :
CompizConfig Settings Manager -> Viewport Switcher -> Desktop-Based Viewport Switching.
Change 'Move Next' and 'Move Prev' to 'Button 4' and 'Button 5' respectively (default value is "Disabled").

This I too suppose isn't a bug, check or re-change your settings in the above manner. It should be working alright then!

Oh right! Thanks.

markhirota (markhirota) said : #5

Wow thanks so much Robben for posting this answer! This was a nice default in Jaunty that I missed in Karmic, and your instructions made it quite easy to enable.

Vikram Dhillon (dhillon-v10) said : #6

If your problem has been solved, please mark it solved :D

Regards,
Vikram Dhillon

~~~
There are lots of Linux users who don't care how the kernel works, but
only want to use it. That is a tribute to how good Linux is.
-- Linus Torvalds

On Tue, Dec 22, 2009 at 2:18 PM, markhirota
<email address hidden> wrote:
> Question #91722 on compizconfig-settings-manager in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/compizconfig-settings-manager/+question/91722
>
> markhirota posted a new comment:
> Wow thanks so much Robben for posting this answer! This was a nice
> default in Jaunty that I missed in Karmic, and your instructions made it
> quite easy to enable.
>
> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>