compiz config in 11.04

Asked by Miro Glavić on 2011-05-16

I just upgraded to 11.04 and was playing with my compiz config settings and as a result i lost my launcher bars and menus. The only thing that's on the screen is the background. What do I do?
I tried unity --reset command in tty but it did not work.
Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Solved by:
Miro Glavić
Solved:
2011-05-18
Last query:
2011-05-18
Last reply:
2011-05-16
Ivor Thomas (ivor-pdx) said : #1

Same thing happened to me. I was able to create a launcher for a browser and Nautilus, so I can surf and back up files to a thumbdirve, but I can't Alt-F2 or the shell to re-run Compiz-manager to try to undo. Is there a global 'reset to defaults' for Ubuntu and/or Natty?

Sam_ (and-sam) said : #2

> tried unity --reset command in tty but it did not work

And rebooted?

Maybe try this then.
unity --replace

If nothing helps reset Compiz configuration via tty and reboot. (Close all GUIs and save your work)
gconftool-2 --recursive-unset /apps/compiz-1
gconftool-2 --recursive-unset /apps/compizconfig-1
sudo reboot

http://manpages.ubuntu.com/manpages/natty/en/man1/gconftool-2.1.html

Before playing with CCSM again, export the default .profile in order to reset after an occasional misconfiguration or press button 'reset' under 'preferences'.
Test plugins successive, if it works export profile files and give it a meaningful name.
Some plugins conflict with each other, such as wall vs. cube, static switcher vs. ringswitcher.
Workaround by disabling 'automated plugin sorting', after done enabling it again.
Examples.
https://answers.launchpad.net/ubuntu/+source/gnome-panel/+question/156305
http://www.omgubuntu.co.uk/2011/04/compiz-cube-natty

Miro Glavić (klek) said : #3

Thanks Sam, unity --replace did the trick for me.

Ivor Thomas (ivor-pdx) said : #4

Unity --replace worked for me too. Whew! Thanks!!!!