Downloaded Packages fail to install

Asked by John Adrian Brooker on 2011-01-03

I am able to use the update Manager to download updates
But they won't install
I get the Following Message

nstallArchives() failed:
Extract templates from packages: 37%
Extract templates from packages: 74%
Extract templates from packages: 100%
Preconfiguring packages ...

Extract templates from packages: 37%
Extract templates from packages: 74%
Extract templates from packages: 100%
Preconfiguring packages ...
dpkg: unrecoverable fatal error, aborting:
 syntax error: unknown user 'clamav' in statoverride file

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu clamav Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-01-08
Last query:
2011-01-08
Last reply:
2011-01-08

Can you give the output of:

lsb_release -a; sudo apt-get update; sudo apt-get -y upgrade

Thanks

Hello
Here is the output that you requested.

Many Thanks

john@johnbzero:~$ sudo apt-get update; sudo apt-get -y upgrade
[sudo] password for john:
Hit http://archive.canonical.com maverick Release.gpg
Ign http://archive.canonical.com/ubuntu/ maverick/partner Translation-en
Hit http://gb.archive.ubuntu.com maverick Release.gpg
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick/main Translation-en
Hit http://extras.ubuntu.com maverick Release.gpg
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en
Hit http://security.ubuntu.com maverick-security Release.gpg
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en_GB
Get:1 http://gb.archive.ubuntu.com/ubuntu/ maverick/main Translation-en_GB [94.5kB]
Ign http://archive.canonical.com/ubuntu/ maverick/partner Translation-en_GB
Hit http://archive.canonical.com maverick Release
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en_GB
Hit http://extras.ubuntu.com maverick Release
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en_GB
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en_GB
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en_GB
Hit http://security.ubuntu.com maverick-security Release
Hit http://archive.canonical.com maverick/partner Sources
Hit http://extras.ubuntu.com maverick/main i386 Packages
Hit http://archive.canonical.com maverick/partner i386 Packages
Hit http://security.ubuntu.com maverick-security/main Sources
Get:2 http://dl.google.com stable Release.gpg [197B]
Hit http://security.ubuntu.com maverick-security/restricted Sources
Hit http://security.ubuntu.com maverick-security/universe Sources
Hit http://security.ubuntu.com maverick-security/multiverse Sources
Hit http://security.ubuntu.com maverick-security/main i386 Packages
Hit http://security.ubuntu.com maverick-security/restricted i386 Packages
Ign http://dl.google.com/linux/chrome/deb/ stable/main Translation-en
Hit http://security.ubuntu.com maverick-security/universe i386 Packages
Hit http://security.ubuntu.com maverick-security/multiverse i386 Packages
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en
Get:3 http://gb.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en_GB [91.2kB]
Ign http://dl.google.com/linux/chrome/deb/ stable/main Translation-en_GB
Get:4 http://dl.google.com stable Release [1,347B]
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en
Get:5 http://gb.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en_GB [2,332B]
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en
Get:6 http://gb.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en_GB [32.0kB]
Hit http://gb.archive.ubuntu.com maverick-updates Release.gpg
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en
Get:7 http://dl.google.com stable/main i386 Packages [1,088B]
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en_GB
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en_GB
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en_GB
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en_GB
Hit http://gb.archive.ubuntu.com maverick-backports Release.gpg
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-backports/main Translation-en
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-backports/main Translation-en_GB
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-backports/multiverse Translation-en
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-backports/multiverse Translation-en_GB
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-backports/restricted Translation-en
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-backports/restricted Translation-en_GB
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-backports/universe Translation-en
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-backports/universe Translation-en_GB
Hit http://gb.archive.ubuntu.com lucid-backports Release.gpg
Hit http://gb.archive.ubuntu.com maverick-proposed Release.gpg
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-proposed/main Translation-en
Get:8 http://gb.archive.ubuntu.com/ubuntu/ maverick-proposed/main Translation-en_GB [98.8kB]
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-proposed/multiverse Translation-en
Get:9 http://gb.archive.ubuntu.com/ubuntu/ maverick-proposed/multiverse Translation-en_GB [91.2kB]
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-proposed/restricted Translation-en
Get:10 http://gb.archive.ubuntu.com/ubuntu/ maverick-proposed/restricted Translation-en_GB [2,332B]
Ign http://gb.archive.ubuntu.com/ubuntu/ maverick-proposed/universe Translation-en
Get:11 http://gb.archive.ubuntu.com/ubuntu/ maverick-proposed/universe Translation-en_GB [32.2kB]
Hit http://gb.archive.ubuntu.com maverick Release
Hit http://gb.archive.ubuntu.com maverick-updates Release
Hit http://gb.archive.ubuntu.com maverick-backports Release
Hit http://gb.archive.ubuntu.com lucid-backports Release
Hit http://gb.archive.ubuntu.com maverick-proposed Release
Hit http://gb.archive.ubuntu.com maverick/main Sources
Hit http://gb.archive.ubuntu.com maverick/restricted Sources
Hit http://gb.archive.ubuntu.com maverick/universe Sources
Hit http://gb.archive.ubuntu.com maverick/multiverse Sources
Hit http://gb.archive.ubuntu.com maverick/main i386 Packages
Hit http://gb.archive.ubuntu.com maverick/restricted i386 Packages
Hit http://gb.archive.ubuntu.com maverick/universe i386 Packages
Hit http://gb.archive.ubuntu.com maverick/multiverse i386 Packages
Hit http://gb.archive.ubuntu.com maverick-updates/main Sources
Hit http://gb.archive.ubuntu.com maverick-updates/restricted Sources
Hit http://gb.archive.ubuntu.com maverick-updates/universe Sources
Hit http://gb.archive.ubuntu.com maverick-updates/multiverse Sources
Hit http://gb.archive.ubuntu.com maverick-updates/main i386 Packages
Hit http://gb.archive.ubuntu.com maverick-updates/restricted i386 Packages
Hit http://gb.archive.ubuntu.com maverick-updates/universe i386 Packages
Hit http://gb.archive.ubuntu.com maverick-updates/multiverse i386 Packages
Hit http://gb.archive.ubuntu.com maverick-backports/main i386 Packages
Hit http://gb.archive.ubuntu.com maverick-backports/restricted i386 Packages
Hit http://gb.archive.ubuntu.com maverick-backports/universe i386 Packages
Hit http://gb.archive.ubuntu.com maverick-backports/multiverse i386 Packages
Hit http://gb.archive.ubuntu.com lucid-backports/main Sources
Hit http://gb.archive.ubuntu.com lucid-backports/restricted Sources
Hit http://gb.archive.ubuntu.com lucid-backports/universe Sources
Hit http://gb.archive.ubuntu.com lucid-backports/multiverse Sources
Hit http://gb.archive.ubuntu.com maverick-proposed/restricted i386 Packages
Hit http://gb.archive.ubuntu.com maverick-proposed/main i386 Packages
Hit http://gb.archive.ubuntu.com maverick-proposed/multiverse i386 Packages
Hit http://gb.archive.ubuntu.com maverick-proposed/universe i386 Packages
Fetched 447kB in 0s (603kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  linux-generic linux-headers-generic linux-image-generic
The following packages will be upgraded:
  apparmor apparmor-utils aptdaemon brasero brasero-cdrkit brasero-common cups
  cups-bsd cups-client cups-common cups-ppdc dell-recovery dpkg dpkg-dev
  evince evince-common evolution evolution-common evolution-data-server
  evolution-data-server-common evolution-plugins git git-core
  google-chrome-stable gstreamer0.10-packagekit icedtea-6-jre-cacao
  icedtea6-plugin ifupdown imagemagick indicator-sound krb5-multidev
  language-pack-en language-pack-gnome-en libapparmor-perl libapparmor1
  libbrasero-media-dev libbrasero-media1 libcamel1.2-14 libcups2 libcupscgi1
  libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1 libdpkg-perl
  libebackend1.2-0 libebook1.2-9 libecal1.2-7 libedata-book1.2-2
  libedata-cal1.2-7 libedataserver1.2-13 libedataserverui1.2-8
  libegroupwise1.2-13 libevdocument3 libevolution libevview3
  libgdata-google1.2-1 libgdata1.2-1 libgssapi-krb5-2 libgssrpc4 libk5crypto3
  libkadm5clnt-mit7 libkadm5srv-mit7 libkdb5-4 libkrb5-3 libkrb5-dev
  libkrb5support0 libmagick++3 libmagickcore3 libmagickcore3-extra
  libmagickwand3 libpackagekit-glib2-14 libparted0debian1 libsmbclient
  libsqlite3-0 libsqlite3-dev libssl-dev libssl0.9.8 libvlc-dev libvlc5
  libvlccore-dev libvlccore4 libwbclient0 libx264-98 linux-firmware
  linux-libc-dev mozilla-plugin-vlc openjdk-6-jre openjdk-6-jre-headless
  openjdk-6-jre-lib openssl packagekit packagekit-backend-aptcc parted
  perlmagick python python-aptdaemon python-aptdaemon-gtk python-dbg
  python-dev python-minimal python-packagekit samba-common samba-common-bin
  smbclient thunderbird thunderbird-gnome-support ttf-symbol-replacement
  ubuntu-docs ubuntu-sso-client vlc vlc-data vlc-dbg vlc-nox vlc-plugin-ggi
  vlc-plugin-jack vlc-plugin-notify vlc-plugin-pulse vlc-plugin-sdl
  vlc-plugin-svg vlc-plugin-svgalib winbind wine-gecko wine1.2 wine1.2-dbg
  wine1.2-dev xulrunner-1.9.2
127 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 0B/214MB of archives.
After this operation, 6,222kB of additional disk space will be used.
Extract templates from packages: 100%
Preconfiguring packages ...
dpkg: unrecoverable fatal error, aborting:
 syntax error: unknown user 'clamav' in statoverride file
E: Sub-process /usr/bin/dpkg returned an error code (2)
john@johnbzero:~$

May help:

sudo apt-get update
sudo service clamav stop
gksudo gedit /var/lib/dpkg/statoverride

( delete the line with clamav)

sudo apt-get -f install
sudo apt-get install clamav
sudo apt-get purge clamav
sudo apt-get update
sudo service clamav start

Source:
http://ubuntuforums.org/archive/index.php/t-617496.html

Thanks actionparsnip, that solved my question.