syntax error

Asked by PliachasPaschalis on 2007-03-30

i try to install the latest updates and i get the following error. before that i used synaptic to install backuppc.
here is the error: "dpkg: syntax error: unknown user 'backuppc' in statoverride file E: Sub-process /usr/bin/dpkg returned an error code (2)
failed to install package. trying to recover:

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
PliachasPaschalis
Solved:
2007-04-10
Last query:
2007-04-10
Last reply:
2007-04-04
Ralph Janke (txwikinger) said : #1

Where do you get this error? Do you use apt-get?

It basically says you don't have a user account 'backuppc' on your system. Backuppc needs this user and usually sets it up when it is installed. Maybe you did not go through the screen when you installed in in synaptics.

Try to execute the following command from a commandline terminal:

sudo dpkg-reconfigure backuppc

This should let you go through the questions again.

After that your update should work again.

Hope this helps.

PliachasPaschalis (pliahas) said : #2

it says to me that the backuppc is destroyed or not fully installed

Ralph Janke (txwikinger) said : #3

Can you save somewhere your configuration files (/etc/backuppc) and remove the package?

I would then do

sudo apt-get update

and look if then everything is ok

PliachasPaschalis (pliahas) said : #4

i removed the folder and after that i did the command you said. no different. i tried then the following:
 sudo apt-get dist-upgrade
it downloaded some files and then i got the following:
dpkg: syntax error: unknown user `backuppc' in statoverride file
E: Sub-process /usr/bin/dpkg returned an error code (2)
any help please?

Ralph Janke (txwikinger) said : #5

Does

sudo apt-get remove backuppc

work?

Best PliachasPaschalis (pliahas) said : #6

i tried this command and the program told me to use autoremove. so i did: sudo apt-get autoremove
and after i did: sudo apt-get remove backuppc
 and after that i used sudo apt-get update
and finally: sudo apt-get install

agitation500 (agitation500) said : #7

had the same problem. This solved it:
1. got into /var/chache/apt/archives and delete the file "lock"
2. delete the file /var/lib/dpkg/statoverride
3. start over

cbaunni (cbaunni) said : #8

Thanks a lot agitation500.. you saved hours for me...