Upgrade to Natty has broken Broadcom STA

Asked by Derek Shute on 2011-12-10

Just upgraded to Natty after delaying as long as possible. Everything works except wireless connection. I've checked all settings - all OK. I've then run Checkbox - reports included in Bugs section (sorry if this breaks protocol - but not sure whether this is question or bug). I then tried removing Broadcom STA and running - no luck. Reactivating Broadcom STA - no luck. Various combinations of rebooting along the way. It was working perfectly before - obviously because I was able to download Natty.

I am not as clued in as you guys, but please, please, please help.

Would it be easy to revert to an earlier Ubuntu - how would I do that ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu broadcom-sta Edit question
Assignee:
No assignee Edit question
Solved by:
Derek Shute
Solved:
2011-12-11
Last query:
2011-12-11
Last reply:
2011-12-11
Ubfan (ubfan1) said : #1

The older broadcom chips like the 4311 started having problems with the STA driver (bug #732677). The b43 driver works fine on these older chips, after you install the firmware( sudo apt-get install b43-fwcutter) on a wired connection, and clean out any lines exactly like "blacklist b43" or "blacklist b43legacy" in any file in /etc/modprobe.d. Deactivating the STA drivers may get rid of some of these, but check anyway.
  If you don't like the unity interface, you can always install another of your choice instead of trying to downgrading.

marcus aurelius (adbiz) said : #2

version 11.04 and 11.10 use a different bcom package. it's "firmware-b43-installer".

Derek Shute (yg-derek) said : #3

While searching site for "blacklist b43" came across someone who has had exact same problem as me on same laptop (Inspiron 1501). Someone had posted a fix:

 $ sudo apt-get update
 $ sudo apt-get install firmware-b43-installer
 $ sudo apt-get remove bcmwl-kernel-source
 $ sudo reboot

Not sure whether this does what you recommended, but it as worked for me

      thanks