cannot start bind9

Asked by aneesh on 2009-11-18

When I restart bind9 in my ubuntu 9.04 using command /etc/init.d/bind9 restart
 it has shows the following output

* Stopping domain name service... bind9 [ OK ]
   rndc: connect failed: 127.0.0.1#953: connection refused
    * Starting domain name service... bind9 [fail]

how can I start bind9 .what is the actual problem here ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bind9 Edit question
Assignee:
No assignee Edit question
Solved by:
Cristi Nistor
Solved:
2009-11-20
Last query:
2009-11-20
Last reply:
2009-11-20
Cristi Nistor (cristi-nistor) said : #1

Take a look at the /var/log/syslog file to see if any references regarding the BIND server after you try to restart the service. It may be a misconfiguration of this service. And get back to tell as the relevant messages.

Good luck.

aneesh (aneesholv) said : #2

hai,

    Following are my /var/log/syslog contents

Nov 18 18:05:20 aneesh named[4378]: starting BIND 9.5.1-P2 -u bind
Nov 18 18:05:20 aneesh named[4378]: found 1 CPU, using 1 worker thread
Nov 18 18:05:20 aneesh named[4378]: using up to 4096 sockets
Nov 18 18:05:20 aneesh named[4378]: loading configuration from
'/etc/bind/named.conf'
Nov 18 18:05:20 aneesh named[4378]: /etc/bind/named.conf:8: unknown option
'forwarders'
Nov 18 18:05:20 aneesh named[4378]: /etc/bind/named.conf.local:7: expected
quoted string near '“'
Nov 18 18:05:20 aneesh named[4378]: loading configuration: unexpected token
Nov 18 18:05:20 aneesh named[4378]: exiting (due to fatal error)
Nov 18 18:05:44 aneesh named[4431]: starting BIND 9.5.1-P2 -u bind
Nov 18 18:05:44 aneesh named[4431]: found 1 CPU, using 1 worker thread
Nov 18 18:05:44 aneesh named[4431]: using up to 4096 sockets
Nov 18 18:05:44 aneesh named[4431]: loading configuration from
'/etc/bind/named.conf'
Nov 18 18:05:44 aneesh named[4431]: /etc/bind/named.conf:8: unknown option
'forwarders'
Nov 18 18:05:44 aneesh named[4431]: /etc/bind/named.conf.local:7: expected
quoted string near '“'
Nov 18 18:05:44 aneesh named[4431]: loading configuration: unexpected token
Nov 18 18:05:44 aneesh named[4431]: exiting (due to fatal error)

      with regards

On Wed, Nov 18, 2009 at 5:21 PM, Cristi Nistor <
<email address hidden>> wrote:

> Your question #90687 on gnome-terminal in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/90687
>
> Status: Open => Answered
>
> Cristi Nistor proposed the following answer:
> Take a look at the /var/log/syslog file to see if any references
> regarding the BIND server after you try to restart the service. It may
> be a misconfiguration of this service. And get back to tell as the
> relevant messages.
>
> Good luck.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/90687/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/90687
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
------with regards,

                      Aneesh.T.V
                      Olavara
                      Mob:9544067525

Cristi Nistor (cristi-nistor) said : #3

forwarders should be IN the options sections in your /etc/bind/named.conf, something like

options {
directory "/var/cache/bind";

auth-nxdomain no; # conform to RFC1035
listen-on-v6 { any; };

forwarders {
XXX.XXX.XXX.XXX
};
};
Also you have a syntax error in your /etc/bind/named.conf.local file. If you copied/pasted the code make sure the " char is typed by you; and look maybe you omitted some ; char in your syntax.

Good luck.

aneesh (aneesholv) said : #4

hello cristi Nistor,

     As per your instruction i had changed my /etc/bind/named.conf.options
file. But till the same problem exist.My current
/etc/bind/named.conf.options file and /etc/bind/named.conf.local files
configuration are given below .please help me to overcome this problem

options {
    directory "/var/cache/bind";

    // If there is a firewall between you and nameservers you want
    // to talk to, you may need to fix the firewall to allow multiple
    // ports to talk. See http://www.kb.cert.org/vuls/id/800113

    // If your ISP provided one or more IP addresses for stable
    // nameservers, you probably want to use them as forwarders.
    // Uncomment the following block, and insert the addresses replacing
    // the all-0's placeholder.

     forwarders {
         10.10.0.100;
     };

    auth-nxdomain no; # conform to RFC1035
    listen-on-v6 { any; };
};

/
// Do any local configuration here
//
# This is the zone definition. replace example.com with your domain name
zone “aneesh.com” {
type master;
file “/etc/bind/zones/aneesh.com.db”;
};

#This is the zone definition for reverse DNS. replace 0.168.192 with your
network address in reverse notation – e.g #my network address is .0.10.10
zone “0.10.10.in-addr.arpa” {
type master;
file “/etc/bind/zones/rev.0.10.10.in-addr.arpa”;
};
// Consider adding the 1918 zones here, if they are not used in your
// organization
//include "/etc/bind/zones.rfc1918";

On Wed, Nov 18, 2009 at 6:30 PM, Cristi Nistor <
<email address hidden>> wrote:

> Your question #90687 on gnome-terminal in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/90687
>
> Status: Open => Answered
>
> Cristi Nistor proposed the following answer:
> forwarders should be IN the options sections in your
> /etc/bind/named.conf, something like
>
> options {
> directory "/var/cache/bind";
>
> auth-nxdomain no; # conform to RFC1035
> listen-on-v6 { any; };
>
> forwarders {
> XXX.XXX.XXX.XXX
> };
> };
> Also you have a syntax error in your /etc/bind/named.conf.local file. If
> you copied/pasted the code make sure the " char is typed by you; and look
> maybe you omitted some ; char in your syntax.
>
> Good luck.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/90687/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/90687
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
------with regards,

                      Aneesh.T.V
                      Olavara
                      Mob:9544067525

Best Cristi Nistor (cristi-nistor) said : #5

/
// Do any local configuration here
//
# This is the zone definition. replace example.com with your domain name
zone “aneesh.com” {
type master;
file “/etc/bind/zones/aneesh.com.db”;
};

#This is the zone definition for reverse DNS. replace 0.168.192 with your
network address in reverse notation – e.g #my network address is .0.10.10
zone “0.10.10.in-addr.arpa” {
type master;
file “/etc/bind/zones/rev.0.10.10.in-addr.arpa”;
};

Here is the problem. If you copied pasted make double forward slash in the previous line for //Do any local .... If you take a look at your post above, you'll see some strange " chars starting from zone “aneesh.com” . Delete the " chars and add them by yourself for each statement as I told you before. It seems that they aren't ASCII chars as they should be.

Also take a look at named.conf file and not named.conf.options, because from there was registered the error in /var/log/syslog

Nov 18 18:05:20 aneesh named[4378]: /etc/bind/named.conf:8: unknown option 'forwarders'

Update the files and get back to tell us if it's ok

aneesh (aneesholv) said : #6

Hai cristi Nistor

             Thanks alot. now its ok

On Thu, Nov 19, 2009 at 9:49 PM, Cristi Nistor <
<email address hidden>> wrote:

> Your question #90687 on bind9 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/bind9/+question/90687
>
> Status: Open => Answered
>
> Cristi Nistor proposed the following answer:
> /
> // Do any local configuration here
> //
> # This is the zone definition. replace example.com with your domain name
> zone “aneesh.com” {
> type master;
> file “/etc/bind/zones/aneesh.com.db”;
> };
>
> #This is the zone definition for reverse DNS. replace 0.168.192 with your
> network address in reverse notation – e.g #my network address is .0.10.10
> zone “0.10.10.in-addr.arpa” {
> type master;
> file “/etc/bind/zones/rev.0.10.10.in-addr.arpa”;
> };
>
> Here is the problem. If you copied pasted make double forward slash in
> the previous line for //Do any local .... If you take a look at your
> post above, you'll see some strange " chars starting from zone
> “aneesh.com” . Delete the " chars and add them by yourself for each
> statement as I told you before. It seems that they aren't ASCII chars as
> they should be.
>
> Also take a look at named.conf file and not named.conf.options, because
> from there was registered the error in /var/log/syslog
>
> Nov 18 18:05:20 aneesh named[4378]: /etc/bind/named.conf:8: unknown
> option 'forwarders'
>
> Update the files and get back to tell us if it's ok
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/bind9/+question/90687/+confirm?answer_id=4
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/bind9/+question/90687
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
------with regards,

                      Aneesh.T.V
                      Olavara
                      Mob:9544067525

Cristi Nistor (cristi-nistor) said : #7

Please mark the question as solved and chose the answer which helped you.

Regards,
Cristian Nistor

aneesh (aneesholv) said : #8

Thanks Cristi Nistor, that solved my question.