E: Archive directory /var/cache/apt/archives/partial is missing

Asked by Surut

hi there,

when i run the command " sudo get-apt update" i recieve error "E: Archive directory /var/cache/apt/archives/partial is missing".
what i have done here is that by mistake i have deleted the "/var/cache/apt/archives/partial" from the system while trying to remove the downloaded packages which i got via " sudo apt-get install" is there any way i can correct this problem.

thanks a lot


Question information

English Edit question
Ubuntu apt Edit question
No assignee Edit question
Solved by:
Cesare Tirabassi
Last query:
Last reply:
Revision history for this message
Best Cesare Tirabassi (norsetto) said :

First of all, to clean your cache just use this command:

sudo apt-get clean

This will avoid this kind of problems in the future.

Lets try to solve this by remaking the missing directory:

sudo mkdir -m755 /var/cache/apt/archives/partial

Revision history for this message
Surut (surut-shah) said :

Thanks Cesare Tirabassi, that solved my question.

Revision history for this message
Tina Russell (tinarussell) said :

Thanks! I made the same mistake, and this saved me.