aptd crashes afver latest Ubuntu Softw Updates

Asked by Mark Jackson on 2016-12-13

After re-boot and desktop start, see Ubuntu error and crash from aptd. Running commands,
administrator@testanalyst:~$ ubuntu-support-status
Support status summary of 'testanalyst':

You have 48 packages (3.0%) supported until May 2017 (3y)
You have 1404 packages (88.6%) supported until May 2019 (5y)
You have 1 packages (0.1%) supported until September 2017 (9m)

You have 0 packages (0.0%) that can not/no-longer be downloaded
You have 131 packages (8.3%) that are unsupported

Your Hardware Enablement Stack (HWE) is supported until April 2019.

Run with --show-unsupported, --show-supported or --show-all to see more details
administrator@testanalyst:~$ cat /etc/dpkg/dpkg.cfg.d/multiarch
cat: /etc/dpkg/dpkg.cfg.d/multiarch: No such file or directory
administrator@testanalyst:~$ cat /etc/dpkg/dpkg.cfg.d/multiarch
cat: /etc/dpkg/dpkg.cfg.d/multiarch: No such file or directory
administrator@testanalyst:~$ dpkg --print-foreign-architectures
i386
administrator@testanalyst:~$ sudo grep -R proxy /etc/apt/*
[sudo] password for administrator:
administrator@testanalyst:~$ grep proxy /etc/environment
administrator@testanalyst:~$ echo $http_proxy

administrator@testanalyst:~$ grep proxy /etc/bash.bashrc
administrator@testanalyst:~$ grep proxy ~/.bashrc
administrator@testanalyst:~$ cat /etc/apt/apt.conf
cat: /etc/apt/apt.conf: No such file or directory
administrator@testanalyst:~$ sudo fuser -vvv /var/lib/dpkg/lock
administrator@testanalyst:~$ sudo fuser -vvv /var/cache/apt/archives/lock
administrator@testanalyst:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.5 LTS"
administrator@testanalyst:~$ uname -a
Linux testanalyst 4.4.0-53-generic #74~14.04.1-Ubuntu SMP Fri Dec 2 03:43:31 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
administrator@testanalyst:~$ sudo rm /var/lib/apt/lists/lock
administrator@testanalyst:~$ sudo rm /var/cache/apt/archives/lock
administrator@testanalyst:~$ sudo rm /var/lib/dpkg/lock
administrator@testanalyst:~$ sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
administrator@testanalyst:~$ sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-bad
administrator@testanalyst:~$ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status || sudo cp /var/backups/apt.extended_states.0 /var/lib/dpkg/status
administrator@testanalyst:~$ sudo mv /var/lib/dpkg/available /var/lib/dpkg/available-bad
administrator@testanalyst:~$ sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
administrator@testanalyst:~$ sudo rm -rf /var/lib/dpkg/updates/*
administrator@testanalyst:~$ sudo rm -rf /var/lib/apt/lists
administrator@testanalyst:~$ sudo rm /var/cache/apt/*.bin
administrator@testanalyst:~$ sudo mkdir /var/lib/apt/lists
administrator@testanalyst:~$ sudo mkdir /var/lib/apt/lists/partial
administrator@testanalyst:~$ LANG=C;sudo apt-get clean
administrator@testanalyst:~$ LANG=C;sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
administrator@testanalyst:~$ sudo dpkg --configure -a
Setting up isc-dhcp-common (4.2.4-7ubuntu12.8) ...
Setting up libsystemd-journal0:amd64 (204-5ubuntu20.20) ...
Setting up init-system-helpers (1.14ubuntu1) ...
Setting up tzdata-java (2016j-0ubuntu0.14.04) ...
Setting up libudev1:amd64 (204-5ubuntu20.20) ...
Setting up software-center (13.10-0ubuntu4.2) ...
Updating software catalog...this may take a moment.
INFO:softwarecenter.db.pkginfo_impl.aptcache:aptcache.open()
Software catalog update was successful.
Setting up libsystemd-daemon0:amd64 (204-5ubuntu20.20) ...
Setting up libsystemd-login0:amd64 (204-5ubuntu20.20) ...
Setting up libgs9-common (9.10~dfsg-0ubuntu10.6) ...
Setting up linux-headers-4.4.0-53 (4.4.0-53.74~14.04.1) ...
Setting up linux-image-4.4.0-53-generic (4.4.0-53.74~14.04.1) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
initrd.img(/boot/initrd.img-4.4.0-53-generic
) points to /boot/initrd.img-4.4.0-53-generic
 (/boot/initrd.img-4.4.0-53-generic) -- doing nothing at /var/lib/dpkg/info/linux-image-4.4.0-53-generic.postinst line 491.
vmlinuz(/boot/vmlinuz-4.4.0-53-generic
) points to /boot/vmlinuz-4.4.0-53-generic
 (/boot/vmlinuz-4.4.0-53-generic) -- doing nothing at /var/lib/dpkg/info/linux-image-4.4.0-53-generic.postinst line 491.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-53-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.4.0-53-generic
Found initrd image: /boot/initrd.img-4.4.0-53-generic
Found linux image: /boot/vmlinuz-4.4.0-51-generic
Found initrd image: /boot/initrd.img-4.4.0-51-generic
Found linux image: /boot/vmlinuz-4.4.0-45-generic
Found initrd image: /boot/initrd.img-4.4.0-45-generic
Found linux image: /boot/vmlinuz-4.4.0-42-generic
Found initrd image: /boot/initrd.img-4.4.0-42-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
Found Windows 7 (loader) on /dev/sdb1
done
Setting up python3-distupgrade (1:0.220.9) ...
Setting up firefox (50.0.2+build1-0ubuntu0.14.04.1) ...
Please restart all running instances of firefox, or you will experience problems.
Setting up linux-image-extra-4.4.0-53-generic (4.4.0-53.74~14.04.1) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-53-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.4.0-53-generic
Found initrd image: /boot/initrd.img-4.4.0-53-generic
Found linux image: /boot/vmlinuz-4.4.0-51-generic
Found initrd image: /boot/initrd.img-4.4.0-51-generic
Found linux image: /boot/vmlinuz-4.4.0-45-generic
Found initrd image: /boot/initrd.img-4.4.0-45-generic
Found linux image: /boot/vmlinuz-4.4.0-42-generic
Found initrd image: /boot/initrd.img-4.4.0-42-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
Found Windows 7 (loader) on /dev/sdb1
done
Setting up udev (204-5ubuntu20.20) ...
udev stop/waiting
udev start/running, process 19113
update-initramfs: deferring update (trigger activated)
Setting up isc-dhcp-client (4.2.4-7ubuntu12.8) ...
Setting up linux-headers-4.4.0-53-generic (4.4.0-53.74~14.04.1) ...
Setting up atom (1.12.7-1~webupd8~0) ...
tar: atom*.tar.xz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
dpkg: error processing package atom (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up libgudev-1.0-0:amd64 (1:204-5ubuntu20.20) ...
Setting up systemd-services (204-5ubuntu20.20) ...
Setting up libpam-systemd:amd64 (204-5ubuntu20.20) ...
Setting up linux-image-generic-lts-xenial (4.4.0.53.40) ...
Setting up libgs9 (9.10~dfsg-0ubuntu10.6) ...
Setting up gir1.2-gudev-1.0 (1:204-5ubuntu20.20) ...
Setting up ubuntu-release-upgrader-core (1:0.220.9) ...
Setting up ghostscript (9.10~dfsg-0ubuntu10.6) ...
Setting up ubuntu-drivers-common (1:0.2.91.12) ...
Setting up linux-headers-generic-lts-xenial (4.4.0.53.40) ...
Setting up ubuntu-release-upgrader-gtk (1:0.220.9) ...
Setting up linux-generic-lts-xenial (4.4.0.53.40) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
Processing triggers for initramfs-tools (0.103ubuntu4.4) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-53-generic
Errors were encountered while processing:
 atom
administrator@testanalyst:~$ sudo dpkg --clear-avail
administrator@testanalyst:~$ LANG=C;sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-42 linux-headers-4.4.0-42-generic
  linux-image-4.4.0-42-generic linux-image-extra-4.4.0-42-generic
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up atom (1.12.7-1~webupd8~0) ...
tar: atom*.tar.xz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
dpkg: error processing package atom (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 atom
E: Sub-process /usr/bin/dpkg returned an error code (1)
administrator@testanalyst:~$ LANG=C;sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-42 linux-headers-4.4.0-42-generic
  linux-image-4.4.0-42-generic linux-image-extra-4.4.0-42-generic
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up atom (1.12.7-1~webupd8~0) ...
tar: atom*.tar.xz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
dpkg: error processing package atom (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 atom
E: Sub-process /usr/bin/dpkg returned an error code (1)
administrator@testanalyst:~$ LANG=C;sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  linux-headers-4.4.0-42* linux-headers-4.4.0-42-generic*
  linux-image-4.4.0-42-generic* linux-image-extra-4.4.0-42-generic*
0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 300 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 343589 files and directories currently installed.)
Removing linux-headers-4.4.0-42-generic (4.4.0-42.62~14.04.1) ...
Removing linux-headers-4.4.0-42 (4.4.0-42.62~14.04.1) ...
Removing linux-image-extra-4.4.0-42-generic (4.4.0-42.62~14.04.1) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-42-generic /boot/vmlinuz-4.4.0-42-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-42-generic /boot/vmlinuz-4.4.0-42-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-42-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.4.0-42-generic /boot/vmlinuz-4.4.0-42-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.4.0-42-generic /boot/vmlinuz-4.4.0-42-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.4.0-53-generic
Found initrd image: /boot/initrd.img-4.4.0-53-generic
Found linux image: /boot/vmlinuz-4.4.0-51-generic
Found initrd image: /boot/initrd.img-4.4.0-51-generic
Found linux image: /boot/vmlinuz-4.4.0-45-generic
Found initrd image: /boot/initrd.img-4.4.0-45-generic
Found linux image: /boot/vmlinuz-4.4.0-42-generic
Found initrd image: /boot/initrd.img-4.4.0-42-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
Found Windows 7 (loader) on /dev/sdb1
done
Purging configuration files for linux-image-extra-4.4.0-42-generic (4.4.0-42.62~14.04.1) ...
Removing linux-image-4.4.0-42-generic (4.4.0-42.62~14.04.1) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-42-generic /boot/vmlinuz-4.4.0-42-generic
update-initramfs: Deleting /boot/initrd.img-4.4.0-42-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-42-generic /boot/vmlinuz-4.4.0-42-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.4.0-53-generic
Found initrd image: /boot/initrd.img-4.4.0-53-generic
Found linux image: /boot/vmlinuz-4.4.0-51-generic
Found initrd image: /boot/initrd.img-4.4.0-51-generic
Found linux image: /boot/vmlinuz-4.4.0-45-generic
Found initrd image: /boot/initrd.img-4.4.0-45-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
Found Windows 7 (loader) on /dev/sdb1
done
Purging configuration files for linux-image-4.4.0-42-generic (4.4.0-42.62~14.04.1) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-42-generic /boot/vmlinuz-4.4.0-42-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-42-generic /boot/vmlinuz-4.4.0-42-generic
Setting up atom (1.12.7-1~webupd8~0) ...
tar: atom*.tar.xz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
dpkg: error processing package atom (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 atom
E: Sub-process /usr/bin/dpkg returned an error code (1)
administrator@testanalyst:~$ LANG=C;sudo apt-get --fix-missing update -o APT::Cache-Limit=100000000
Ign http://us.archive.ubuntu.com trusty InRelease
Get:1 http://security.ubuntu.com trusty-security InRelease [65.9 kB]
Get:2 http://us.archive.ubuntu.com trusty-updates InRelease [65.9 kB]
Get:3 http://us.archive.ubuntu.com trusty Release.gpg [933 B]
Get:4 http://security.ubuntu.com trusty-security/main Sources [123 kB]
Get:5 http://us.archive.ubuntu.com trusty-updates/main Sources [387 kB]
Get:6 http://security.ubuntu.com trusty-security/restricted Sources [4613 B]
Get:7 http://security.ubuntu.com trusty-security/universe Sources [46.3 kB]
Get:8 http://ppa.launchpad.net trusty InRelease [15.5 kB]
Get:9 http://security.ubuntu.com trusty-security/multiverse Sources [3199 B]
Get:10 http://security.ubuntu.com trusty-security/main amd64 Packages [565 kB]
Get:11 http://us.archive.ubuntu.com trusty-updates/restricted Sources [5888 B]
Get:12 http://us.archive.ubuntu.com trusty-updates/universe Sources [170 kB]
Get:13 http://ppa.launchpad.net trusty/main amd64 Packages [569 B]
Get:14 http://us.archive.ubuntu.com trusty-updates/multiverse Sources [7522 B]
Get:15 http://us.archive.ubuntu.com trusty-updates/main amd64 Packages [930 kB]
Get:16 http://ppa.launchpad.net trusty/main i386 Packages [570 B]
Get:17 http://security.ubuntu.com trusty-security/restricted amd64 Packages [13.3 kB]
Get:18 http://ppa.launchpad.net trusty/main Translation-en [299 B]
Get:19 http://security.ubuntu.com trusty-security/universe amd64 Packages [146 kB]
Get:20 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [4140 B]
Get:21 http://security.ubuntu.com trusty-security/main i386 Packages [524 kB]
Get:22 http://us.archive.ubuntu.com trusty-updates/restricted amd64 Packages [16.4 kB]
Get:23 http://us.archive.ubuntu.com trusty-updates/universe amd64 Packages [390 kB]
Get:24 http://security.ubuntu.com trusty-security/restricted i386 Packages [13.1 kB]
Get:25 http://security.ubuntu.com trusty-security/universe i386 Packages [146 kB]
Get:26 http://us.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [14.0 kB]
Get:27 http://security.ubuntu.com trusty-security/multiverse i386 Packages [4301 B]
Get:28 http://us.archive.ubuntu.com trusty-updates/main i386 Packages [889 kB]
Get:29 http://security.ubuntu.com trusty-security/main Translation-en [311 kB]
Get:30 http://security.ubuntu.com trusty-security/multiverse Translation-en [2201 B]
Get:31 http://security.ubuntu.com trusty-security/restricted Translation-en [3349 B]
Get:32 http://security.ubuntu.com trusty-security/universe Translation-en [86.1 kB]
Get:33 http://us.archive.ubuntu.com trusty-updates/restricted i386 Packages [16.2 kB]
Get:34 http://us.archive.ubuntu.com trusty-updates/universe i386 Packages [392 kB]
Get:35 http://us.archive.ubuntu.com trusty-updates/multiverse i386 Packages [14.5 kB]
Get:36 http://us.archive.ubuntu.com trusty-updates/main Translation-en [453 kB]
Get:37 http://us.archive.ubuntu.com trusty-updates/multiverse Translation-en [7340 B]
Get:38 http://us.archive.ubuntu.com trusty-updates/restricted Translation-en [3842 B]
Get:39 http://us.archive.ubuntu.com trusty-updates/universe Translation-en [206 kB]
Get:40 http://us.archive.ubuntu.com trusty Release [58.5 kB]
Get:41 http://us.archive.ubuntu.com trusty/main Sources [1064 kB]
Get:42 http://us.archive.ubuntu.com trusty/restricted Sources [5433 B]
Get:43 http://us.archive.ubuntu.com trusty/universe Sources [6399 kB]
Get:44 http://us.archive.ubuntu.com trusty/multiverse Sources [174 kB]
Get:45 http://us.archive.ubuntu.com trusty/main amd64 Packages [1350 kB]
Get:46 http://us.archive.ubuntu.com trusty/restricted amd64 Packages [13.0 kB]
Get:47 http://us.archive.ubuntu.com trusty/universe amd64 Packages [5859 kB]
Get:48 http://us.archive.ubuntu.com trusty/multiverse amd64 Packages [132 kB]
Get:49 http://us.archive.ubuntu.com trusty/main i386 Packages [1348 kB]
Get:50 http://us.archive.ubuntu.com trusty/restricted i386 Packages [13.4 kB]
Get:51 http://us.archive.ubuntu.com trusty/universe i386 Packages [5866 kB]
Get:52 http://us.archive.ubuntu.com trusty/multiverse i386 Packages [134 kB]
Get:53 http://us.archive.ubuntu.com trusty/main Translation-en [762 kB]
Get:54 http://us.archive.ubuntu.com trusty/multiverse Translation-en [102 kB]
Get:55 http://us.archive.ubuntu.com trusty/restricted Translation-en [3457 B]
Get:56 http://us.archive.ubuntu.com trusty/universe Translation-en [4089 kB]
Fetched 33.4 MB in 12s (2584 kB/s)
Reading package lists... Done
administrator@testanalyst:~$ LANG=C;sudo apt-get update -o APT::Cache-Limit=100000000 && sudo apt-get dist-upgrade
Ign http://us.archive.ubuntu.com trusty InRelease
Hit http://us.archive.ubuntu.com trusty-updates InRelease
Hit http://us.archive.ubuntu.com trusty Release.gpg
Hit http://us.archive.ubuntu.com trusty-updates/main Sources
Hit http://us.archive.ubuntu.com trusty-updates/restricted Sources
Hit http://us.archive.ubuntu.com trusty-updates/universe Sources
Hit http://us.archive.ubuntu.com trusty-updates/multiverse Sources
Hit http://us.archive.ubuntu.com trusty-updates/main amd64 Packages
Hit http://us.archive.ubuntu.com trusty-updates/restricted amd64 Packages
Hit http://us.archive.ubuntu.com trusty-updates/universe amd64 Packages
Hit http://us.archive.ubuntu.com trusty-updates/multiverse amd64 Packages
Hit http://ppa.launchpad.net trusty InRelease
Hit http://security.ubuntu.com trusty-security InRelease
Hit http://us.archive.ubuntu.com trusty-updates/main i386 Packages
Hit http://us.archive.ubuntu.com trusty-updates/restricted i386 Packages
Hit http://us.archive.ubuntu.com trusty-updates/universe i386 Packages
Hit http://us.archive.ubuntu.com trusty-updates/multiverse i386 Packages
Hit http://us.archive.ubuntu.com trusty-updates/main Translation-en
Hit http://us.archive.ubuntu.com trusty-updates/multiverse Translation-en
Hit http://ppa.launchpad.net trusty/main amd64 Packages
Hit http://us.archive.ubuntu.com trusty-updates/restricted Translation-en
Hit http://security.ubuntu.com trusty-security/main Sources
Hit http://us.archive.ubuntu.com trusty-updates/universe Translation-en
Hit http://us.archive.ubuntu.com trusty Release
Hit http://ppa.launchpad.net trusty/main i386 Packages
Hit http://security.ubuntu.com trusty-security/restricted Sources
Hit http://us.archive.ubuntu.com trusty/main Sources
Hit http://us.archive.ubuntu.com trusty/restricted Sources
Hit http://us.archive.ubuntu.com trusty/universe Sources
Hit http://us.archive.ubuntu.com trusty/multiverse Sources
Hit http://us.archive.ubuntu.com trusty/main amd64 Packages
Hit http://us.archive.ubuntu.com trusty/restricted amd64 Packages
Hit http://ppa.launchpad.net trusty/main Translation-en
Hit http://security.ubuntu.com trusty-security/universe Sources
Hit http://us.archive.ubuntu.com trusty/universe amd64 Packages
Hit http://us.archive.ubuntu.com trusty/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com trusty/main i386 Packages
Hit http://us.archive.ubuntu.com trusty/restricted i386 Packages
Hit http://us.archive.ubuntu.com trusty/universe i386 Packages
Hit http://us.archive.ubuntu.com trusty/multiverse i386 Packages
Hit http://us.archive.ubuntu.com trusty/main Translation-en
Hit http://security.ubuntu.com trusty-security/multiverse Sources
Hit http://us.archive.ubuntu.com trusty/multiverse Translation-en
Hit http://us.archive.ubuntu.com trusty/restricted Translation-en
Hit http://us.archive.ubuntu.com trusty/universe Translation-en
Hit http://security.ubuntu.com trusty-security/main amd64 Packages
Hit http://security.ubuntu.com trusty-security/restricted amd64 Packages
Hit http://security.ubuntu.com trusty-security/universe amd64 Packages
Hit http://security.ubuntu.com trusty-security/multiverse amd64 Packages
Hit http://security.ubuntu.com trusty-security/main i386 Packages
Hit http://security.ubuntu.com trusty-security/restricted i386 Packages
Hit http://security.ubuntu.com trusty-security/universe i386 Packages
Hit http://security.ubuntu.com trusty-security/multiverse i386 Packages
Hit http://security.ubuntu.com trusty-security/main Translation-en
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en
Hit http://security.ubuntu.com trusty-security/restricted Translation-en
Hit http://security.ubuntu.com trusty-security/universe Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  apt apt-transport-https apt-utils firefox libapt-inst1.5 libapt-pkg4.12
  libsmbclient libwbclient0 python-samba samba-common samba-common-bin
  samba-libs smbclient
13 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 54.4 MB of archives.
After this operation, 16.4 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main libwbclient0 amd64 2:4.3.11+dfsg-0ubuntu0.14.04.3 [30.9 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main python-samba amd64 2:4.3.11+dfsg-0ubuntu0.14.04.3 [1067 kB]
Get:3 http://security.ubuntu.com/ubuntu/ trusty-security/main libapt-pkg4.12 amd64 1.0.1ubuntu2.17 [639 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main samba-common-bin amd64 2:4.3.11+dfsg-0ubuntu0.14.04.3 [509 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main smbclient amd64 2:4.3.11+dfsg-0ubuntu0.14.04.3 [312 kB]
Get:6 http://security.ubuntu.com/ubuntu/ trusty-security/main apt amd64 1.0.1ubuntu2.17 [953 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main libsmbclient amd64 2:4.3.11+dfsg-0ubuntu0.14.04.3 [53.2 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main samba-libs amd64 2:4.3.11+dfsg-0ubuntu0.14.04.3 [5138 kB]
Get:9 http://security.ubuntu.com/ubuntu/ trusty-security/main libapt-inst1.5 amd64 1.0.1ubuntu2.17 [58.8 kB]
Get:10 http://security.ubuntu.com/ubuntu/ trusty-security/main apt-utils amd64 1.0.1ubuntu2.17 [171 kB]
Get:11 http://security.ubuntu.com/ubuntu/ trusty-security/main apt-transport-https amd64 1.0.1ubuntu2.17 [25.0 kB]
Get:12 http://security.ubuntu.com/ubuntu/ trusty-security/main firefox amd64 50.1.0+build2-0ubuntu0.14.04.1 [45.3 MB]
Get:13 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main samba-common all 2:4.3.11+dfsg-0ubuntu0.14.04.3 [84.1 kB]
Fetched 54.4 MB in 30s (1791 kB/s)
Preconfiguring packages ...
(Reading database ... 311374 files and directories currently installed.)
Preparing to unpack .../libapt-pkg4.12_1.0.1ubuntu2.17_amd64.deb ...
Unpacking libapt-pkg4.12:amd64 (1.0.1ubuntu2.17) over (1.0.1ubuntu2.15) ...
Setting up libapt-pkg4.12:amd64 (1.0.1ubuntu2.17) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
(Reading database ... 311374 files and directories currently installed.)
Preparing to unpack .../apt_1.0.1ubuntu2.17_amd64.deb ...
Unpacking apt (1.0.1ubuntu2.17) over (1.0.1ubuntu2.15) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up apt (1.0.1ubuntu2.17) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
(Reading database ... 311374 files and directories currently installed.)
Preparing to unpack .../libapt-inst1.5_1.0.1ubuntu2.17_amd64.deb ...
Unpacking libapt-inst1.5:amd64 (1.0.1ubuntu2.17) over (1.0.1ubuntu2.15) ...
Preparing to unpack .../libwbclient0_2%3a4.3.11+dfsg-0ubuntu0.14.04.3_amd64.deb ...
Unpacking libwbclient0:amd64 (2:4.3.11+dfsg-0ubuntu0.14.04.3) over (2:4.3.11+dfsg-0ubuntu0.14.04.1) ...
Preparing to unpack .../python-samba_2%3a4.3.11+dfsg-0ubuntu0.14.04.3_amd64.deb ...
Unpacking python-samba (2:4.3.11+dfsg-0ubuntu0.14.04.3) over (2:4.3.11+dfsg-0ubuntu0.14.04.1) ...
Preparing to unpack .../samba-common-bin_2%3a4.3.11+dfsg-0ubuntu0.14.04.3_amd64.deb ...
Unpacking samba-common-bin (2:4.3.11+dfsg-0ubuntu0.14.04.3) over (2:4.3.11+dfsg-0ubuntu0.14.04.1) ...
Preparing to unpack .../smbclient_2%3a4.3.11+dfsg-0ubuntu0.14.04.3_amd64.deb ...
Unpacking smbclient (2:4.3.11+dfsg-0ubuntu0.14.04.3) over (2:4.3.11+dfsg-0ubuntu0.14.04.1) ...
Preparing to unpack .../libsmbclient_2%3a4.3.11+dfsg-0ubuntu0.14.04.3_amd64.deb ...
Unpacking libsmbclient:amd64 (2:4.3.11+dfsg-0ubuntu0.14.04.3) over (2:4.3.11+dfsg-0ubuntu0.14.04.1) ...
Preparing to unpack .../samba-libs_2%3a4.3.11+dfsg-0ubuntu0.14.04.3_amd64.deb ...
Unpacking samba-libs:amd64 (2:4.3.11+dfsg-0ubuntu0.14.04.3) over (2:4.3.11+dfsg-0ubuntu0.14.04.1) ...
Preparing to unpack .../samba-common_2%3a4.3.11+dfsg-0ubuntu0.14.04.3_all.deb ...
Unpacking samba-common (2:4.3.11+dfsg-0ubuntu0.14.04.3) over (2:4.3.11+dfsg-0ubuntu0.14.04.1) ...
Preparing to unpack .../apt-utils_1.0.1ubuntu2.17_amd64.deb ...
Unpacking apt-utils (1.0.1ubuntu2.17) over (1.0.1ubuntu2.15) ...
Preparing to unpack .../apt-transport-https_1.0.1ubuntu2.17_amd64.deb ...
Unpacking apt-transport-https (1.0.1ubuntu2.17) over (1.0.1ubuntu2.15) ...
Preparing to unpack .../firefox_50.1.0+build2-0ubuntu0.14.04.1_amd64.deb ...
Unpacking firefox (50.1.0+build2-0ubuntu0.14.04.1) over (50.0.2+build1-0ubuntu0.14.04.1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Setting up atom (1.12.7-1~webupd8~0) ...
tar: atom*.tar.xz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
dpkg: error processing package atom (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up libapt-inst1.5:amd64 (1.0.1ubuntu2.17) ...
Setting up libwbclient0:amd64 (2:4.3.11+dfsg-0ubuntu0.14.04.3) ...
Setting up samba-libs:amd64 (2:4.3.11+dfsg-0ubuntu0.14.04.3) ...
Setting up python-samba (2:4.3.11+dfsg-0ubuntu0.14.04.3) ...
Setting up samba-common (2:4.3.11+dfsg-0ubuntu0.14.04.3) ...
Setting up samba-common-bin (2:4.3.11+dfsg-0ubuntu0.14.04.3) ...
Setting up libsmbclient:amd64 (2:4.3.11+dfsg-0ubuntu0.14.04.3) ...
Setting up smbclient (2:4.3.11+dfsg-0ubuntu0.14.04.3) ...
Setting up apt-utils (1.0.1ubuntu2.17) ...
Setting up apt-transport-https (1.0.1ubuntu2.17) ...
Setting up firefox (50.1.0+build2-0ubuntu0.14.04.1) ...
Please restart all running instances of firefox, or you will experience problems.
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
Errors were encountered while processing:
 atom
E: Sub-process /usr/bin/dpkg returned an error code (1)
administrator@testanalyst:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;

/etc/apt/sources.list.d/webupd8team-atom-trusty.list

     1 deb http://ppa.launchpad.net/webupd8team/atom/ubuntu trusty main
     2 # deb-src http://ppa.launchpad.net/webupd8team/atom/ubuntu trusty main

/etc/apt/sources.list

     1 #
     2
     3 # deb cdrom:[Ubuntu-Server 14.04.4 LTS _Trusty Tahr_ - Release amd64 (20160217.1)]/ trusty main restricted
     4
     5 # deb cdrom:[Ubuntu-Server 14.04.4 LTS _Trusty Tahr_ - Release amd64 (20160217.1)]/ trusty main restricted
     6
     7 # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     8 # newer versions of the distribution.
     9 deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
    10 deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
    11
    12 ## Major bug fix updates produced after the final release of the
    13 ## distribution.
    14 deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
    15 deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
    16
    17 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    18 ## team. Also, please note that software in universe WILL NOT receive any
    19 ## review or updates from the Ubuntu security team.
    20 deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
    21 deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
    22 deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
    23 deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
    24
    25 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    26 ## team, and may not be under a free licence. Please satisfy yourself as to
    27 ## your rights to use the software. Also, please note that software in
    28 ## multiverse WILL NOT receive any review or updates from the Ubuntu
    29 ## security team.
    30 deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
    31 deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
    32 deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
    33 deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
    34
    35 ## N.B. software from this repository may not have been tested as
    36 ## extensively as that contained in the main release, although it includes
    37 ## newer versions of some applications which may provide useful features.
    38 ## Also, please note that software in backports WILL NOT receive any review
    39 ## or updates from the Ubuntu security team.
    40
    41 deb http://security.ubuntu.com/ubuntu trusty-security main restricted
    42 deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
    43 deb http://security.ubuntu.com/ubuntu trusty-security universe
    44 deb-src http://security.ubuntu.com/ubuntu trusty-security universe
    45 deb http://security.ubuntu.com/ubuntu trusty-security multiverse
    46 deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse
    47
    48 ## Uncomment the following two lines to add software from Canonical's
    49 ## 'partner' repository.
    50 ## This software is not part of Ubuntu, but is offered by Canonical and the
    51 ## respective vendors as a service to Ubuntu users.
    52 # deb http://archive.canonical.com/ubuntu trusty partner
    53 # deb-src http://archive.canonical.com/ubuntu trusty partner
    54
    55 ## Uncomment the following two lines to add software from Ubuntu's
    56 ## 'extras' repository.
    57 ## This software is not part of Ubuntu, but is offered by third-party
    58 ## developers who want to ship their latest software.
    59 # deb http://extras.ubuntu.com/ubuntu trusty main
    60 # deb-src http://extras.ubuntu.com/ubuntu trusty main
administrator@testanalyst:~$ sudo dpkg --audit
The following packages are only half configured, probably due to problems
configuring them the first time. The configuration should be retried using
dpkg --configure <package> or the configure menu option in dselect:
 atom Atom text editor from GitHub

administrator@testanalyst:~$

Appears the problem may be with the Atom install although it runs fine and got updated with the last Software Updater install.
What do I need to fix, or uninstall and re-install Atom?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2016-12-14
Last query:
2016-12-14
Last reply:
2016-12-14
Manfred Hampl (m-hampl) said : #1

I suggest either trying a reinstall of atom, or try removing that package

What output do you get for the commands

apt-cache policy atom
sudo apt-get install --reinstall atom

That package seems to come from a PPA. I suggest that you contact the provider of that PPA if the attempt to reinstall fails.

Setting up atom (1.12.7-1~webupd8~0) ...
tar: atom*.tar.xz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
dpkg: error processing package atom (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 atom

Standard PPA issues

Mark Jackson (secwizzard) said : #3

Fixed by reinstalling atom using
$sudo apt-get install --reinstall atom
(and verifying /etc/apt/sources.list.d/ contents).

M