Unabale to fix 'held broken packages'?

Asked by Taren on 2016-03-25

I tried to compile a 32bit program and had a conflict when trying to install some the dependencies, namely libssl-dev:i386 and liblz02-dev:i386. The only way to fix that mess that I could figure out was sudo dpkg -r --force-depends which seemed to work.

A while later I wanted to update and apt-get listed a whole load of packages that were supposedly not needed anymore. I really didn't pay enough attention here and ran sudo apt-get autoremove. I mostly managed to fix this after I noticed that I needed and manually installed a whole bunch of them but manage to reinstall them by grabbing the packages out of the shell history.

Except that steam didn't want to install anymore:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 steam:i386 : Depends: libgl1-mesa-dri:i386 but it is not going to be installed
              Depends: libgl1-mesa-glx:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have tried pretty much everything that I could think of or find.but I am really not sure what the actual problem is.

Here is the output from https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure :

 taren@laptop  ~  >....
LANG=C;sudo apt-get clean

LANG=C;sudo apt-get autoclean

sudo dpkg --configure -a

sudo dpkg --clear-avail

LANG=C;sudo apt-get -f install

LANG=C;sudo apt-get --fix-missing install

LANG=C;sudo apt-get --purge autoremove

LANG=C;sudo apt-get --fix-missing update -o APT::Cache-Limit=100000000

LANG=C;sudo apt-get update -o APT::Cache-Limit=100000000 && sudo apt-get dist-upgrade

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;

sudo dpkg --audit
Support status summary of 'laptop':

You have 2147 packages (85.1%) supported until July 2016 (9m)

You have 33 packages (1.3%) that can not/no-longer be downloaded
You have 344 packages (13.6%) that are unsupported

Run with --show-unsupported, --show-supported or --show-all to see more details
cat: /etc/dpkg/dpkg.cfg.d/multiarch: No such file or directory
i386
[sudo] password for taren:

cat: /etc/apt/apt.conf: No such file or directory
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.10
DISTRIB_CODENAME=wily
DISTRIB_DESCRIPTION="Ubuntu 15.10"
Linux laptop 4.2.0-34-generic #39-Ubuntu SMP Thu Mar 10 22:13:01 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
cp: cannot stat ‘/var/lib/dpkg/available-old’: No such file or directory
zsh: no matches found: /var/lib/dpkg/updates/*
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Get:1 http://archive.ubuntu.com wily InRelease [218 kB]
Get:2 http://archive.ubuntu.com wily-updates InRelease [65.9 kB]
Get:3 http://archive.ubuntu.com wily-backports InRelease [65.9 kB]
Get:4 http://archive.ubuntu.com wily-security InRelease [65.9 kB]
Get:5 http://archive.ubuntu.com wily/main Sources [1118 kB]
Get:6 http://archive.ubuntu.com wily/restricted Sources [7181 B]
Get:7 http://archive.ubuntu.com wily/universe Sources [7238 kB]
Get:8 http://archive.ubuntu.com wily/multiverse Sources [178 kB]
Get:9 http://archive.ubuntu.com wily/main amd64 Packages [1420 kB]
Get:10 http://archive.ubuntu.com wily/restricted amd64 Packages [15.6 kB]
Get:11 http://archive.ubuntu.com wily/universe amd64 Packages [6704 kB]
Get:12 http://archive.ubuntu.com wily/multiverse amd64 Packages [138 kB]
Get:13 http://archive.ubuntu.com wily/main i386 Packages [1416 kB]
Get:14 http://archive.ubuntu.com wily/restricted i386 Packages [16.0 kB]
Get:15 http://archive.ubuntu.com wily/universe i386 Packages [6701 kB]
Get:16 http://archive.ubuntu.com wily/multiverse i386 Packages [139 kB]
Get:17 http://archive.ubuntu.com wily/main Translation-en [839 kB]
Get:18 http://archive.ubuntu.com wily/multiverse Translation-en [107 kB]
Get:19 http://archive.ubuntu.com wily/restricted Translation-en [4296 B]
Get:20 http://archive.ubuntu.com wily/universe Translation-en [4579 kB]
Get:21 http://archive.ubuntu.com wily-updates/main Sources [71.0 kB]
Get:22 http://archive.ubuntu.com wily-updates/restricted Sources [3741 B]
Get:23 http://archive.ubuntu.com wily-updates/universe Sources [21.1 kB]
Get:24 http://archive.ubuntu.com wily-updates/multiverse Sources [3199 B]
Get:25 http://archive.ubuntu.com wily-updates/main amd64 Packages [202 kB]
Get:26 http://archive.ubuntu.com wily-updates/restricted amd64 Packages [13.3 kB]
Get:27 http://archive.ubuntu.com wily-updates/universe amd64 Packages [88.1 kB]
Get:28 http://archive.ubuntu.com wily-updates/multiverse amd64 Packages [6247 B]
Get:29 http://archive.ubuntu.com wily-updates/main i386 Packages [199 kB]
Get:30 http://archive.ubuntu.com wily-updates/restricted i386 Packages [13.4 kB]
Get:31 http://archive.ubuntu.com wily-updates/universe i386 Packages [85.6 kB]
Get:32 http://archive.ubuntu.com wily-updates/multiverse i386 Packages [6678 B]
Get:33 http://archive.ubuntu.com wily-updates/main Translation-en [92.7 kB]
Get:34 http://archive.ubuntu.com wily-updates/multiverse Translation-en [3156 B]
Get:35 http://archive.ubuntu.com wily-updates/restricted Translation-en [3024 B]
Get:36 http://archive.ubuntu.com wily-updates/universe Translation-en [51.5 kB]
Get:37 http://archive.ubuntu.com wily-backports/main Sources [760 B]
Get:38 http://archive.ubuntu.com wily-backports/restricted Sources [28 B]
Get:39 http://archive.ubuntu.com wily-backports/universe Sources [2257 B]
Get:40 http://archive.ubuntu.com wily-backports/multiverse Sources [28 B]
Get:41 http://archive.ubuntu.com wily-backports/main amd64 Packages [615 B]
Get:42 http://archive.ubuntu.com wily-backports/restricted amd64 Packages [28 B]
Get:43 http://archive.ubuntu.com wily-backports/universe amd64 Packages [2006 B]
Get:44 http://archive.ubuntu.com wily-backports/multiverse amd64 Packages [28 B]
Get:45 http://archive.ubuntu.com wily-backports/main i386 Packages [615 B]
Get:46 http://archive.ubuntu.com wily-backports/restricted i386 Packages [28 B]
Get:47 http://archive.ubuntu.com wily-backports/universe i386 Packages [1998 B]
Get:48 http://archive.ubuntu.com wily-backports/multiverse i386 Packages [28 B]
Get:49 http://archive.ubuntu.com wily-backports/main Translation-en [496 B]
Get:50 http://archive.ubuntu.com wily-backports/multiverse Translation-en [28 B]
Get:51 http://archive.ubuntu.com wily-backports/restricted Translation-en [28 B]
Get:52 http://archive.ubuntu.com wily-backports/universe Translation-en [1390 B]
Get:53 http://archive.ubuntu.com wily-security/main Sources [43.2 kB]
Get:54 http://archive.ubuntu.com wily-security/restricted Sources [2854 B]
Get:55 http://archive.ubuntu.com wily-security/universe Sources [10.8 kB]
Get:56 http://archive.ubuntu.com wily-security/multiverse Sources [2788 B]
Get:57 http://archive.ubuntu.com wily-security/main amd64 Packages [138 kB]
Get:58 http://archive.ubuntu.com wily-security/restricted amd64 Packages [10.9 kB]
Get:59 http://archive.ubuntu.com wily-security/universe amd64 Packages [49.8 kB]
Get:60 http://archive.ubuntu.com wily-security/multiverse amd64 Packages [6247 B]
Get:61 http://archive.ubuntu.com wily-security/main i386 Packages [135 kB]
Get:62 http://archive.ubuntu.com wily-security/restricted i386 Packages [10.8 kB]
Get:63 http://archive.ubuntu.com wily-security/universe i386 Packages [49.8 kB]
Get:64 http://archive.ubuntu.com wily-security/multiverse i386 Packages [6443 B]
Get:65 http://archive.ubuntu.com wily-security/main Translation-en [67.9 kB]
Get:66 http://archive.ubuntu.com wily-security/multiverse Translation-en [2806 B]
Get:67 http://archive.ubuntu.com wily-security/restricted Translation-en [2666 B]
Get:68 http://archive.ubuntu.com wily-security/universe Translation-en [32.6 kB]
Fetched 32.5 MB in 43s (741 kB/s)
Reading package lists... Done
Hit http://archive.ubuntu.com wily InRelease
Hit http://archive.ubuntu.com wily-updates InRelease
Hit http://archive.ubuntu.com wily-backports InRelease
Hit http://archive.ubuntu.com wily-security InRelease
Hit http://archive.ubuntu.com wily/main Sources
Hit http://archive.ubuntu.com wily/restricted Sources
Hit http://archive.ubuntu.com wily/universe Sources
Hit http://archive.ubuntu.com wily/multiverse Sources
Hit http://archive.ubuntu.com wily/main amd64 Packages
Hit http://archive.ubuntu.com wily/restricted amd64 Packages
Hit http://archive.ubuntu.com wily/universe amd64 Packages
Hit http://archive.ubuntu.com wily/multiverse amd64 Packages
Hit http://archive.ubuntu.com wily/main i386 Packages
Hit http://archive.ubuntu.com wily/restricted i386 Packages
Hit http://archive.ubuntu.com wily/universe i386 Packages
Hit http://archive.ubuntu.com wily/multiverse i386 Packages
Hit http://archive.ubuntu.com wily/main Translation-en
Hit http://archive.ubuntu.com wily/multiverse Translation-en
Hit http://archive.ubuntu.com wily/restricted Translation-en
Hit http://archive.ubuntu.com wily/universe Translation-en
Hit http://archive.ubuntu.com wily-updates/main Sources
Hit http://archive.ubuntu.com wily-updates/restricted Sources
Hit http://archive.ubuntu.com wily-updates/universe Sources
Hit http://archive.ubuntu.com wily-updates/multiverse Sources
Hit http://archive.ubuntu.com wily-updates/main amd64 Packages
Hit http://archive.ubuntu.com wily-updates/restricted amd64 Packages
Hit http://archive.ubuntu.com wily-updates/universe amd64 Packages
Hit http://archive.ubuntu.com wily-updates/multiverse amd64 Packages
Hit http://archive.ubuntu.com wily-updates/main i386 Packages
Hit http://archive.ubuntu.com wily-updates/restricted i386 Packages
Hit http://archive.ubuntu.com wily-updates/universe i386 Packages
Hit http://archive.ubuntu.com wily-updates/multiverse i386 Packages
Hit http://archive.ubuntu.com wily-updates/main Translation-en
Hit http://archive.ubuntu.com wily-updates/multiverse Translation-en
Hit http://archive.ubuntu.com wily-updates/restricted Translation-en
Hit http://archive.ubuntu.com wily-updates/universe Translation-en
Hit http://archive.ubuntu.com wily-backports/main Sources
Hit http://archive.ubuntu.com wily-backports/restricted Sources
Hit http://archive.ubuntu.com wily-backports/universe Sources
Hit http://archive.ubuntu.com wily-backports/multiverse Sources
Hit http://archive.ubuntu.com wily-backports/main amd64 Packages
Hit http://archive.ubuntu.com wily-backports/restricted amd64 Packages
Hit http://archive.ubuntu.com wily-backports/universe amd64 Packages
Hit http://archive.ubuntu.com wily-backports/multiverse amd64 Packages
Hit http://archive.ubuntu.com wily-backports/main i386 Packages
Hit http://archive.ubuntu.com wily-backports/restricted i386 Packages
Hit http://archive.ubuntu.com wily-backports/universe i386 Packages
Hit http://archive.ubuntu.com wily-backports/multiverse i386 Packages
Hit http://archive.ubuntu.com wily-backports/main Translation-en
Hit http://archive.ubuntu.com wily-backports/multiverse Translation-en
Hit http://archive.ubuntu.com wily-backports/restricted Translation-en
Hit http://archive.ubuntu.com wily-backports/universe Translation-en
Hit http://archive.ubuntu.com wily-security/main Sources
Hit http://archive.ubuntu.com wily-security/restricted Sources
Hit http://archive.ubuntu.com wily-security/universe Sources
Hit http://archive.ubuntu.com wily-security/multiverse Sources
Hit http://archive.ubuntu.com wily-security/main amd64 Packages
Hit http://archive.ubuntu.com wily-security/restricted amd64 Packages
Hit http://archive.ubuntu.com wily-security/universe amd64 Packages
Hit http://archive.ubuntu.com wily-security/multiverse amd64 Packages
Hit http://archive.ubuntu.com wily-security/main i386 Packages
Hit http://archive.ubuntu.com wily-security/restricted i386 Packages
Hit http://archive.ubuntu.com wily-security/universe i386 Packages
Hit http://archive.ubuntu.com wily-security/multiverse i386 Packages
Hit http://archive.ubuntu.com wily-security/main Translation-en
Hit http://archive.ubuntu.com wily-security/multiverse Translation-en
Hit http://archive.ubuntu.com wily-security/restricted Translation-en
Hit http://archive.ubuntu.com wily-security/universe Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

/etc/apt/sources.list

     1 # deb cdrom:[Ubuntu 15.04 _Vivid Vervet_ - Release amd64 (20150422)]/ trusty contrib main non-free
     2
     3 # deb cdrom:[Ubuntu 15.04 _Vivid Vervet_ - Release amd64 (20150422)]/ vivid main restricted
     4
     5 # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     6 # newer versions of the distribution.
     7 deb http://archive.ubuntu.com/ubuntu wily main restricted
     8 deb-src http://archive.ubuntu.com/ubuntu wily main restricted
     9
    10 ## Major bug fix updates produced after the final release of the
    11 ## distribution.
    12 deb http://archive.ubuntu.com/ubuntu wily-updates main restricted
    13 deb-src http://archive.ubuntu.com/ubuntu wily-updates main restricted
    14
    15 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    16 ## team. Also, please note that software in universe WILL NOT receive any
    17 ## review or updates from the Ubuntu security team.
    18 deb http://archive.ubuntu.com/ubuntu wily universe
    19 deb-src http://archive.ubuntu.com/ubuntu wily universe
    20 deb http://archive.ubuntu.com/ubuntu wily-updates universe
    21 deb-src http://archive.ubuntu.com/ubuntu wily-updates universe
    22
    23 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    24 ## team, and may not be under a free licence. Please satisfy yourself as to
    25 ## your rights to use the software. Also, please note that software in
    26 ## multiverse WILL NOT receive any review or updates from the Ubuntu
    27 ## security team.
    28 deb http://archive.ubuntu.com/ubuntu wily multiverse
    29 deb-src http://archive.ubuntu.com/ubuntu wily multiverse
    30 deb http://archive.ubuntu.com/ubuntu wily-updates multiverse
    31 deb-src http://archive.ubuntu.com/ubuntu wily-updates multiverse
    32
    33 ## N.B. software from this repository may not have been tested as
    34 ## extensively as that contained in the main release, although it includes
    35 ## newer versions of some applications which may provide useful features.
    36 ## Also, please note that software in backports WILL NOT receive any review
    37 ## or updates from the Ubuntu security team.
    38 deb http://archive.ubuntu.com/ubuntu wily-backports main restricted universe multiverse
    39 deb-src http://archive.ubuntu.com/ubuntu wily-backports main restricted universe multiverse
    40
    41 deb http://archive.ubuntu.com/ubuntu wily-security main restricted
    42 deb-src http://archive.ubuntu.com/ubuntu wily-security main restricted
    43 deb http://archive.ubuntu.com/ubuntu wily-security universe
    44 deb-src http://archive.ubuntu.com/ubuntu wily-security universe
    45 deb http://archive.ubuntu.com/ubuntu wily-security multiverse
    46 deb-src http://archive.ubuntu.com/ubuntu wily-security multiverse
    47
    48 ## Uncomment the following two lines to add software from Canonical's
    49 ## 'partner' repository.
    50 ## This software is not part of Ubuntu, but is offered by Canonical and the
    51 ## respective vendors as a service to Ubuntu users.
    52 # deb http://archive.canonical.com/ubuntu vivid partner
    53 # deb-src http://archive.canonical.com/ubuntu vivid partner

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Solved by:
Taren
Solved:
2016-03-30
Last query:
2016-03-30
Last reply:
2016-03-26
Manfred Hampl (m-hampl) said : #1

What is the output of the commands

apt-get --simulate install steam:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

apt-cache policy libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libgl1-mesa-dri libgl1-mesa-glx

Taren (ersetzen) said : #2

Hey, sorry for the late answer. I figured out that I somehow managed to install a i386 version on top of another version which somehow broke everything. Since I had home on a separate partition anyway I just saved the list of manually installed packages into a text file and reinstalled ubuntu because I needed the laptop for work.

Thanks for the support!