help how fix all these error

Asked by Muhammad Khurrum Butt on 2010-08-17

sudo apt-get update
Get:1 http://archive.canonical.com lucid Release.gpg [189B]
Ign http://archive.canonical.com/ubuntu/ lucid/partner Translation-en_US
Hit http://archive.canonical.com lucid Release
Err http://archive.canonical.com lucid Release

Ign http://ppa.launchpad.net lucid Release.gpg
Ign http://ppa.launchpad.net/user/ppa-name/ubuntu/ lucid/main Translation-en_US
Ign http://ppa.launchpad.net lucid Release
Ign http://ppa.launchpad.net lucid/main Packages
Ign http://ppa.launchpad.net lucid/main Packages
Err http://ppa.launchpad.net lucid/main Packages
  404 Not Found
Hit http://archive.ubuntu.com lucid Release.gpg
Ign http://archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
Get:2 http://archive.ubuntu.com lucid-updates Release.gpg [189B]
Ign http://archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_US
Get:3 http://archive.ubuntu.com lucid-security Release.gpg [189B]
Ign http://archive.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
Get:4 http://archive.ubuntu.com lucid-proposed Release.gpg [189B]
Ign http://archive.ubuntu.com/ubuntu/ lucid-proposed/restricted Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-proposed/main Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-proposed/multiverse Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-proposed/universe Translation-en_US
Get:5 http://archive.ubuntu.com lucid-backports Release.gpg [189B]
Ign http://archive.ubuntu.com/ubuntu/ lucid-backports/restricted Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-backports/main Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-backports/multiverse Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ lucid-backports/universe Translation-en_US
Hit http://archive.ubuntu.com lucid Release
Get:6 http://archive.ubuntu.com lucid-updates Release [44.7kB]
Err http://archive.ubuntu.com lucid-updates Release

Get:7 http://archive.ubuntu.com lucid-security Release [38.5kB]
Err http://archive.ubuntu.com lucid-security Release

Get:8 http://archive.ubuntu.com lucid-proposed Release [38.5kB]
Ign http://archive.ubuntu.com lucid-proposed Release
Get:9 http://archive.ubuntu.com lucid-backports Release [32.5kB]
Hit http://archive.ubuntu.com lucid/main Packages
Hit http://archive.ubuntu.com lucid/restricted Packages
Hit http://archive.ubuntu.com lucid/main Sources
Hit http://archive.ubuntu.com lucid/restricted Sources
Hit http://archive.ubuntu.com lucid/universe Packages
Hit http://archive.ubuntu.com lucid/universe Sources
Hit http://archive.ubuntu.com lucid/multiverse Packages
Hit http://archive.ubuntu.com lucid/multiverse Sources
Get:10 http://archive.ubuntu.com lucid-proposed/restricted Packages [14B]
Get:11 http://archive.ubuntu.com lucid-proposed/main Packages [24.1kB]
Hit http://archive.ubuntu.com lucid-proposed/multiverse Packages
Get:12 http://archive.ubuntu.com lucid-proposed/universe Packages [20.6kB]
Hit http://archive.ubuntu.com lucid-backports/restricted Packages
Hit http://archive.ubuntu.com lucid-backports/main Packages
Hit http://archive.ubuntu.com lucid-backports/multiverse Packages
Get:13 http://archive.ubuntu.com lucid-backports/universe Packages [24.3kB]
Fetched 179kB in 38s (4,622B/s)
Reading package lists... Done
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://archive.canonical.com lucid Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <email address hidden>

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://archive.ubuntu.com lucid-updates Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <email address hidden>

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://archive.ubuntu.com lucid-security Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <email address hidden>

W: GPG error: http://archive.ubuntu.com lucid-proposed Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <email address hidden>
W: Failed to fetch http://archive.canonical.com/ubuntu/dists/lucid/Release

W: Failed to fetch http://ppa.launchpad.net/user/ppa-name/ubuntu/dists/lucid/main/binary-i386/Packages.gz 404 Not Found

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/lucid-updates/Release

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/lucid-security/Release

W: Some index files failed to download, they have been ignored, or old ones used instead.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Last query:
2010-08-17
Last reply:
2010-08-17

gpg --keyserver wwwkeys.eu.pgp.net --recv-keys 40976EAF437D05B5; gpg --armor --export 40976EAF437D05B5 | sudo apt-key add -

Should do it. Please remember to add keys if you are adding 3rd party repos, or you will get this.

Can you help with this problem?

Provide an answer of your own, or ask Muhammad Khurrum Butt for more information if necessary.

To post a message you must log in.