Viewing web server from external pcs

Asked by john makras on 2010-07-06

We have setup a website on our ubuntu 10 system and can vie it using our internal 192.168.0.2 address . We have setup our router to forward all http requests for port 80 to forward to our webserver on 192.168.0.2 but when we try and browse to our web server using our external ip address 58.198.xxx.xxx we can't connect to it it times out. We have also setup a A name record that forwards to our external ip address. Can anybody help solve this.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apache2 Edit question
Assignee:
No assignee Edit question
Last query:
2010-07-07
Last reply:
2010-07-08
arjun (arjunak01) said : #1

have you checked your firewall settings

john makras (jmakras) said : #2

It seems to allow all but not sure

john makras (jmakras) said : #3

We are using ubuntu server 10.0.4 - what should the firewall settings be?

Check the forwarding. Reboot the roter to ensure the forward is present. Also set the server to a static ip so that dhcp ip changes don't break the link. Also reboot the server. It can help.

john makras (jmakras) said : #5

have done all tha has been suggested but still have the same issue - we also checked to see whether our port 80 on our ubuntu server is open and it is. It seems like we need to setup something on the ubuntu server that routes HTTP requests to 192.168.0.2 where our website is located.

john makras (jmakras) said : #6

just checked with our ISP and no ports are blocked- they can see our server using our ANAME recored and our external Ip address 58.xxx.xxx.xxx. We cant resolve our external ip address and ANAME record within our local network???

Is apache2 bound to 58.198.xxx.xxx?

john makras (jmakras) said : #8

I don't think so - how do we do that in apache

Regards,

John Makras
Informatix Pty. Ltd.
Level 7 / 131 Wickham Terrace Spring Hill QLD 4000 Australia
P 07 3831 0033
M 0414 781 058
F 07 3102 6182
<email address hidden> www.informatix.com.au | www.emailer.net.au | www.isurveys.com.au

On 08/07/2010, at 4:52 AM, io <email address hidden> wrote:

> Your question #116815 on apache2 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/apache2/+question/116815
>
> Status: Open => Answered
>
> io proposed the following answer:
> Is apache2 bound to 58.198.xxx.xxx?
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+source/apache2/+question/116815/+confirm?answer_id=6
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/apache2/+question/116815
>
> You received this question notification because you are a direct
> subscriber of the question.

Please check the following two files to make sure that apache2 is binding on 58.198.xxx.xxx.

/etc/apache2/ports.conf

NameVirtualHost 58.198.xxx.xxx:80
Listen 80

/etc/apache2/sites-enabled/<domain>

<VirtualHost 58.198.xxx.xxx:80>

Can you help with this problem?

Provide an answer of your own, or ask john makras for more information if necessary.

To post a message you must log in.