No Audio on Amarok - Ubuntu & Kubuntu

Asked by Gene Rodgers on 2009-11-23

I run Ubuntu 9.10 with Gnome and face the same issue with Amaroc. However, when starting Amaroc which is principally ok, I get the failure message "Phonon KDE's Multimedia Library - The audio playback device HDA NVidia (ALC1200 Analog) does not work. Falling back to default". Even under default or any other alternative: NO SOUND. I also tried the ...sudo apt-get ... before and that installation worked.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu amarok Edit question
Assignee:
No assignee Edit question
Last query:
2009-12-19
Last reply:
2010-01-18
Don Forigua (ingforigua) said : #1

Try to install all codecs:

sudo apt-get install kubuntu-restricted-extras

Gene Rodgers (w5ffa) said : #2

What application do I use for this command below? Console? I'm new to
Kunbutu/Ubuntu and don't know all the processes.

Sudo apt-get install kubuntu-restricted-extras

Gene - w5ffa
-------Original Message-------

From: Ing. Forigua
Date: 11/23/2009 12:53:44 PM
To: <email address hidden>
Subject: Re: [Question #91403]: No Audio on Amarok - Ubuntu & Kubuntu

Your question #91403 on amarok in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/amarok/+question/91403

    Status: Open => Answered

Ing. Forigua proposed the following answer:
Try to install all codecs:

sudo apt-get install kubuntu-restricted-extras

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad
net/ubuntu/+source/amarok/+question/91403/+confirm?answer_id=0

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/amarok/+question/91403

You received this question notification because you are a direct
subscriber of the question.

____________________________________________________________

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.425 / Virus Database: 270.14.78/2521 - Release Date: 11/23/09
07:52:00

Gene Rodgers (w5ffa) said : #3

I used the sudo apt-get install kubuntu-restricted-extras as directed. It went thru install and when finished I restarted the computer and Amarok is still silent. It shows the stream feed and what is playing, but NO SOUND.

Myriam Schweingruber (myriam) said : #4

Hi Gene,

a few question first:

do you use the KDE or the Gnome desktop?

In the case of KDE, you need to make sure you have the xine backend selected: in the system settings -> Multimedia -> backend tab.

In the case you use Gnome, please go in the Amarok Settings menu -> Configure Amarok -> Playback -> Sound configuration. Click on that button to access the multimedia settings.

Adam Zovits (zovits) said : #5

I'm having the same issue (at least I think it is the same) using Amarok with Gnome on Jaunty.
So Amarok loads just fine, but can not start any music files. No sound, no timeline, no on screen displays.
I've tried accessing the settings, but Settings->Configure->Playback only contains settings for fadeout and playback resuming.

I've got the same issue. I can play every sound file in any player except in Amarok.

I installed amarok by "apt-get install amarok"

2.6.31-16-generic #53-Ubuntu SMP x86_64 GNU/Linux

 - Jo

Myriam Schweingruber (myriam) said : #7

@Adam, please read again what I wrote and check what you see on your screen: once you are in the

Settings menu -> Configure Amarok... -> Playback

there is a "Sound configuration" button. Just click on that.

@Johannes, please read my post from December 3rd.

Gene Rodgers (w5ffa) said : #8

In regards to the thread on Amarok - regardless of what I tried, and I tried them all, there was NO AUDIO in Amarok. I went thru the setup and could get a test sample in the setup, but no audio when trying to play music or radio streams. it would show the station playing and what was playing , but NO AUDIO. I've installed all gstreams and codecs from all sources including Medibuntu with no solution to the problem. I found that by installing Xubuntu 8.04.1 then upgrading till I reached. 9.04. Amarok would work with the upgrade to 9.10, however there were other problems, such as no button to shutdown. I stopped at Xubuntu 9.04 and have a good distribution. Hope someone can use this information, although it isn't much help.

@Myriam Schweingruber, I allready tried every solution in this thread. So yes, I've read your post, and no it doesn't change anything.

 - Jo

I run Ubuntu 9.10 with Gnome and face the same issue with Amaroc. However, when starting Amaroc which is principally ok, I get the failure message "Phonon KDE's Multimedia Library - The audio playback device HDA NVidia (ALC1200 Analog) does not work. Falling back to default". Even under default or any other alternative: NO SOUND. I also tried the ...sudo apt-get ... before and that installation worked.

Myriam Schweingruber (myriam) said : #11

Christoph, why did you change that question?
Now this "Answers" entry has become pretty useless since the original question is gone :(

To answer your question: this has absolutely *nothing* to do with Amarok, it is a Pulseaudio issue, please ask there, I can't tell you how to change that on Gnome since I use only KDE.
Amarok doesn't handle sound, it let's Phonon do so, and when using the phonon-backend-xine with pulseaudio it can lead to this behavior.

kalosz (miszczkalosz) said : #12

Hey,
I just had the same problem. And i solved it just by installing by myself phonon-backend-xine.
Write sudo apt-get install phonon-backend-xine in the terminal and voila, you will have sound in Amarok. Worked for me.
P.S. I've installed kubuntu packages.

Cheers,
Kalosz

Can you help with this problem?

Provide an answer of your own, or ask Gene Rodgers for more information if necessary.

To post a message you must log in.